-   Linux - Networking (
-   -   eth0 NIC Card Not Working! 3com 3c501 NIC. (

Mustard010 11-09-2003 07:50 PM

eth0 NIC Card Not Working! 3com 3c501 NIC.

I just installed Red Hat 9.0 with (2) CD's that came with the Red Hat 9.0 Dummies Book. Unfourtunately, this wasn't info included inside the book, but I tweaked around search engines to find answers...(none) please, i am asking you guys.

I went to the Network Configurtion, and I figured out these:

eth0 - 3com 3c501

It's status was inactive!

Now, I learned some tricks from some source, I tried:

/etc/init.d/network start

This is the output:

/etc/init.d/network start
Setting Network Parameters: [OK]
Bringing Up Loopback Interface: [OK]
Bringing Up Interface eth0: 3c501 device eth0 does not seem to be present, delating initialization. [FAILED]

Bad huh?

Another command I used is insmod 3c501...(no clue what this did)


Using: /lib/modules/2.4.20-6/kernel/drivers/net/3c501.o
/lib/modules/2.4.20-6/kernel/drivers/net/3c501.o Input/Output Error

Hint: insmod errors can be caused by incorrect module parameters, including invalied IO or IRQ paramters. You may find some information in syslog or the output from dmesg.

I have no clue, what all this means, but I have (1) guess.

Updating 3c501 ... but where do I get a driver install for this?

I can easily burn the tar.gz easily in a CD, but where to find?

If I'm wrong, please don't hesitate to correct me! Thanks for your help!

arrruken 11-09-2003 08:20 PM

Are you sure thats the driver for your nic?
Did the ethernet card ever work, like when you booted off the cd?

I dont use red hat, so i dont know about the "network start" command you used. If insmod doesnt work, you can try "modprobe 3c501". If that doesnt work, either its the wrong module, your kernel doesnt support your card, or its a bad nic.
When you type "ifconfig -a", what does it display?
Please answer the first two questions in your response...

Fascistchicken 11-09-2003 08:22 PM

i think thats an old card, i have a 3c509 and i know its old its isa
i'm not sure but i would think that red hat must have support for that card
are you positive thats your ethernet card is a 3c501?
what kind of bus is it on?

Fascistchicken 11-09-2003 08:22 PM

deja vu

Mustard010 11-09-2003 09:43 PM

I have a Linksys 10/100 LAN Card, model no. LNE100TX ver. 5.1

In the system requirements: it says, any version of Windows. But, I'm positive that my brother's computer has the same card with RH 8.0. I'm not sure if that is my driver, due to the box or manual not giving any answers. Automatically, it chose 3c501. This card was bought almost six months ago! It is on a PCI bus.

I typed modeprobe 3c501, and it produced the same error as I stated in the first post. ifconfig -a produced teh following:

lo Link Encap: Local Loopback
inter addr: Mask:
UP Loopback Running MTR:16436 METRIC: 1
RX PACKETS: 2125 Errors: 0 dropped: 0 overruns:0 frame:0
TX Packets:2125 Errors:0 dropped: 0 overrims: 0 carrier: 0
Collisions: 0 txqueuelen:0
Rxbytes:144916(141.5KB) Tx bytes: H4916 (141.5kb)

Mustard010 11-10-2003 05:50 AM


GJB 11-10-2003 07:24 AM

From what i can see when looking at the latest downloadable driver this card is compatible with the tulip chipset, so you most probably have to insmod tulip


arrruken 11-10-2003 09:09 AM

yeah hes right, if you go on linksys's site, download the driver package for your card. it uses the tulip driver. the driver and instructions are in the package.

Mustard010 11-10-2003 12:03 PM

Ok thanks, but want simple problem.

I don't have internet to download the files, but I can d/l it from this computer and burn it into a cd . . . what is a command to copy from cd to harddrive?

Also, I'm just verifying if this is correct, I found this from linksys:

All of the setup instructions are contained in your Linux package. When you unpack your archive, look for a "how-to" document concerning the installation of PCMCIA cards. When you find the file, read it and follow the directions. You'll need to install the PCMCIA services, enable networking, and finally, recompile the kernel. After this point, the PC Card will be automatically recognized as soon as you plug it in. You must have version 2.9.10 of the Linux PCMCIA services or higher. You can ftp the latest version here

Judging by this, I just have to do those steps, now I just need that command

Thanks again!

Fascistchicken 11-10-2003 04:24 PM

to copy from cd justt mount the cd
mount /dev/cdrom /wherever
and cp /wherever/thething /tohere
as for pcmcia and all that do you have a pcmica card?
i thought it was pci?

Fascistchicken 11-10-2003 04:34 PM

why don't you try "modprobe tulip"

Mustard010 11-10-2003 08:31 PM

Fascistchicken, you are a LIFE SAVER!!!

This was the command I was looking for!!!

After I typed it in, I started /etc/init.d/network start, and IT WORKS!!!

Thanks a bunch, I owe ya one!

arrruken 11-10-2003 10:37 PM

i guess it already had tulip support eh?

Mustard, it would be a good idea to understand what you did and why it worked. It worked because your kernel had support for it, and you should look into learning how to recompile your kernel with support for specific modules. Just my two sense, it took me a while to learn about device drivers, modules, etc., but once you do, it will all seem so simple man...

faizan_agha 07-28-2007 03:43 AM

hi musturd..

i am having exactly the same problem. I went to linksys to download the driver but couldnt find one. Can you tell me the exact url please. I have sent you a private message aswell and i badly need your help in this matter.

anxiously waiting for your reply.

faizan_agha 07-28-2007 04:47 PM

can anyone else please help me out?

All times are GMT -5. The time now is 08:23 AM.