LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Networking (http://www.linuxquestions.org/questions/forumdisplay.php?f=3)
-   -   eth0 is ignoring me when I tell it "Activate at startup" (http://www.linuxquestions.org/questions/showthread.php?t=655650)

pentalive 07-14-2008 09:09 AM

eth0 is ignoring me when I tell it "Activate at startup"
 
Fedora 9 Installed from live CD.

I have set the "activate on startup" both in system-config-networks and in the network gui tool.

After any reboot eth0 is not present in ipconfig. I go into the gui tool and activate it.

This machine will be a server so it doesn't want to run the gui...

farslayer 07-14-2008 10:26 AM

could you post the output of..
cat /etc/sysconfig/network-scripts/ifcfg-eth0


Static IP address configuration:

Code:

    DEVICE=eth0
    BOOTPROTO=static
    TYPE=Ethernet
    HWADDR=XX:XX:XX:XX:XX:XX
    BROADCAST=XXX.XXX.XXX.255
    IPADDR=XXX.XXX.XXX.XXX
    NETMASK=255.255.255.0
    NETWORK=XXX.XXX.XXX.0
    GATEWAY=XXX.XXX.XXX.XXX
    ONBOOT=yes


pentalive 07-14-2008 11:22 AM

[QUOTE=farslayer;3214044]could you post the output of..
cat /etc/sysconfig/network-scripts/ifcfg-eth0

# Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:1e:90:94:0a:bc
ONBOOT=yes
DNS1=192.168.1.1
NM_CONTROLLED=yes
TYPE=Ethernet
DHCP_HOSTNAME=beehive
USERCTL=no
PEERDNS=yes
IPV6INIT=no
IPADDR=192.168.1.80
NETMASK=255.255.255.0
GATEWAY=192.168.1.1

colucix 07-14-2008 11:35 AM

Try to put NM_CONTROLLED=no. There are issues on Fedora 9, with Network Manager interfering with the activation of ethernet cards at startup. The above option tells that eth0 must not be controlled by Network Manager.

If you don't need Network Manager, e.g. if the server has a static IP address and wireless (or other devices) connectivity is not required, you can disable Network Manager and re-enable the old-fashioned network service.

pentalive 07-14-2008 12:26 PM

disabled network manager, no fix
 
Thanks - I am trying that now.

I think I turned on network manager when it wasn't working the first time.

Rebooting now....

nope - didn't work.

Should BootProto say somthing other than "none"

pentalive 07-14-2008 01:18 PM

I think I found it.

/etc/rc3.d does not have an S**network link in it. Fixed that, rebooted.. lookie my server has eth0!

Now on to apache and Samba!

This seems to be fixed.


All times are GMT -5. The time now is 04:41 AM.