LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-04-2016, 04:15 PM   #1
jmafc
LQ Newbie
 
Registered: Feb 2016
Posts: 16

Rep: Reputation: Disabled
eth0 inet static shutting down on LinuxMint Mate 17.3


I installed Mint 17.3 64bit on a new custom-built PC and configured eth0 to use a static IP address. Looking at dmesg right after boot shows the following

Code:
r8169 ... eth0: link up
IPv6: ADDRCONF(NETDEV_CHANGE): link becomes ready
However, when I try to ping the gateway (192.168.1.1) there is no response. If I do an ifdown followed by ifup the same messages show up in dmesg. Once (but only once) I got a response from the very first ping but the second one failed. It seems as if the interface is being shut down by some mysterious agent but leaving no record (some google results mention avahi--which I see running if I do an "ifup -v").

One thing that is different between Mint and my main Debian box is "ip route" shows a 169.254.0.0 entry after the default route and before the 192.168.1.0/24 entry. Some discussions in LQ describe how to remove the entry on Red Hat but on Mint there is no /etc/sysconfig/network (and I'm not sure if removing the ZEROCONF entry will resolve my problem).

Any suggestions?
 
Old 02-05-2016, 02:44 PM   #2
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,850

Rep: Reputation: 161Reputation: 161
What's route and ifconfig output?
 
Old 02-05-2016, 04:08 PM   #3
jmafc
LQ Newbie
 
Registered: Feb 2016
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by nini09 View Post
What's route and ifconfig output?
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 eth0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
partial transcription only
Code:
eth0:   Link encap:Ethernet  HWaddr: ...
        inet addr:192.168.1.4  Bcast: 192.168.1.255   Mask 255.255.255.0  
        inet6 addr: .../64    Scope:Link
        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
        RX/TX packets/bytes: [Non-zero values] errors/dropped/overruns: 0
 
Old 02-08-2016, 02:40 PM   #4
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,850

Rep: Reputation: 161Reputation: 161
If link-local entry in route table, Internet can't be access. The entry should be removed.
 
Old 02-08-2016, 04:00 PM   #5
jmafc
LQ Newbie
 
Registered: Feb 2016
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by nini09 View Post
If link-local entry in route table, Internet can't be access. The entry should be removed.
That is why I had questioned, near the end of my original query, about address 169.254.0.0 in the output of "ip route" (which I believe is the same as that "link-local"). As I mentioned earlier, the only discussions I was able to find gave instructions on removing link-local on Red Hat. What I need are instructions on how to remove the link-local entry on Mint or Ubuntu (also would be useful to know what is putting it there in the first place).
 
Old 02-09-2016, 02:45 PM   #6
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,850

Rep: Reputation: 161Reputation: 161
Zeroconf on Ubuntu or Mint has another name, Avahi. Following is instruction to disable it.

Quote:
Edit the Avahi daemon config file:

sudo vi /etc/init/avahi-daemon.conf

Search for the following lines, edit the line with start on and add never and:

-start on (filesystem and started dbus)
+start on (never and filesystem and started dbus)
stop on stopping dbus

One more thing to do in order to avoid the popup notice:
% sudo vi /etc/default/avahi-daemon
AVAHI_DAEMON_DETECT_LOCAL=0

To stop the daemon from the command line:

% sudo service avahi-daemon stop

And then, find out if it is really gone:

% ps -ef | grep -i [a]vahi

If you get no match, then it means that it is gone for good.
 
Old 02-14-2016, 12:41 PM   #7
jmafc
LQ Newbie
 
Registered: Feb 2016
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by nini09 View Post
Zeroconf on Ubuntu or Mint has another name, Avahi. Following is instruction to disable it.
Shutting down the avahi-daemon doesn't appear to have the desired effect. If I make the indicated change to /etc/init/avahi-daemon.conf and set AVAHI_DAEMON_DETECT_LOCAL to 0 in /etc/default/avahi-daemon, the daemon does not come up on reboot, but the kernel IP routing table still has that second entry for link-local. If I do an "ifdown eth0" followed by an "ifup -v eth0" I see two avahi scripts being executed, both in /etc/network/if-up.d/ : avahi-autoipd and avahi-daemon. The first one appears to be the one adding the 169.254.0.0 if it's not present. The second one runs /usr/lib/avahi/avahi-daemon-check-dns.sh and that checks the setting of AVAHI_DAEMON_DETECT_LOCAL and exits if it's not 1.

So the question appears to be how to stop avahi-autoipd from adding the link-local address in the first place.
 
Old 02-14-2016, 03:26 PM   #8
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,661

Rep: Reputation: Disabled
What does ethtool eth0 print?
 
Old 02-14-2016, 05:26 PM   #9
jmafc
LQ Newbie
 
Registered: Feb 2016
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
What does ethtool eth0 print?
I don't have an easy way to copy all the output of ethtool. Is there something in particular you'd be looking at? Let me try a few highlights:

Code:
Supported ports TP MII
Supported/advertised link modes: 10/100/1000Base half/full
Speed 100Mb/s
Duplex Full
Port MII
PHYAD 0
Auto-negotiaton: on
Current message level: 0x00000033
                       drv probe ifdown ifup
Link detected: yes
 
Old 02-14-2016, 05:30 PM   #10
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,661

Rep: Reputation: Disabled
I was wondering if there is actual handshake between your box and switch. You are getting 169.254 address, this indicates network is down.
 
Old 02-14-2016, 06:00 PM   #11
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,674

Rep: Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892
Quote:
Originally Posted by nini09 View Post
If link-local entry in route table, Internet can't be access. The entry should be removed.
Not necessarily. Below is my output (route -n) from my debian which is similar to the OP's output. The route with the lowest metric value is the default.

Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
Are you positive the router's address is 192.168.1.1? I would try disabling IPV6 to see if that fixes the problem.
How did you configure a static IP address? Via the network manager applet?
 
Old 02-14-2016, 06:10 PM   #12
jmafc
LQ Newbie
 
Registered: Feb 2016
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
I was wondering if there is actual handshake between your box and switch. You are getting 169.254 address, this indicates network is down.
The new box is on the same network as the one I'm writing this on. I can see the lights flickering on the new box and the router. Plus, at least once I was able to ping the hub.
 
Old 02-14-2016, 06:22 PM   #13
jmafc
LQ Newbie
 
Registered: Feb 2016
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
Not necessarily. Below is my output (route -n) from my debian which is similar to the OP's output. The route with the lowest metric value is the default.

Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
Are you positive the router's address is 192.168.1.1? I would try disabling IPV6 to see if that fixes the problem.
How did you configure a static IP address? Via the network manager applet?
On my debian box, from which I'm writing this and that is on the same network, route -n returns:

Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
I'm quite certain it's 192.168.1.1 (it's assigned by my ISP), since I was able to ping it once and I'm able to ping it from this other box. I had started configuring by editing /etc/network/interfaces but then I saw I got the same results via the network applet.
 
Old 02-14-2016, 06:30 PM   #14
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,661

Rep: Reputation: Disabled
OK, I still suspect your hardware (network cable perhaps). The speed from ethtool is 100 MB/s, is this your network speed? If it is not it may indicate intermittent connection.
 
Old 02-14-2016, 06:35 PM   #15
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,674

Rep: Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892
Assigned by your ISP? I assume your using a router provided by your ISP and 192.168.1.1 is its default LAN configuration? Make sure the Mint IP address is not within the DHCP server's range so the same address is not being used by two different devices.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to install DVDongle LinuxMint Mate 17.3 . Bump Linux Mint 3 02-22-2016 07:35 AM
my linuxmint-14.1-mate-dvd-32bit.iso file won't boot rolandl Linux - Newbie 3 04-13-2013 12:51 PM
Restarts after shutdown . linuxmint 13 mate dvd 64bit rmon Linux - Newbie 0 07-08-2012 10:47 PM
eth0 inet address not assigned at startup?? abolishtheun Slackware 2 04-30-2009 07:38 AM
inet<---eth1[LinuxBox_1]eth0<---e0[LinuxBox_2] : LinuxBox_2 hv no inet connection? Andrea_44 Linux - Networking 5 10-25-2006 08:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration