LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-14-2013, 09:09 AM   #1
biotric
LQ Newbie
 
Registered: Aug 2013
Location: Europe
Distribution: Debian wheezy
Posts: 2

Rep: Reputation: Disabled
eth0 Has No IP address/eth0 Not working.


Hello I'm slowly getting into networking and Linux and I was trying tcpdump out on Debian Wheezy.

I'm trying to run tcpdump and this is the output I get:

Code:
tcpdump
tcpdump: WARNING: eth0: no IPv4 address assigned
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
So I decided to check eth0 out

Code:
ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 08:9e:01:21:5b:2a  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:44
This is the full ifconfig:
Code:
eth0      Link encap:Ethernet  HWaddr 08:9e:01:21:5b:2a  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:44 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:279 errors:0 dropped:0 overruns:0 frame:0
          TX packets:279 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:9469 (9.2 KiB)  TX bytes:9469 (9.2 KiB)

wlan0     Link encap:Ethernet  HWaddr 08:3e:8e:65:20:35  
          inet addr:10.1.3.37  Bcast:10.1.255.255  Mask:255.255.0.0
          inet6 addr: fe80::a3e:8eff:fe65:2035/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9703 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10686 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5233812 (4.9 MiB)  TX bytes:1857593 (1.7 MiB)
I notice it has no IPV4 address assigned. So I have been searching around a bit and installed wicm instead of network-manager and still no luck. I have been trying to add an ip to eth0 manually but no luck either.

Is there any way to fix this?

Regards,

Biotric

Last edited by biotric; 08-14-2013 at 09:11 AM.
 
Old 08-14-2013, 12:52 PM   #2
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,278

Rep: Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694
Well,.. it looks to me like you are using a wireless connection, which is set up on wlan0.

If you plug an ethernet cable into the computer, then into a switch port, you will more than likely get an ip for eth0.
 
Old 08-14-2013, 01:49 PM   #3
biotric
LQ Newbie
 
Registered: Aug 2013
Location: Europe
Distribution: Debian wheezy
Posts: 2

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by szboardstretcher View Post
Well,.. it looks to me like you are using a wireless connection, which is set up on wlan0.

If you plug an ethernet cable into the computer, then into a switch port, you will more than likely get an ip for eth0.
Hi, thank you for responding!

This is true I can specificy an interface with the -i in tcpdump. But whenever I do

Code:
tcpdump -i wlan0
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on wlan0, link-type EN10MB (Ethernet), capture size 65535 bytes
It indeed works but only for my laptop, I have tried it with my mobile phone which is also connected to the wifi but it doesnt show the traffic of my mobile phone. I want to capture all the traffic that is currently on the LAN which can be done with eth0 (correct me if I am wrong.) And that's what I am trying to do.
 
Old 08-14-2013, 02:00 PM   #4
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,278

Rep: Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694Reputation: 1694
what are the interface names on your mobile phone?

ifconfig

are you running as root? tcpdump doesnt like to run as non-priv users.
 
Old 12-31-2015, 11:53 PM   #5
TheLinuxCake
Member
 
Registered: Dec 2015
Posts: 31
Blog Entries: 1

Rep: Reputation: Disabled
This may not be very timley but..

For the people like me who found this link from googling/people searching forums for answer to this, (as the user who created this thread probably has already found the solution), add -vv in as an option without anything after or stuff.
For example for clarification as i feel as i didn't make clear.. lel..

User@CompuerName$ sudo tcpdump -i wlan0 -vv -w /home/pcapstuff/
 
Old 01-01-2016, 12:22 AM   #6
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Hi...

Welcome to the forum

Also, please open a terminal and post the entire results of...

Code:
lspci -nnk | grep -i net -A2
No screenshots, please.

Regards...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
assigning range of ip address not working- ifcfg-eth0-range0 anjan_rs@hotmail.com Red Hat 4 09-08-2011 01:36 AM
beginning interface eth0 : device eth0 has different MAC address to expected.FAILED petrofrontier Linux - Software 2 02-28-2011 11:09 AM
eth0: Device eth0 has different MAC address than expected,ignoring. lin1010 Linux - Networking 5 11-24-2010 07:30 AM
[SOLVED] Trying to set an alt. ip address - eth0:1 just replaces eth0 instead ECRocker Linux - Newbie 1 10-30-2009 12:07 PM
eth0 and eth0:1. Default gateway is not working Fillys6 Linux - Networking 1 12-21-2005 09:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration