LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-25-2004, 10:37 PM   #1
mecister
LQ Newbie
 
Registered: Jun 2004
Location: Santiago, Chile
Distribution: Fedore Core 3
Posts: 14

Rep: Reputation: 0
Thumbs down eth0 & ppp0 seem to be OK, but adsl isn't working. help plz


Well, I just installed Debian, and I think my pppoe configuration was ok, because I seem to be connected , but still can't browse or anything.


This is my ifconfig :

eth0 Link encap:Ethernet HWaddr 00:07:95:EC:99:9E
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:64 errors:0 dropped:0 overruns:0 frame:0
TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:4394 (4.2 KiB) TX bytes:3329 (3.2 KiB)
Interrupt:10 Base address:0xde00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:3924 Metric:1
RX packets:87 errors:0 dropped:0 overruns:0 frame:0
TX packets:87 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5779 (5.6 KiB) TX bytes:5779 (5.6 KiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:200.90.206.68 P-t-P:192.168.10.14 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:40 errors:0 dropped:0 overruns:0 frame:0
TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:10
RX bytes:1408 (1.3 KiB) TX bytes:875 (875.0 b)

This is my route :

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.10.14 * 255.255.255.255 UH 0 0 0 ppp0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

And this is what I get when I run the plog command, here it shows some kind of problem i guess:

Jun 25 21:25:03 marmaduque pppd[18937]: not replacing existing default route to
eth0 [192.168.1.1]
Jun 25 21:25:03 marmaduque pppd[18937]: Cannot determine ethernet address for proxy ARP
Jun 25 21:25:03 marmaduque pppd[18937]: local IP address 200.42.188.230
Jun 25 21:25:03 marmaduque pppd[18937]: remote IP address 192.168.10.14
Jun 25 21:25:03 marmaduque pppd[18937]: primary DNS address 200.50.96.90
Jun 25 21:25:03 marmaduque pppd[18937]: secondary DNS address 200.54.144.227

Please help me Thanks !
 
Old 06-26-2004, 01:23 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Are those DNS addresses correct? What are the contents of your /etc/resolv.conf? How is the ADSL modem connected to its parent computer (USB or ethernet) and is the parent computer the computer you're using? You should not need a pppX interface. You'd need either an ethX or a pppoeX.
 
Old 06-26-2004, 02:47 AM   #3
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
are you able to ping to your gateway.

Try setting bootproto for eth0 to none; stop and start eth0.

Now run adsl-start and check whether you can ping/browse, etc.
 
Old 06-27-2004, 04:33 PM   #4
mecister
LQ Newbie
 
Registered: Jun 2004
Location: Santiago, Chile
Distribution: Fedore Core 3
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for the feedback guys.

Those DNS from resolv.conf seem to be correct, because they are the same I get when connected through Windows.
The router is connected through ethernet to my computer, which is for personal use, it's not connected to any other computer.

Indeed, I'm able to ping my gateway (I pinged every IP from eth0 and ppp0 just to be sure)

About what ppuru said, "setting bootproto for eth0 to none" ... could you be a little more explicit... I'm of the newbish kind

Well , thanks again.
 
Old 06-27-2004, 07:24 PM   #5
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
One question: Why do you have a ppp interface?

One thing I saw maybe you could change the mtu of you eth0 to 1492 by typing ifconfig eth0 mtu 1492.
 
Old 06-27-2004, 08:43 PM   #6
mecister
LQ Newbie
 
Registered: Jun 2004
Location: Santiago, Chile
Distribution: Fedore Core 3
Posts: 14

Original Poster
Rep: Reputation: 0
I changed mtu to 1492 but still nothing happened... thanks anyway.

Why do I have a ppp interface ? Well , not sure, I configured everything with pppoeconf and then I connect with "pon dsl-provider" (I don't have the adsl commands, don't know why).
The ppp0 shows my IP, so I'm guessing I'm connected.
Looking carefully, I noticed that the that ppp0 shows as mine (200.90.206.68), is quite different from the one i get connected through windows (200.42.188.224). I'm pretty lost now

Any idea on what's the meaning of this ? :

Jun 27 21:30:30 marmaduque pppd[662]: Connect: ppp0 <--> /dev/pts/1
Jun 27 21:30:31 marmaduque pppd[662]: Couldn't set pass-filter in kernel: Invalid argument
Jun 27 21:30:31 marmaduque pppd[662]: local IP address 200.90.206.60
Jun 27 21:30:31 marmaduque pppd[662]: remote IP address 192.168.10.14
Jun 27 21:30:31 marmaduque pppd[662]: primary DNS address 200.50.96.90
Jun 27 21:30:31 marmaduque pppd[662]: secondary DNS address 200.54.144.227
 
Old 06-27-2004, 09:59 PM   #7
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
the BOOTPROTO entry goes in ifcfg-eth0. I am not sure of the file's location in Debian ... should be somewhere in /etc.
 
Old 06-28-2004, 03:41 AM   #8
Freaky Dave
LQ Newbie
 
Registered: Jun 2004
Location: Prince George BC Ca
Distribution: Debian
Posts: 22

Rep: Reputation: 15
try to remove the ppp conection?
 
Old 06-28-2004, 07:17 PM   #9
mecister
LQ Newbie
 
Registered: Jun 2004
Location: Santiago, Chile
Distribution: Fedore Core 3
Posts: 14

Original Poster
Rep: Reputation: 0
Well, after trying almost everything, I downloaded rp-pppoe from roaring penguin , installed it, configured adsl again, did adsl-start, and I noticed this time my IP was correct, but the thing wasnt working, as usual.
This time though, I did ifconfig eth0 down, ifconfig eth0 up, adsl-stop and adsl-start, and voila! I'm connected through linux right now
Not sure why I have to do the steps mentioned above in order to have my connection working, but at least works perfect.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0+ppp0 routing kwlg Linux - Networking 5 07-18-2005 05:50 PM
ADSL-STATUS: linked to ppp0 but ppp0 seems to be down. mikkime23 Linux - Networking 1 01-01-2005 11:00 AM
Masquerading ppp0 and eth0 zulfilee Linux - Networking 2 07-20-2004 12:32 AM
ppp0 uses eth0... but eth0 never activates joshuapurcell Linux - Networking 3 12-17-2003 12:52 AM
eth0 and ppp0 fight motyl Linux - Networking 3 05-23-2003 04:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration