Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 09-06-2001, 02:32 PM   #1
LQ Newbie
Registered: Sep 2001
Location: Austin
Posts: 3

Rep: Reputation: 0
eth0 and eth1 work fine seperately but together one disables.

eth0 and eth1 work fine seperately but together one disables.
How do you resolve irq issues in linux? And what else might it be?
Old 09-06-2001, 04:09 PM   #2
LQ Guru
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 245Reputation: 245Reputation: 245
have you read the ehternet howto on getting two cards to work in one machine..
This might help if you haven't read it.
Old 09-06-2001, 11:58 PM   #3
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Hi Derek,

After reading your email, I had a couple of thoughts. I haven't configured multiple NICs myself, but here's what I have to offer, I hope it helps:

-If both are PCI cards, try changing the arrangement/order of the cards in your PCI slots.

-If one (or both) are ISA cards, please read the Ethernet HOW-TO. Trickykid posted a link to the section on multiple cards in his response, and I'd suggest you also read the FAQ section and any sections that deal specifically with your make of card(s). The section trickykid posted explains how to force IRQ and address settings for ISA cards; I'm not sure this works with PCI cards, but it won't hurt to try.

-Make sure Plug-N-Play support is turned off in your BIOS. That feature was introduced to help deal with Windows, but it can cause problems with some cards under Linux. If it is already disabled, try enabling it. Doing so runs contrary to most of the tech support advice I've read, but I know that it has worked for some Linux users.

-After booting up with both cards installed, log in and type "dmesg |less" (no qoutes). This will let you review the system startup messages, which usually scroll by too quickly to read at bootup. Using the page up/page down keys to scroll through the messages a screenful at a time, look for lines which relate to the initializing of eth0 and eth1, and write down any pertinent information and errors you find.

-Type "cat /proc/pci", and look for entries which start with "Ethernet Controllers:". If you see both cards listed, that's a start. Either way, note the card name and IRQ & I/O settings for each entry.

-Type "cat /proc/interrupts" to view your IRQ assignments. Identify which interrupts eth0 and eth1 are using (or if both are even listed, for that matter). Look for conflicts with devices which might be trying to use an interrupt that you think one of your NiCs should be using, and verify the values against those found in /proc/interrupts.

-Type "cat /proc/ioports" and note the address value given for your NIC(s). You might see an indented line directly below the device's listing, which starts with the same address range. The name on the right side of the colon is the driver the card is using. Make sure it is correct.

- If you know what modules your cards should use, type "lsmod", and see if the resulting output lists those modules.

Those are a few low-level basics to check out. Beyond that- if you need to repost, please provide a little more information:

- Basic system specs
- Model of your ethernet cards, as well as that of any other cards installed in the system.
- The name of the modules you think the cards are using.
- What Linux distro (and its version) you're using.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ping does not work between eth0 and eth1 Colin123 Linux - Networking 1 09-28-2005 01:10 PM
Can't get eth1 to work, just eth0. Thrifty Linux - Hardware 7 08-03-2004 03:01 PM
eth1 added, mysql connections FROM this machine are from eth1. Need bound to eth0??? kreese Linux - Networking 9 03-31-2004 12:12 PM
eth0 doesn't work when eth1 is up Amir Linux - Networking 4 09-08-2003 08:57 PM
UPgrade to Redhat 7.2 from 7.0 disables eth1 dsmigelski Linux - Networking 2 09-06-2001 12:04 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:59 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration