LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-27-2005, 07:31 PM   #1
jesse4349
LQ Newbie
 
Registered: Dec 2005
Location: Puyallup, WA
Distribution: Suse 9.0 Professional
Posts: 17

Rep: Reputation: 0
eth0 and eth1 failed at boot


I am trying to connect to Comcast High Speed Internet with Suse 9.0 Pro.

I am having trouble with my NIC card. At boot, someone instructed me to hit the F2 button to see what was happening, and sure enough, eth0 and eth1 failed.

How can I get connected? I have Yast set up for DHCP.

I came up with this somehow too:

Link encap: Local Loopback
inet addr:127.0.0.1 Mask: 255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 metric:1
RX packets:162 errors:0 dropped:0 overruns:0 frame:0
TX packets: 162 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueue1en:0
RX bytes:11340 (11.0 Kb) TX bytes:11340 (11.0 Kb)


Thanks for any help that you can provide.

Jesse
 
Old 12-28-2005, 05:23 AM   #2
ankscorek
Member
 
Registered: Mar 2003
Distribution: Slackware10.2,SUSE,FC,RHL,Vector Linux,WHAX,PHLAK,bt4,ubuntu,debian,aptosid,backtrack,blackbuntu
Posts: 529

Rep: Reputation: 31
try using static IP

if eth0 is connected to ADSL modem then most likely its address is 192.168.1.2 and gateway is 192.168.1.1..u can install bind and give nameserver as 127.0.0.1
 
Old 12-28-2005, 12:24 PM   #3
jesse4349
LQ Newbie
 
Registered: Dec 2005
Location: Puyallup, WA
Distribution: Suse 9.0 Professional
Posts: 17

Original Poster
Rep: Reputation: 0
eth0 and eth1 fail

Thank you for the response.

I am trying to connect with a cable modem that Comcast provided. RCA model # DCM315. I also have a wireless router (manufactured by the evil empire from Redmond, WA) so I can connect to the Internet with my laptop in my home.

So, the cable comes in from the wall, to the RCA cable modem, which then goes to the wireless router. I then have a network cable (the kind that looks like a phone plug but bigger) to my dual boot machine that has XP and Suse 9.0 Pro on it. The XP side works fine.

Yast shows that I have two network cards configured. However, eth0 and eth1 fail at boot (pressed F2 for details during start).

I tried to assign the address, gateway, and name server like you instructed, but it didn't work either. Bummer days!

Do I need to unplug the router and the cable box after I set the addresses? Why doesn't the DHCP work? Is the MS router not compatible with Suse? Do I need to install drivers or anything? I am a newbie but it shouldn't be this difficult!

Thanks again,
Jesse
 
Old 12-28-2005, 09:51 PM   #4
jesse4349
LQ Newbie
 
Registered: Dec 2005
Location: Puyallup, WA
Distribution: Suse 9.0 Professional
Posts: 17

Original Poster
Rep: Reputation: 0
Connecting to Comcast with Suse

Is it a party foul to reply to your own thread to get it back to the top?
 
Old 12-29-2005, 06:01 AM   #5
ankscorek
Member
 
Registered: Mar 2003
Distribution: Slackware10.2,SUSE,FC,RHL,Vector Linux,WHAX,PHLAK,bt4,ubuntu,debian,aptosid,backtrack,blackbuntu
Posts: 529

Rep: Reputation: 31
DHCP works fine

try pinging both the ethernet cards and then your gateway and finally your DNS

once that is ok then try

#dig yahoo.com

if that is ok then try pulling down the firewall and opening the web page

if it works then reconfigure your firewall

else post your

network file
 
Old 12-29-2005, 10:47 AM   #6
jesse4349
LQ Newbie
 
Registered: Dec 2005
Location: Puyallup, WA
Distribution: Suse 9.0 Professional
Posts: 17

Original Poster
Rep: Reputation: 0
I guess that I am going to learn how to ping too.
 
Old 12-29-2005, 10:47 AM   #7
jesse4349
LQ Newbie
 
Registered: Dec 2005
Location: Puyallup, WA
Distribution: Suse 9.0 Professional
Posts: 17

Original Poster
Rep: Reputation: 0
Off to Google!
 
Old 12-29-2005, 12:53 PM   #8
edanono
LQ Newbie
 
Registered: Feb 2005
Posts: 23

Rep: Reputation: 15
I think I had the same problem.

Try disabling the NIC card you are not using. I had a conflict somehow with two in a system I was running.
 
Old 12-30-2005, 02:26 PM   #9
jesse4349
LQ Newbie
 
Registered: Dec 2005
Location: Puyallup, WA
Distribution: Suse 9.0 Professional
Posts: 17

Original Poster
Rep: Reputation: 0
Suse 9.0 connection to Comcast

Thanks for the input.

I tried:

ping 192.168.1.2 and ping 192.168.1.1
Network is unreachable on both accounts.

ping 127.0.0.1
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.117 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.029 ms
and it kept repeating forever....

Is this promising?????

I looked in hardware compatibility and my MS Wireless Base Station MN-700 isn't listed there. Could this be the problem?

I also deleted that other card and the temporarily disabled the firewall. I don't think there are two on my machine, LOL! I am SO new.

Last edited by jesse4349; 12-30-2005 at 08:20 PM.
 
Old 12-31-2005, 03:17 AM   #10
ruuster
Member
 
Registered: Dec 2005
Distribution: Slackware 10.2 - bare.i, Slackware 10.1 - scsi.s, Slackware 9.1 - bare.i
Posts: 47

Rep: Reputation: 15
What does ifconfig -a give you?
 
Old 12-31-2005, 10:29 AM   #11
jesse4349
LQ Newbie
 
Registered: Dec 2005
Location: Puyallup, WA
Distribution: Suse 9.0 Professional
Posts: 17

Original Poster
Rep: Reputation: 0
ifconfig -a gave me this:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:40 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2608 (2.5 Kb) TX bytes:2608 (2.5 Kb)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Last edited by jesse4349; 12-31-2005 at 10:32 AM.
 
Old 12-31-2005, 07:11 PM   #12
ruuster
Member
 
Registered: Dec 2005
Distribution: Slackware 10.2 - bare.i, Slackware 10.1 - scsi.s, Slackware 9.1 - bare.i
Posts: 47

Rep: Reputation: 15
The results of ifconfig -a indicate that the kernel is not recognizing your ethernet interfaces. You are missing drivers, have conflicts, or have hardware problems.
 
Old 12-31-2005, 08:12 PM   #13
jesse4349
LQ Newbie
 
Registered: Dec 2005
Location: Puyallup, WA
Distribution: Suse 9.0 Professional
Posts: 17

Original Poster
Rep: Reputation: 0
Thank you. Is it a good assumption that I am probably missing drivers because everything works on the XP side of my dual boot? Should I give up?

Happy New Year!
 
Old 12-31-2005, 08:36 PM   #14
ruuster
Member
 
Registered: Dec 2005
Distribution: Slackware 10.2 - bare.i, Slackware 10.1 - scsi.s, Slackware 9.1 - bare.i
Posts: 47

Rep: Reputation: 15
No. Identify the NICs by manufacturer and model number. Then, make sure you have the drivers loaded for Linux. BTW: recent kernels support most of the current hardware you can find. You may just need to go through the network setup again. I am a Slacker but one of our Suse gurus should be able to help.
 
Old 12-31-2005, 09:24 PM   #15
jesse4349
LQ Newbie
 
Registered: Dec 2005
Location: Puyallup, WA
Distribution: Suse 9.0 Professional
Posts: 17

Original Poster
Rep: Reputation: 0
I'm on it. Thanks again.

In Device Manager on the XP side:

Network Adapters
1394 Net Adapter (manufactured by MS)
Microsoft® PCI Adapter MN-130

Do they make drivers for these for Linux?

Last edited by jesse4349; 12-31-2005 at 10:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I change eth0 to eth1 during the first boot us901 Red Hat 8 01-12-2010 06:51 PM
How do you swap the eth0 and eth1 boot order? rankis1 Linux - Networking 3 03-16-2005 12:49 AM
Eth0 & Eth1 boot start Up FAILED.. PAOLO_GRS Linux - Networking 1 09-03-2004 08:18 PM
eth0 eth1 and eth2 on boot sergiodemoura Linux - Newbie 4 12-03-2003 02:21 AM
30 minutes to OK eth0 and eth1 during boot up OldBlue Red Hat 2 09-12-2003 11:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration