LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-01-2003, 07:46 PM   #1
psychoholic
Member
 
Registered: Nov 2002
Location: Manchester, UK
Distribution: Slackware 10.2
Posts: 52

Rep: Reputation: 15
Eth0 and ADSL Speedtouch


Hi,

Maybe I should begin by stating what I am trying to achieve! I am hoping to use my dual booting linux / XP box to share the internet connection with another computer on the network (an XP one).

I was hoping to create a situation where the other user using XP wouldn't notice if I was using linux or XP. That is they dont have to change there netowrk settings to access to two different OS that I may be using ... (hope that makes sense!)

Simple? Well sort of.... except.

I dont seem able under linux to connect to websites on the internet when eth0 is up AND running with my ppp speedtouch connection.

That is my ADSL modem (ppp0) connects I get my IP address but when I use ping www.yahoo.com for instance nada/zip/nothing. I believe this is a DNS issue. I am connecting as I get my IP listed.

However this issue ONLY occurs when the eth0 is running. If I diable the referance to eth0 in /etc/modules.conf THEN run the usual "modem_run -f -m /path/to/mgmt.o" command and usual "pppd call adsl", all is well I can ping websites using there names

This is stumping me completley. Obviously I need both devices to work at the same time. I need to ping the internet using my speedtouch and ping the other XP machine

Briefly my linux/XP machine uses a static IP of 192.168.0.1
The other uses 192.168.0.2

i think part of the problem may lie in my shocking ignorance of how to set my eth0 card using the mandrake. For instance Mandrake always asks for the DNS of the eth0 and the gateway... which I dont have a clue what to answer with.

i aplogise for thwe lengthy nature of this post but can anyone help b4 i go mad!!!??

Thanks in advance!

Tom
 
Old 02-02-2003, 12:53 AM   #2
vexer
Member
 
Registered: Jan 2003
Location: Sudbury Ontario, Canada
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
Have you tried IP Forwarding with MDK?

What you would do is set your linux box as a Router type. And on the Second computer you would put the default address to your linux box as gateway and whatnot..

Go here. The site is for slackware but it doesn't really matter since the what your going to use is IPtables.

French version can be foundhere Translated by me

And that's all I can tell you. Try it out and if it doesn't work, I'm sure a more knowledgeable user will help ya. :/


-vex
 
Old 02-02-2003, 11:32 AM   #3
psychoholic
Member
 
Registered: Nov 2002
Location: Manchester, UK
Distribution: Slackware 10.2
Posts: 52

Original Poster
Rep: Reputation: 15
hi

Thanks for the info and using iptables to set my linux box as a router. It will be very useful when I solve the problem below...

However the one problem is that since my eth0 card or USB ADSL speedtouch modem will not "co exist".

That is when my network is up using 192.168.0.1 then my DNS wont work with the internet... therefor I cannot resolve the domain name of a website....

I think that prt of the problem lies in the fact the in my /etc/resolv.conf/ the line search localdomain appears when I do a "pppd call adsl"... I think it is this that is causing the problem....

Oh well !
 
Old 02-02-2003, 07:25 PM   #4
psychoholic
Member
 
Registered: Nov 2002
Location: Manchester, UK
Distribution: Slackware 10.2
Posts: 52

Original Poster
Rep: Reputation: 15
oh well for anyone interested problem solved...

Dont know why my eth0 bugged my ppp0 connection!

Still got both up and running...

That routing info will be useful now

Thanks!!!!!!
 
Old 04-18-2003, 12:54 PM   #5
cuboctahedron
Member
 
Registered: Nov 2002
Posts: 70

Rep: Reputation: 15
Hi, I have the same problem.

I have a usb speedtouch modem, and when I want to establish an internet connection, it only tries to do so through eth0, and not the usb dailer.

Is there a way to execute the dailer directly through the command prompt terminal?

cheers
Patrick
 
Old 04-21-2003, 10:00 AM   #6
psychoholic
Member
 
Registered: Nov 2002
Location: Manchester, UK
Distribution: Slackware 10.2
Posts: 52

Original Poster
Rep: Reputation: 15
Hi!

Just read your email Patrick!

I really do not know how exactly I got eth0 and my USB modem working!. I really should cause sooner or later I am going ot have to do it again!

The below is some slightly random information! Hope something in it helps!

*****

If you've the modem set up right then you could use the following to dial the modem! I think you need to be logged is as root to do this.

modem_run -m -f /usr/share/speedtouch/mgmt.o
pppd call adsl

(You need obviously to have installed you alcatel modem driver and microcode for this to work)

Also if you type:

ifconfig -a

As root then you will get a listing of all network devices connected to your system.

The listing for ppp0 is your speedtouch connection. The bit after where it says inet addr is your ip address.

Try pinging it with with IP address on ppp0.Using : ping (YOUR IP)
You can also do the same for youe IP address on eth0. Wither your machine or the IP of a local networked machine.


Interestingly in my mandrake control centre under services section I have turned off the Internet service which starts at boot. I actually start my internet connection by using the two lines above!
(There placed in /etc/rc.d/rc.local )

******

Hope some of this helps! Sorry for the latish reply I am in the middle of Easter revision... joy!

If you get any success or failure use the forum and I see if the is anything I can do!
 
Old 04-21-2003, 10:07 AM   #7
cuboctahedron
Member
 
Registered: Nov 2002
Posts: 70

Rep: Reputation: 15
Thank you for the reply

I'll check it straight away....

greets
Patrick
 
Old 04-21-2003, 10:12 AM   #8
psychoholic
Member
 
Registered: Nov 2002
Location: Manchester, UK
Distribution: Slackware 10.2
Posts: 52

Original Poster
Rep: Reputation: 15
One more thing!

In your posting you suggested that it was the DNS that was working incorrectly. I.e. website names not solving.

I seem to remember that there are 2 files with DNS info in them

One at : /etc/resolv.conf

The other at : /etc/ppp/resolv.conf
(This contains is my ISP's DNS)


I think my problem was that /etc/resolv.conf had some stupid entry that read search localdomain. I really wanted the DNS enteries from /etc/ppp/resolv.conf in this file.

Info on making a symlink between these fiels is at:
http://cvs.sourceforge.net/cgi-bin/v...x/FAQ?rev=1.14
Section 4.13
 
Old 04-21-2003, 10:46 AM   #9
cuboctahedron
Member
 
Registered: Nov 2002
Posts: 70

Rep: Reputation: 15
It worked!

the 2 lines:
modem_run -m -f /usr/share/speedtouch/mgmt.o
pppd call adsl

those were the lines I needed (I've been fussing with this for over 2 weeks now)

Do you have, I know this goes beyond the topic, a way how to run mysql on Mandrake? I am having an error "Can't connect to local MySQL server through socket".

I have a tread on http://www.linuxquestions.org/questi...threadid=53518

I am just trying to run a webserver at home, running mysql

Anyhow, thanks for your response

greetz
Patrick
 
Old 04-21-2003, 12:26 PM   #10
psychoholic
Member
 
Registered: Nov 2002
Location: Manchester, UK
Distribution: Slackware 10.2
Posts: 52

Original Poster
Rep: Reputation: 15
Sorry info on mysql is way way way beyond me. If you post a new thread here though I am sure theres someone with enough knowledge to help!

Glad your connections working though. I know how frustrating it can be!!

Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
speedtouch 330 adsl obstinatesod Linux - Newbie 4 09-27-2005 09:47 AM
ADSL Speedtouch 330 b4silence Linux - Hardware 1 03-16-2005 04:30 AM
ADSL Speedtouch USB Linbie23 Yoper 1 01-09-2005 06:16 AM
Hi speedtouch adsl usb Nawas111 Linux - Hardware 0 11-22-2004 02:06 PM
adsl with speedtouch 330 hraposo Debian 2 10-24-2004 05:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration