LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-15-2007, 04:24 PM   #1
ChristopherAngel
LQ Newbie
 
Registered: May 2007
Location: London
Distribution: Fedora 6
Posts: 13

Rep: Reputation: 0
/etc/resolv.conf to symbolic link


I use a sagem 800 USB modem to connect to the internet. All is well except when the connection is brought up (either at reboot or when I manually do this) my /etc/resolv.conf is is removed and instead a symbol link is created:

/etc/resolv.conf -> /var/run/ppp/resolv.conf

The problem is that at startup /var/run/ppp/resolv.conf is empty or does not exist so my internet does not start automatically. I have to restore my /etc/resolv.conf manually.

I have tried:
1) to grep for a script that is doing this;
2) to remove write permission from this file;
3) to create my own symbolic link;

None of the above make any difference.

I have two questions:

1) Anyone know why or how this is happening so I can stop it?
and/or
2) What would normally populate files such as /var/run/ppp/resolv.conf so that I may give up trying to stop the linking and just use it instead?

Regards,
 
Old 05-15-2007, 05:51 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
I haven't used Fedora Core but in general there is a system administration application to set up ppp connections. When you run this application it will ask you if you want to replace the local /etc/resolv.conf with information obtained through DHCP when the ppp connection is established. You should be able to fix your problem by running this application and configuring the ppp daemon to keep the existing /etc/resolv.conf instead of replacing it.
 
Old 05-25-2007, 06:28 AM   #3
ChristopherAngel
LQ Newbie
 
Registered: May 2007
Location: London
Distribution: Fedora 6
Posts: 13

Original Poster
Rep: Reputation: 0
Smile

I think you are referring to kppp. I used the option to manually use the DNS servers and specified the correct servers but this made no difference.

What did make a difference was running "cp /etc/ppp/resolv.conf /etc/resolv.conf" before the connection is made.

I'm still not sure why it was doing this but it's all working now thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Hosts.conf or resolv.conf problem mac_casey SUSE / openSUSE 0 03-26-2006 09:21 AM
About /etc/resolv.conf satimis Linux - Networking 10 02-24-2006 09:30 PM
resolv.conf Snump Mandriva 54 10-31-2004 04:16 PM
resolv.conf jmdlcar Slackware 9 05-15-2004 11:44 AM
resolv.conf ricemark20 Linux - Networking 12 11-11-2003 04:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration