LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-26-2004, 08:30 PM   #1
robertn
Member
 
Registered: Mar 2004
Location: mid-atlantic
Distribution: mandrake 9.1 rc2
Posts: 43

Rep: Reputation: 15
/etc/ppp/options--PLEASE ADVISE


Hello,

I am successfully accessing my IP with the KPPP KDE GUI which I have mostly configured by console and am using Firefox to browse (which I like a lot). My connect speeds have been 28,800bps and am not sure this matters (have seen 44,000 and 52,000 before). I have a "network" service that loads on boot and basically activates lo 127.0.0.1 which has been mounted shortly before. KPPP activates ppp0 and uses at least this configuration file:

#/etc/ppp/options

noauth
noipdefault
#usepeerdns
#verbose error logging
#debug
netmask 255.255.255.0
# /etc/ppp/options (NO CHAP--last line "name" for PAP)
#
# Prevent pppd from forking into the background
-detach
#linespeed
115200
# use the modem control lines
modem
# use uucp style locks to ensure exclusive access to the serial device
#lock
# use hardware flow control
crtscts
# create a default route for this connection in the routing table
defaultroute
# do NOT set up any "escaped" control sequences
asyncmap 0
# use a maximum transmission packet size of 1500 bytes
mtu 1500
# use a maximum receive packet size of 1500 bytes
mru 1500
#
# force pppd to use your ISP user name as your 'host name' during the
# authentication process#

name mylogin@myIP.com

This is a standalone machine with a simple but effective iptables firewall and I am just trying to "tweak it up". Does anybody have any constructive comments?

Thanks for taking the time


robertn

Last edited by robertn; 05-26-2004 at 08:34 PM.
 
Old 05-26-2004, 10:04 PM   #2
ggeorgiev
LQ Newbie
 
Registered: May 2004
Location: Montreal, Canada.
Distribution: Slackware, with modifs.
Posts: 3

Rep: Reputation: 0
Hi,

I find it difficult to understand your problem from the posting - so I will try to give ideas for a sane setup that should work mostly everywhere:

In /etc/ppp/options and/or /etc/ppp/options.ttySx (x=0,1, etc) for a modem line I used something like:
modem
lock
crtscts
asyncmap 0
mtu 552
mru 552
name your_loginname
defaultroute

If you are required to authenticate via CHAP or PAP you should set-up files named 'chap-secrets' or 'pap-secrets'.
/etc/ppp/ip-up may be used for firewall mounting.
And of course you make your chat script - I used to login to my ISP with a serial communication package like minicom and see the login dialog, after that I adjusted my chat script.

Usefull sources of information: 'man pppd'; 'man chat'; PPP-Howto.

Good luck!
 
Old 05-27-2004, 10:12 PM   #3
robertn
Member
 
Registered: Mar 2004
Location: mid-atlantic
Distribution: mandrake 9.1 rc2
Posts: 43

Original Poster
Rep: Reputation: 15
@ggeorgiev,

thanks very much for your reply; I admit that I did not state much of a problem. I got so confused trying to reestablish my internet connection that I am still sorting things out. I had used MandrakeUpdate to download security fixes and accidentally loaded and installed "httpd" (Apache) which I did not want. It seemed to do some major reconfiguration of my net configuration. I uninstalled it before I realized this and so ...

I posted my /etc/ppp/options file for review just to make sure that I didn't have any silly settings. Sometimes my understanding is foggy or even wrong about what I am entering into these files even though I read a great deal before acting or posting here.

Even though I am now logged on with this connection, something seems not right. Before I use the KPPP GUI things look like this:


# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:300 (300.0 b) TX bytes:300 (300.0 b)


#ifup ppp0
Failed to activate ppp0 with error 17

# man pppd
(Exit Status) 17 The PPP negotiation failed because serial loopback was detected.

I am not sure which files/scripts that KPPP is using to sucessfully overcome this; moments later I am on the web and now:

# ifconfig

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:300 (300.0 b) TX bytes:300 (300.0 b)

ppp0 Link encap:Point-to-Point Protocol
inet addr:65.XXX.XXX.XX P-t-P:63.YYY.Y.YYY Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1412 Metric:1
RX packets:293 errors:1 dropped:0 overruns:0 frame:0
TX packets:338 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:231788 (226.3 Kb) TX bytes:55159 (53.8 Kb)

Still robertn#

Last edited by robertn; 05-27-2004 at 10:15 PM.
 
Old 05-28-2004, 08:24 AM   #4
ggeorgiev
LQ Newbie
 
Registered: May 2004
Location: Montreal, Canada.
Distribution: Slackware, with modifs.
Posts: 3

Rep: Reputation: 0
Yes, I remember to have had 'serial loopback detected' long time ago - and if I am not mistaken it tells that your pppd thinks someone from the remote end just mirrors back packets that your local pppd is sending. I remember also that if your line is not '8 bit clear' you get this error - so check settings for your modem and set them to 8-N-1. Not too sure - it was long time I used ppp, but hope this helps.

George.
 
Old 06-02-2004, 07:21 PM   #5
robertn
Member
 
Registered: Mar 2004
Location: mid-atlantic
Distribution: mandrake 9.1 rc2
Posts: 43

Original Poster
Rep: Reputation: 15
Thumbs up

George,
Thanks again; have been busy and have not checked in lately.

I will check the modem settings and experiment.

[root@localhost log]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
65.yyy.0.yyy 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 lo
0.0.0.0 63.yyy.0.yyy 0.0.0.0 UG 0 0 0 ppp0

I post the output of "route" for comment; sorry about the way it pastes up. Editing didn't help much.

robertn

Last edited by robertn; 06-02-2004 at 07:33 PM.
 
Old 06-03-2004, 02:25 AM   #6
camelrider
Member
 
Registered: Apr 2003
Location: Juneau, Alaska
Posts: 250

Rep: Reputation: 32
If you have a "noisy" phone line, reducing your mtu and mru values should improve performance somewhat as fewer packets will be damaged in transit, needing to be retransmitted. At least it worked for me during my dial-up days.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to link linux ppp client to windows ppp server? cyz Linux - Networking 2 12-11-2008 05:01 AM
Looking for man ppp-on and info ppp-on pages. rvijay Linux - General 1 02-26-2005 08:49 PM
Kernel 2.6.2 options question - LOCKED options ? tvojvodi Linux - General 0 02-17-2004 04:23 AM
best compression options for ppp on V90 modem dominicc Linux - Networking 1 12-02-2003 07:33 PM
'defaultroute' in PPP options? Monster Linux - Newbie 2 01-24-2002 01:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration