LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-05-2005, 01:10 PM   #1
richessence
LQ Newbie
 
Registered: Jun 2005
Posts: 14

Rep: Reputation: 0
Errors with NFS


Errors with NFS
Iím at the step where I need to verify portmap is working OK on the box I want to share.

IN the process of preparing a FC3 Linux box to share a directory out.

I get this error when I run Rpcinfo Ėp:
can't contact portmapper: RPC: Remote system error- Connection denied

Researching articles on the web, I found out this could be because of some errors in hosts.allow/deny or my exports file.
I believe my syntax is correct & when I change it, I believe it exports OK, as I donít get any errors (or anything else ) when I do this command:
Exportfs Ėr

When I run nfs restart all daemons start except portmap.
For that I get the following error:
RPC: failed to contact portmap (errno-5)

Then I tried exportfs Ėvar
It seemed to work as it said:
ďexporting *:/home/mark

Then running nfs restart does work
But I still get that error when running rpcinfo Ėp

And a portmapper failure error when running
Showmount -e

Iíve tried putting the FQH name & then the IP address for my share server in the exports file, that didnít work so I took it out.

At one time I also changed my hosts.allow file to ALL: ALL

Iíve found out (correctly I hope) that even though I want portmap I need to have an entry in the hosts.deny file such as: portmap: ALL
But Iíve also tried it without this entry in here & it the hosts.allow file.

The box Iíd like to share-out is 192.168.113.1
The box Iíd like to connect to it is 192.168.113.2

Iíve included my hosts & exportfs files below.
Any information would be helpful.
I donít know if this has anything to do with it, but my NIC doesnít retain itís values (ip/mask) info even though I put it in the /etc/sysconfig/network-scripts/ifcfg-eth0 file. But I do get IP by manually using the ifconfig command.
So I included that as well.

Thank you,

Mark

EXPORTS
#Exports file
/home/mark *(no_root_squash)

HOSTS.ALLOW
# hosts.allow This file describes the names of the hosts which are
# allowed to use the local INET services, as decided
# by the '/usr/sbin/tcpd' server.
#
ALL: 192.168.113.1
ALL: 192.168.113.2
portmap: 192.168.113.0/255.255.255.0


HOSTS.DENY
#
# hosts.deny This file describes the names of the hosts which are
# *not* allowed to use the local INET services, as decided
# by the '/usr/sbin/tcpd' server.
#
# The portmap line is redundant, but it is left to remind you that
# the new secure portmap uses hosts.deny and hosts.allow. In articular
# you should know that NFS uses portmap!
ALL:ALL
portmap: ALL

IFCFG-ETH0
#This should be autoconfiguring my card, but it's not!
DEVICE=eth0
IPADDR=192.168.113.1
NETMASK=255.255.255.0
ONBOOT=yes
TYPE=ethernet
 
Old 07-05-2005, 01:15 PM   #2
nixcraft
Member
 
Registered: Nov 2004
Location: BIOS
Distribution: RHEL3.0, FreeBSD 5.x, Debian 3.x, Soaris x86 v10
Posts: 379

Rep: Reputation: 30
Start portmap service.
 
Old 07-05-2005, 02:20 PM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
/sbin/service portmap start
 
Old 07-05-2005, 02:57 PM   #4
richessence
LQ Newbie
 
Registered: Jun 2005
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks guys, but I'm still getting it.

This what Iíve done:
When I start portmap I get green [OK]
But rpcinfo Ėp still gives same error.

I did this too:
Rebooted
/sbin/service portmap start
rpcinfo Ėp (still same error)
exportfs Ėvar (looks like it goes OK)
nfs restart (goes OK)
rpcinfo Ėp (still same error)

And I noticed this, even though my exports file only has this in it:
/home/mark *(no_root_squash)
When I go to /var/lib/nfs & look in the etab file I see:
/home/mark *(ro,sync,wdelay,hide,nocrossmnt,secure,no_root_squash,no_all_squash,subtree_check,secure_locks,mapp ing=identity,anonuid=-2


Thanks,
Mark
 
Old 07-05-2005, 03:14 PM   #5
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 128Reputation: 128
Might your firewall be blocking even local connections?
 
Old 07-05-2005, 04:44 PM   #6
richessence
LQ Newbie
 
Registered: Jun 2005
Posts: 14

Original Poster
Rep: Reputation: 0
looks like thats disabled...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting NFS Quota errors, among others, with Mandrake 8.2 FunBunny Mandriva 0 05-24-2005 06:45 PM
Intermittent nfs errors bilbod Linux - Networking 0 01-05-2005 09:43 PM
Lan configuration problem - NFS boot problem - RX&TX packets errors 242VDM242 Linux - Networking 4 11-25-2004 01:35 PM
Non-fatal NFS errors on mount in boot CD andrewb758 Linux - Software 0 10-12-2003 02:26 PM
Input/Output errors when mv or cp from local machine->NAS device via NFS? Matt@Ants Linux - Networking 2 06-24-2003 01:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration