LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-21-2002, 08:30 AM   #1
guanyu
Member
 
Registered: Jul 2001
Distribution: RedHat 7.0,7.1,7.2,7.3,8.0. Sun Solaris
Posts: 111

Rep: Reputation: 15
enable telnet but can't telnet from the computer


Hey guys,
I am having a weird problem. I can't telnet from WAN. But I managed to telnet from my LAN. Do you guys have any idea about it. I really don't have any clue. Thank you appreciate that!!

guanyu
 
Old 08-21-2002, 09:19 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977
can you give some actual information here? where are you trying to telnet to? what errors do you get? please provide useful information in your posts in future, thanks.
 
Old 08-21-2002, 10:57 PM   #3
guanyu
Member
 
Registered: Jul 2001
Distribution: RedHat 7.0,7.1,7.2,7.3,8.0. Sun Solaris
Posts: 111

Original Poster
Rep: Reputation: 15
Well my msg is "Could not open a connection to xxx.xx.xxx.xx. I guess something with my ip. I need to cofigure ip so that i can telnet from outside. Is that rite? I am not sure about it
 
Old 08-22-2002, 10:00 AM   #4
Griffon26
Member
 
Registered: Sep 2001
Location: The Netherlands
Distribution: Gentoo, Debian, Mandrake, LFS
Posts: 182

Rep: Reputation: 30
What I gather is that you are trying to connect to your own computer from the internet and it's not working.
Telnetting from your own computer to somewhere on the internet does work.

Is this correct?

If so and if you are sure you want to enable the telnet service on your computer, you probably have to enable it in /etc/xinetd.d/telnet.
That file most likely contains a line:
disable = yes

Change this to "no" and it should work.

Keep in mind that everything you type on a telnet connection is sent over the network unencrypted. Someone in between could sniff your passwords and hack your box. If you want more security, consider using SSH instead.
 
Old 08-22-2002, 08:14 PM   #5
guanyu
Member
 
Registered: Jul 2001
Distribution: RedHat 7.0,7.1,7.2,7.3,8.0. Sun Solaris
Posts: 111

Original Poster
Rep: Reputation: 15
Giffon,
Thank for replying. I can telnet from my internal(192.168.xx.xxx). But I cannot telnet from WAN(or other ISP). For instance, 68.2.xx.xxx. I had already enable the telnet feature otherwise my internal computer won't be able to telnet. That's my problem. Thanks

GuanYu
 
Old 08-23-2002, 02:32 AM   #6
Griffon26
Member
 
Registered: Sep 2001
Location: The Netherlands
Distribution: Gentoo, Debian, Mandrake, LFS
Posts: 182

Rep: Reputation: 30
Check the /etc/hosts.allow and /etc/hosts.deny files.

man hosts.allow
 
Old 08-23-2002, 11:16 AM   #7
Rich
LQ Newbie
 
Registered: Jan 2001
Location: Raleigh, NC
Posts: 11

Rep: Reputation: 0
Your internal "192" address would imply a NAT translation is taking place. Are you using a router? If so, did you open up the telnet port?
 
Old 08-24-2002, 06:47 PM   #8
JamesLittle
LQ Newbie
 
Registered: Aug 2002
Posts: 1

Rep: Reputation: 0
Certain IP addresses are reserved for private use and are not routable across the internet. Routers on the internet recognize these ip addresses and "drop" them.

Because your local wan is using 192.x you "can't get there from here".

There is a way though... Your router to the internet uses NAT to "rewrite" the IP addresses comming in and out of your LAN. You could configure a static forwarding entry in the router that basicaly says "forward incoming port 23 to the internal ip address 192.x.x.x (server ip)"

BTW: It is better to use ssh, telnet uses unencrypted passwords
 
Old 08-26-2002, 06:34 AM   #9
guanyu
Member
 
Registered: Jul 2001
Distribution: RedHat 7.0,7.1,7.2,7.3,8.0. Sun Solaris
Posts: 111

Original Poster
Rep: Reputation: 15
JamesLittle,
No No. I wanna connect to my server instead of my local computer which mean connect to Eth0. I don't wan forward to my local. What I want just let me telnet to my server(cox ISP).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
enable telnet mbquartnut SUSE / openSUSE 6 05-23-2008 10:35 PM
How to enable telnet muneebs123 Linux - Newbie 11 04-04-2008 05:01 AM
How to enable Telnet in Linux? lapzlinux Linux - Networking 9 08-11-2006 01:26 AM
Can't enable Telnet server xailer Linux - Newbie 2 11-23-2003 10:48 AM
enable telnet on RH7.1 systray Linux - Newbie 1 03-22-2002 12:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration