-   Linux - Networking (
-   -   Easy way to access Windows shared folders ? (

robertpolson 01-12-2007 10:06 PM

Easy way to access Windows shared folders ?
Hi, I am a Linux (Ubuntu) Noob.

Just when I started to like it, I got really disappointed in Linux because I cannot access my shared windows folders.

I can see the wrokgroup and my windows pc well in samba, but as soon as I try to access the pc with shared folders, I get this:

The folder contents could not be displayed.

Sorry, couldn't display all the contents of "Windows Network: mynetworkpcname".

Is there an easy way I can access my network files just like in windows?

Please help. I already installed samba and fsamba, I am confused here.

robertpolson 01-13-2007 01:44 PM

I also posted this question here:

So far I did not get to the point where I can easily browse my windows shares as in windows to windows.

Any help ?

robertpolson 01-14-2007 03:58 PM

I am not sure what or how but it works now.

My guess is that it started working after I shared folders in Windows and then restarted the computer with those shared folders.

No I can access them and mount too.

Here is the next problem:

When browsing via nautilus, I can delete and write files in these folders because I set the "allow users to modify files" in windows.

But when I mount these shared directories, and I open them, I cannot write to them ?

How do I make it so that I can write to them when they are mounted ?

I can browse via samba to my specific shared disk and right click on it and select connect to server and than it works fine and I can see it in "My Palaces" and delete and write files, but I cannot just open and .avi or and .mp3 file and stream it. I have to copy it and then it works.

If I mount it, I can browse and stream and play, but cannot modify files.

So many irritations with this, that I am almost ready to go back to Windows XP. I mean basic things and so much trouble and hours of reading on forums.

P.S. Another example of a problem I had today - transfer pictures from Canon Powershop A85 was fine, but when it got to the video, it just froze. Both the default nautilus photo uploaded from camera and digiKam.

robertpolson 01-14-2007 09:52 PM

Any ideas how to mount it so that I will get a Read/Write access?

robertpolson 01-14-2007 10:25 PM

Wow, I almost gave up on Linux and finally figured this network issue out.

I went here

Looked at this line:

sudo mount // /media/sharename/ -o username=myusername,password=mypassword,dmask=777,fmask=777

and edited my mount command like this:

sudo mount -t smbfs //battlestation/F /media/BattleStation/F -o dmask=777,fmask=777

This gave me read and write access.

Last items to do remain:

1) Figure out how to mount permanently, I look at the guide.

2) Where do I read about what do these mean?


Especially these that allowed write access:


P.S. Interesting how all this time I have a conversation with myself.

robertpolson 01-14-2007 11:44 PM

I just hate this.

I restarted my Ubuntu without changing anything from my previous post and now I am back "0"

I cannot access the shared folders anymore on the windows box as I posted in my initial post.

For no reason that I a aware of, I get crap with Linux.

archtoad6 01-15-2007 11:20 AM

You need to read Raymond & Moen's "How to Ask Questions the Smart Way" -- all of it.

Google it.

robertpolson 01-16-2007 02:51 PM

This problem is solved here:

All times are GMT -5. The time now is 04:34 AM.