LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Dual NIC's really slow (https://www.linuxquestions.org/questions/linux-networking-3/dual-nics-really-slow-4109/)

hazza96 07-10-2001 04:46 AM

Dual NIC's really slow
 
I have just setup Mandrake 8.0 with two nic's, one is a 3com 509 and the other is an SMC.

My network setup is:- windows machines connected on the 192.168.1 network(eth0 - 3com card), and a Mandrake 7.2 box on the 192.168.0 network (eth1- SMC card).

They both are working but when I telnet from my WinME machine to the 8.0 box the response is in spurts. It will output half the screen, wait half a second and then output the other half.

If I don't load eth1 the network response is as you would expect.

Here's the output of 'ifconfig'
.....................................
eth0 Link encap:Ethernet HWaddr 00:A0:24:08:BA:F1
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1361 errors:0 dropped:0 overruns:0 frame:0
TX packets:1446 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:84219 (82.2 Kb) TX bytes:378412 (369.5 Kb)
Interrupt:10 Base address:0x300

eth1 Link encap:Ethernet HWaddr 00:00:C0:AD:85:96
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:349 errors:0 dropped:0 overruns:0 frame:0
TX packets:474 errors:0 dropped:0 overruns:0 carrier:0
collisions:1 txqueuelen:100
RX bytes:70150 (68.5 Kb) TX bytes:28699 (28.0 Kb)
Interrupt:3 Base address:0x290 Memory:d0000-d4000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:78 errors:0 dropped:0 overruns:0 frame:0
TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5460 (5.3 Kb) TX bytes:5460 (5.3 Kb)
.....................................


Here's the output of 'route -n'
..............................................
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
...........................................

hazza96 07-10-2001 11:47 PM

Found it.

I posted the same question to Experts Exchange and someone pointed out that the SMC card was using IRQ 3, the same as the com port.

I disabled the com port in the bios and everything works fine now.

mcleodnine 07-11-2001 03:39 AM

ExpertSexChange.com I still get a kick outta that.


All times are GMT -5. The time now is 01:01 AM.