LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-04-2017, 06:58 PM   #1
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 2,127

Rep: Reputation: 174Reputation: 174
Donít go looking for other WiFi networks!


I am running Ubuntu Mate 16.04 on a Dell Latitude 2100 mini-notebook which has be re-purposed as a music player for my workshop. My 400+ album collection, converted to mp3 files, resides on the SSD. The music I want and no talk/commercials A next-to-no permission account automatically logs in when the machine starts and any music in the queue begins to play.

The computer is connected to the hidden WiFi signal from the router in the house. Normally this is only used to do OS updates. The problem is that there is a lot of WiFi pollution in the area and I see several other networks displayed in network manager. While these are not hidden they do have some level of security (password at least) and cannot be connected to.

However, sometime the computer looses connection to MY WiFi and when it attempts to connect to one of the other "available" networks it brings up an authentication dialog. Most annoying.

Is there a way to tell Network Manager NOT to look for other WiFi networks which happen to float by?

TIA,

Ken
 
Old 08-04-2017, 07:06 PM   #2
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: arch
Posts: 668

Rep: Reputation: 190Reputation: 190
If you open up networkmanager you should have an option to "Never connect to this network". I would just select that option for any networks that give you that dialog. It's strange that it would try to automatically try to connect to networks you haven't configured though
 
Old 08-04-2017, 07:13 PM   #3
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 2,127

Original Poster
Rep: Reputation: 174Reputation: 174
Thanks TheEzekielProject,

This only started happening a day or two ago. The first dialog wanted MY password (not the dummy account which does the autologin) to make changes to network something - don't recall what. I canceled that and then a dialog to connect to one of my neighbor's WiFi networks appeared. I guess I can (should?) disable WiFi completely as this computer does not normally need network access.

The never connect option might turn into a whack-a-mole game depending on how many alien WiFi networks happen to spread their signal my way.

Ken
 
Old 08-04-2017, 07:23 PM   #4
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: arch
Posts: 668

Rep: Reputation: 190Reputation: 190
If it doesn't need network access then I would disable the wifi.

You're right about the never connect option turning into whack-a-mole. I just find it strange that it would try to connect to random networks in the area in the first place.

What is it that caused you to get the initial dialog asking you for your password to make network changes? If you can reproduce the issue, there is a much better chance of tracking down the problem.

But then again, if you don't normally need network access, it might be more trouble tracking down the cause than it's worth. And just disabling wifi might be the faster approach. I guess it mostly depends on how much you like to fix things
 
Old 08-04-2017, 07:24 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,517

Rep: Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843
You could disable network manager and configure wpa_supplicant via the interfaces file. If it looses connection you might have to manually restart.
 
Old 08-04-2017, 08:56 PM   #6
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 2,127

Original Poster
Rep: Reputation: 174Reputation: 174
Thanks again TheEzekielProject,

I have no idea what caused it. I noticed that the network manager icon which shows sort of juggling balls when trying to connect to a network was frozen. The dialog was present asking for my password. Happened a couple of times at random.

Thanks michaelk,

I may have to look into that approach just as a learning exercise. Disabling WiFi when not needed is probably the simplest approach.

Ken
 
Old 08-04-2017, 09:06 PM   #7
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: arch
Posts: 668

Rep: Reputation: 190Reputation: 190
I would second michaelk's suggestion. I've only ever had issues with networkmanager and wicd. I use wpa supplicant like so
Code:
 wpa_supplicant -B -i wlan0 -c <(wpa_passphrase SSID "password")
gets me connected and then i can just use
Code:
wpa_cli (dis|re)connect
. Of course, this does not assign an ip so depending on your preferences, add an ip with dhcp or static. I use
Code:
ip addr add desiredIP
ip route add default via 192.168.1.1
where 192.168.1.1 is my router

EDIT: Note that the first command requires a root terminal due to process substitution, not just to be prepended with sudo, or you will get errors.

Also, if your wireless passphrase is particularly complex you may want to use here strings
Code:
wpa_supplicant -B -i wlan0 -c <(wpa_passphrase SSID <<< "password")
The Arch Wiki is a great resource for wpa_supplicant https://wiki.archlinux.org/index.php/WPA_supplicant

Last edited by TheEzekielProject; 08-04-2017 at 09:13 PM.
 
Old 08-05-2017, 08:31 AM   #8
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 2,127

Original Poster
Rep: Reputation: 174Reputation: 174
wpa_supplicant looks like a neat utility. However, in this case it is probably overkill. Now if it can prevent DNS leakage when connecting to a VPN service... might be worth some further investigation.

As to the minimal issue at hand... I found in dconf editor

org; gnome; desktop; nm-applet

[X] suppress-wireless-networks-available

Set this to true to disable notifications when Wi-Fi networks are available.

The was on my workstation - no WiFi NIC. Next time I am in the shop I will look at the other machine and see what if anything this might do.

Ken
 
Old 08-06-2017, 02:51 PM   #9
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 2,127

Original Poster
Rep: Reputation: 174Reputation: 174
I investigated the above mentioned setting on my notebook. No change. It seems to impact the popup notification baloon, not the list of available networks. I also investigated the nework manager configuration file. Nothing there to help. Deleting the unwanted networks does not help. They keep coming back. I guess I will ignore the situation or just shut off WiFi when not needed.

Thanks again for all of the assistance provided.

Ken
 
Old 08-06-2017, 03:13 PM   #10
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,517

Rep: Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843Reputation: 5843
Actually nm still uses wpa_supplaint to login to the router so it isn't overkill. Just going from something automatic to manual.
 
Old 08-07-2017, 04:41 AM   #11
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 19,872
Blog Entries: 12

Rep: Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052Reputation: 6052
for the setup you describe in post #1, i think using networkmanager is total overkill.
you are only ever connecting to this one particular wifi network, yes?
i would simply completely purge network-manager and all its libraries and gui utilities, and configure /etc/network/interfaces to connect to that, and that only.
or create a simple shell script that can be used to connect whenever necessary.
plenty of search results for phrases like "linux wireless connect command line"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Cannot detect certain wifi networks. talosthoren Slackware 6 07-23-2016 05:28 PM
[SOLVED] Cant connect to wifi networks Altair827 Linux - Newbie 25 12-19-2015 08:30 AM
[SOLVED] Cannot see wifi networks nine9nine Linux - Newbie 8 02-10-2011 05:05 PM
wifi and changing networks yukaputzer Linux - Newbie 1 12-18-2003 05:23 PM
How to change between networks with wifi yukaputzer Linux - Newbie 1 12-18-2003 03:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration