-   Linux - Networking (
-   -   Domainname and Server found, but cannot login into YP server (

kaizersozzai 10-22-2004 10:13 AM

Domainname and Server found, but cannot login into YP server
Hi. I know that there are a few different threads on this topic, but I have read all of them and I still have not found a solution to my problem. I would like tp apologise ahead of time for my lack of terminology. I have here a machine, Foo, to which I would like to export a group of directories to another machine, Steve. Right now, Foo already serves a group of machines and this is working fine. Recently, I have been trying to get Steve to also working with this NIS Server. When I installed Redhat 9.0 on Steve, I specified the domain, yoyo, and the server,, but I am unable to login under that domain. I have also attempted to place Foo under another domain and this was successful. When I run ypwhich and domainname, I get the correct information, but when I run yptest, I fail 5 out of the 9 tests. For example:
Test3: yp_match
WARNING: Internal NIS error (Map pawwds.byname, key nobody)

Simial errors occur for the other tests. Thank you in advance for any help I can get. Like I said before, I don't like making threads when there are other similar, but I am very desparate right now and could really use the help.

ugge 10-23-2004 05:42 PM

Have you tried running ypcat from steve?
This would let you check if you get contact with the NIS server and if you get any information from it.
Then try to see if you get information from all maps that you need.

Since I don't know you experience with NIS:
The NIS domain doesn't have to be the same as your DNS domain, they are separate domains.
Use domainname to check that the NIS domain is correctly configured for steve.

kaizersozzai 10-25-2004 09:07 AM

Hi. I know a small amount about NIS. I understand that the domain and the domain server can be different, that how we have it set up. Our problem is that I has the corret domain and domain server, but when we try to login usings users from the domain server, it does not allow us to. We've ran ypcat from the server and everything seems fine. On the client, we've tried running yptest and we fail 5 of the nine test. The first error that comes up looks like this:
Test 3: yp_match
Warning: Internal NIS error (Map passwd.byname, key nobody)
Similar errors occur other the following tests. We've made sure that the server is allowed to accept from the ip address of the client (or at least i hope we are). I'm open to any suggestions because we've tried to dublicate the settings that we have on other machines, but we are obviously missing something. THanks in advance.

kaizersozzai 10-26-2004 05:07 PM

Hi all. I have a solution to my problem, but I would like to restate the problem in a better way for anyone who is looking for anyone who is having a similar problem.

I have a server, Steve, to which many other computers are connected to through NIS. For the past week, I've been trying to get a new group of computers to use Steve as an NIS server. During the installation, I gave the clients the proper NIS server and domain. We went into the server's /etc/hosts.allow file and added the ip addresses of the new computers, but We was still unable to get users from the NIS to be able to logon to these new clients. When I ran domainname and ypwhich the clients would return the correct information. But when yptest was ran, it would return errors, mainly having to do with the NIS maps not being read by the client. They looked like the following:

Test3 ypmatch
WARNING cannot match (Map passwd.byname, key nobody)

In an effort to find the problem, We were able to connect the computers through a different server and domain.

The solution:

I ran a man on rpc.ypxfrd, it refers to the /var/yp/sercurenets file on the server. There, you must add to the list of allowed connections, the subnet mask and the ip's of the computers that you would like to connect with that NIS server.

I hope this is of some help to anyone. If you have any other questions, you can ask on this thread. And thanks to ugge for replying.

All times are GMT -5. The time now is 02:53 PM.