-   Linux - Networking (
-   -   Dialup Modem always busy (

windyweather 10-29-2006 07:45 PM

Dialup Modem always busy
SUSE 10.1

KPPP cannot connect the modem. "Modem is Busy" is all I get.

Configured dialup modem with YAST. Configured it with name of /dev/ttyS3 since never got anywhere with /dev/modem.
Configured a provider. I'm using Network manager , or not, it makes no difference.
Installed and configured KPPP 2.3.2 from the SUSE 10.1 distro. And of course had to set it's SUSER and SGROUP bits in Nautilus when logged in as root so it would run as a normal user.

Configured the modem as /dev/ttyS3, configured the provider, same as in YAST since YAST wouldn't let me out without configuring one.

KPPP won't connect. The modem is busy is all I get. I went to terminal window in the KPPP config and it's busy there too of course.

What's going on? How do I find out what has the modem and how do I get rid of it. How do I know that /dev/ttyS3 is the right thing to use. I 've got a USB mouse etc on this system. Is there a clash and /dev/ttyS3 not free for the modem? How to find out?

I've read a bunch of startup pages for dialup on Linux and SUSE and none address this problem. And yes I have rebooted several times.


windyweather 10-29-2006 10:21 PM

I had an agere ltmodem. No driver support built in to SUSE any more for that. I switched to a ZOOM external modem - ancient history - with a keyspan USB serial line. The COMPAQ presarian SR1920NX doesn't have any serial lines - would you believe it.

So all is working. Keyspan hooked right up. YAST found the modem. KPPP configed the modem and dialed right up.


UhhMaybe 09-09-2007 12:25 AM

Kppp is configurable. Within the GUI, Kppp has a "test modem" window box. Try to test the modem; if it fails, go back to settings and try a different "Modem Device" setting. Note: While trouble shooting the settings; write down the pass/fail info, and correlate the data with the hardware. Time saver. Keep trying to find the correct one. Note: During boot up; in run level 3, the screen will show IRQ's. Write down the IRQ's for YOUR Modem Device at that time. Or check the BIOS for IRQ data. There should be at least one IRQ for Modem. Most BIOS have two listed. Also, IRQ data can be checked with "lspci", "lsusb", and "lsmod". Also "modprobe" and "man modprobe" can help. Try here for lots of core reading.... Good luck to YOU.

herbie_popnecker 09-09-2007 01:41 AM

What do u mean modem is busy? Modem in use by another process or do you mean it gets a busy signal all the time when it dials?
Reminds me of old tech support days when every week we got a customer from another ISP who switched to us because the other guy's "lines were always busy".
In every single case where we set it up for them and found they were dialing their own phone number.. LOL

windyweather 09-09-2007 11:25 PM

This was solved months ago...

Originally Posted by herbie_popnecker (Post 2886238)
What do u mean modem is busy?

The Modem Busy was an indication that the driver was busy, not the phone line. But the real problem was that there was no suitable driver.

The problem here was that SUSE no longer has the driver for this modem. The modem was one of those modems where most of the logic of the modem is inside the system rather than in the modem card. And the driver was withdrawn due to some intellectual property snafu. I discovered this with a fair amount of sniffing around the net with goggle at the time.

So, the real fix, regardless of the symptoms of the problem, is to get a supported modem. And of course any external AT modem is supported.

Not sure if all this has changed in the last 11 MONTHS since I originally posted and solved my problem, but my problem was solved AGES AGO, by using an external modem which is supported.

Have a great one,

All times are GMT -5. The time now is 01:23 PM.