LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   DHCPD problem - no free leases (https://www.linuxquestions.org/questions/linux-networking-3/dhcpd-problem-no-free-leases-47059/)

ms_lyon 02-25-2003 10:18 AM

DHCPD problem - no free leases
 
Hi,

I get this message form my (Suse) DHCP server:
DHCPDISCOVER from x:x:x:x:x via eth0: network 192.168.1.0/24: no free leases

Here is my /etc/dhcpd.conf

ddns-update-style none;

subnet 192.168.1.0 netmask 255.255.255.0 {
host example {
hardware ethernet x:x:x:x:x {
fixed-address 192.168.1.10;
}
}


And the client (the printer) which is configured to get automatically the IP address never gets it!!!

Can anyone help?

Many thanks.

cojo 02-25-2003 11:35 PM

your file are missing most of the important lines. Here is my file.

#This is my dhcp server setting
default-lease-time 86400;
max-lease-time 86400;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
option routers 192.168.1.1;
ddns-update-style ad-hoc;
option domain-name-servers 151.164.14.201,151.164.1.8;
option netbios-name-servers 192.168.1.1;
option domain-name "COJO";
subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.10 192.168.1.100;
range 192.168.1.150 192.168.1.200;
}

It should work for your network. Since, we use the same subnet. You could change the domain name to whatever you want. Let me know if you still need help.

ms_lyon 02-26-2003 01:32 AM

You didn't understand...
I just want my printer to have a fixed address assigned..I don't want to use range declaration..

cojo 02-26-2003 10:52 AM

Ok, I guess I don't really understand. If your want a fixed address assigned to your printer. Why don't you manually assign a static IP to your network pritner? Won't that be easier and save your linux box from running an extra process?

clsgis 05-29-2017 01:42 PM

This thread shows up when folks search for an error from ISC dhcpd "DHCPDISCOVER from ma:c:ad:dr:es.s via interface: network range: no free leases"

Most of the answers in forums say "you need a range statement" and then the OP complains "that didn't fix it" and the thread ends.

Modern versions of ISC's DHCPd require that range statement to be inside the subnet definition. EG,

range 192.168.1.100 192.168.1.150;
subnet 192.168.1.0 netmask 255.255.255.0 {
default-lease-time 6000;
max-lease-time 70200;
}

will throw the error, and repeating the range statement will fix it:

range 192.168.1.100 192.168.1.150;
subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.100 192.168.1.150;
default-lease-time 6000;
max-lease-time 70200;
}


All times are GMT -5. The time now is 08:03 PM.