-   Linux - Networking (
-   -   Dhcp problems with debian linux-image-2.6.15-1-686 in etch (

notapplicable 02-12-2006 09:06 PM

Dhcp connection problem with debian linux-image-2.6.15-1-686 in etch
I recently installed the new kernel in debian etch and found, after booting that the networking would not work. When I ran dhclient, it would just keep on sending dhcp requests on port 67 to I would never recieve any dhcp offers. Even after waiting for a long time, it never recieves any. In kernel 2.6.12, dhclient works fine and I am able to use networking. (I am using 2.6.12 with wireless right now :) )

Any ideas on how to fix this?

ichrispa 02-13-2006 12:29 AM

is the routing table correct?

type "route" to get the tables printed, check if the kernel is aware of the network. If the network address is not registered, all incoming datagrams from that network will be dropped.

Have tcpdump run on the dhcp server, or run dhcpd with the -f option. Check if the server is responsive (my guess is that he is, the client just drops the responses as a result of malconfiguration...)

notapplicable 02-13-2006 12:02 PM

Oh yes, I forgot to say that the computer is an IBM 600X without an ethernet port and I have to use a PCMCIA card to use ethernet. I think this might be part of the problem because I also tried it on a T23 and the networking worked just fine.

notapplicable 02-13-2006 06:08 PM

I just tried typing route and it says kernel ip configuration and that's it. The table is empty. What should I do now?

notapplicable 02-13-2006 09:45 PM

When I type route in 2.6.12, I get something but in 2.6.15, I get an empty table. What should I do? My dhcp server is just a wireless router... I don't know how to run a dhcpd -f or something on a router...


notapplicable 02-14-2006 11:46 AM

Is anyone around to answer my question?

ichrispa 02-15-2006 03:14 PM

Yes, sorry. I dont have permanent internet access, sorry again.

Now, how you access the ethernet is not important at this point. If they transmit IP, the routing tables and ipchains are valid means of manipulating traffic.

You need to add a route from your machine in and out of the network. try typing this ($ is the prompt):
$route add -net netmask dev eth0

Now the kernel knows that everything from and to is to be fed through eth0. Adjust the values to your network (copy those from 2.6.12?).
For info about what route is and does, type ($ is the prompt):
$info route

You dont habe to read it all, but it could give you a hint as to how to use route as syntax. If you have questions or if it doesn't work, post. I will try to be on more frequently...

notapplicable 02-15-2006 06:39 PM

I tried that (using my numbers) and tried dhclient. It still does the same thing (never get any dhcpoffers) and after a while, the route table becomes empty again.

What do you mean by copying the values from 2.6.12?

notapplicable 02-15-2006 11:54 PM

Also, when I do this,

It says SIOCADDRT: No such device
after typing in
route add -net netmask dev eth0

ichrispa 02-16-2006 06:57 AM

By copy I meant "look what settings that kernel had while booting and apply them to the new one".

Is the pcmcia ethernet card even recognized by the system? type
which will list the network devices available to you and it is a way to manually configure you IP and netmask. If you know the address of the router, ping it to see if the network is working at all. There is at least one device registered, the loopback device. perhaps the card is called something else than "eth0"?

If I am right, then this problem extends far beyond you dhcp problem, I think you don't have the drivers for the pcmcia card (did you even enable the support for it when compiling the kernel?). If you do not have the drivers available go to the manufacturers homepage and check if he has them. If not, write to their support and demand them (I am a bit sceptic about 3rd party drivers)!

notapplicable 02-16-2006 11:37 AM

Never mind, I fixed the problem. All I had to do was type irqpoll as a startup option and the networking just worked. I don't know why. Can anyone explain this?

All times are GMT -5. The time now is 10:16 PM.