-   Linux - Networking (
-   -   dhcp on boot... (

hross 03-07-2004 10:50 AM

dhcp on boot...
Alright, I am stumped on this one:

I recompiled my 2.4 kernel recently and dhcp on startup has ceased to work properly for me. Here is what I have tried:

- My ethernet card works fine, I ran netconfig and set up a static IP with the same properties as DHCP and was able to connect to the internet.

- I ran netconfig and set up DHCP. Then I set permissions on rc.inet1 to 000 to prevent it from running on startup, then reset them after logging in as root and ran it from the console... no errors, no problems, I was able to obtain an IP address and ping the router.

- Searched the forum and googled to no avail.

I feel like I'm missing something basic, but I just don't know what it is...

Here is the output I get from dhcpd on startup (this doesn't seem right):


dhcpd[163]: broadcasting DHCP_REQUEST for

dhcpd[163]: broadcastAddr option is missing in DHCP server response. Assuming

dhcpd[163]: dhcpIPaddrLeaseTime=86400 in DHCP server response.

dhcpd[163]: dhcpT1value is missing in DHCP server response. Assuming 43200 sec

dhcpd[163]: dhcpT2value is missing in DHCP server response. Assuming 75600 sec


After which I run ifconfig and get the following (note the RX errors):


eth0 Link encap:Ethernet HWaddr 00:80:AD:73:97:EA
inet addr: Bcast: Mask:
RX packets:65 errors:335 dropped:0 overruns:0 frame:0
TX packets:1 errors:4 dropped:0 overruns:0 carrier:4
collisions:0 txqueuelen:100
RX bytes:9139 (8.9 Kb) TX bytes:86 (86.0 b)
Interrupt:11 Base address:0xd800

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:784 (784.0 b) TX bytes:784 (784.0 b)


The connection *works*, but if I try to ping the router I get a reply time of 1000 ms or so. If I then do an "ifconfig eth0 down", 'ifconfig eth0 up", everything goes back to normal and a reply time from the router is on the order of .5 ms.

Any thoughts?

All times are GMT -5. The time now is 04:34 AM.