-   Linux - Networking (
-   -   DHCP not working (

swiezy 10-20-2007 06:21 PM

DHCP not working
Hello there,
recently I installed Slackware 12 and since then I can't get my internet connection operational :( The details:
I am using Toshiba Tecra m2 with intel Pro/100 ethernet card.
Slackware is loading eepro100 driver for my ethernet card.
My Lan looks like that: DSL modem <-> router with cloned mac adress of my NIC <-> my laptop.
I haven't change anytihng in the kernel.
Though lspci shows that there is mentioned before ethernet card, ifconfig doesn't show it. I can get my eth0 interface up by:

ifconfig eth0 up
but it doesn't solve anything. There is still no net.
Please help!

d2490n 10-20-2007 07:20 PM

have you tried #dhcpcd eth0?

edit: eth0 not eth1

swiezy 10-21-2007 06:54 AM

Yes I did, after I put

dhcpcd eth0
screen becomes still and after about 2 minutes prompt line is returned. But still no net.

I tried it with different combinations like

ifconfig eht0 up
or with IP that I should be using that is, but net is still unreachable.
Though when I've used

ifconfig eth0 up
I could log into my router through links and I was able to ping it.

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.022 ms
64 bytes from icmp_seq=2 ttl=64 time=0.008 ms
64 bytes from icmp_seq=3 ttl=64 time=0.005 ms
64 bytes from icmp_seq=4 ttl=64 time=0.005 ms
64 bytes from icmp_seq=5 ttl=64 time=0.006 ms
64 bytes from icmp_seq=6 ttl=64 time=0.005 ms
64 bytes from icmp_seq=7 ttl=64 time=0.006 ms
64 bytes from icmp_seq=8 ttl=64 time=0.005 ms

--- ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 6996ms
rtt min/avg/max/mdev = 0.005/0.007/0.022/0.006 ms

I wasn't able to ping it though when I get eth0 up with (my router).
I am confused mostly because I really don't know much about lan and networking...

One more thing, I have checked syslog and there is this:

Oct 21 12:36:49 aster dhcpcd[2626]: timed out waiting for a valid DHCP server response
Oct 21 12:37:20 aster dhcpcd[2659]: timed out waiting for a valid DHCP server response

I have browsed google for it, but haven't found anything usefull.

d2490n 10-21-2007 07:51 AM

ok, im not very experienced in this area either but are you shore that dhcp is turned on in your router? have you tested it with another computer or os? sorry i cant be more helpful.

swiezy 10-21-2007 08:21 AM

yeah, i dual boot on my lap, in win xp everthing is just fine. I thought that there was somekind of issue with the NIC driver but it is loaded properly. Even when i remove it

modprobe -r eepro100
and than load it again nothing is changing.
Thanks for your interest :)

smuggly 10-21-2007 08:39 PM

I Know Its Obvious But Have U Dbl Checked The Nameserver Aspect,Make Sure All Your Names /domains Are In Order?I Had The Prob.

swiezy 10-22-2007 09:47 AM

I think that when I use DHCP I don't have to put ip or domain name. But I'll check everything in windows and will give it a try in slack. I will also try to connect without router.
Wish me luck ;)!

teabag_46 10-22-2007 02:59 PM

I have the same problem. Dual booting XP/Slack 12. Last week, my 'little darlings' managed to mess up my network. Finally managed to get the XP back online, but even after doing a complete re-install on my Slack, it won't connect.

swiezy 10-22-2007 04:06 PM

I am glad that there is someone else with the same problem, that means that I am not crazy (yet).
I have tried to set STATIC IP by 'netconfig' but it didn't work. I also downgraded to Slack 11, but I have the same problems as with 12.
I am getting sad sad sad... Tommorow I might try another distro, just to check it out. Or maybe I will search for my slack 10.2 cd-roms... I would just like to have slack back.. is it to much...?

larkl 10-22-2007 06:57 PM

Can you clarify, the router has a static IP address and is it or Can you ping on the PC (nternal loopback) and see if it responds? THen I would assign a static IP (the one that isn't assigned to the router) to the PC NIC and then ping that from the PC. THen try to ping the router from the PC. YOu don't have an embedded motherboard NIC and an add-on NIC (don't laugh - it trips me up everytime on my Dell with a failed motherboard NIC).

swiezy 10-23-2007 04:38 AM

Case solved :D
Guys from solved the case.
If you got similar problem then:
Set your IP to static ip with net config. In my option it looked like that:
My ip:
Gateway ip:
And the thing i didn't set before... dns ip. You can put it in /etc/resolv.conf, i had to put my router (gateway) ip, it goes like this: nameserver
And everything works :)

All times are GMT -5. The time now is 03:29 AM.