-   Linux - Networking (
-   -   DHCP, LTSP, Bootable Network Card (

atmelton 01-13-2007 09:23 AM

DHCP, LTSP, Bootable Network Card
I guess I should first explain my setup. I have Vmware Server running Fedora Core 5. On Fedora I have installed the LTSP Server and it is up and running, as far as I can tell, properly. I have two NICs in this machine (the host machine). The virtual machine has two NICs as well. The first NIC (eth0) is bridged directly to the physical network, eth1 is bridged to the physical network as well. Eth0 is attached to the DSL router and eth1 is attached to a switch that I have 1 client machine plugged into, this is the machine that will boot from the LTSP server.

In the LTSP client machine I have just put in a bootable network card that I bought from, it is an A-Open AON-325D. When I turn on the client machine it will get an IP address from the server in the range that I have gave the DHCP server, it also sees the IP address of the server. It appears to start working and then it displays the following:


NET: Registered protocol family 17
Using IPI Shortcut mode
Freeing unused kernel memory: 164K freed
================================================== ====
Running /linuxrc
Mounting /proc
input: AT Translated Set 2 keyboard as /class/input/input0
linuxrc: Installing natsemi driver
modprobe natsemi
insmod /lib/modules/
natsemi dp8381x driver, version 1.07+LK1,0,17, September 27, 2002
originally by Donald Becker <>
2.4.x kernel port by Jeff Garzik, Tjeerd Mulder
natsemi eth0: NatSemi DP8381(56) at 0xfff7e000 (0000;00;0b,0), 00:09:5b:e0:1c:eb, IRQ 10, port TP,
Running dhcpcd on port 67
eth0: DSPCFG accepted after 0 usec,
eth0: remaining active for wake-on-lan

ERROR! dhcpcd failed!

Kernel panic - not syncing: Attempted to kill init!
So I can't get that machine to boot to the LTSP, however, I can set up another virtual machine and have it's NIC use the NIC that is attached to the ethernet switch that the other machine is connected to and it will boot up just fine into the LTSP server.

I'm not sure if there is anything else I can provide for you to maybe help me with this issue. If anyone can help me, I'd be extremely appreciative. I've been trying to set up a LTSP server for a couple of years now, finally bought a bootable NIC and am SOO close to getting it going. OK, sorry for rambling! Thanks in advance!

atmelton 01-14-2007 11:50 AM

Still working on it.
I've tried adding the bootable network card's MAC address to the DHCP configuration file and I still get the same message.

atmelton 01-14-2007 11:58 AM

My dhcpd.conf file
Here is my dhcpd.conf file, thought it might help someone to help me.


# dhcpd.conf

allow booting;
allow bootp;

ddns-update-style ad-hoc;

option subnet-mask;
option broadcast-address;
option routers;
option domain-name-servers;
option domain-name ""; # You really should fix this
option option-128 code 128 = string;
option option-129 code 129 = text;

get-lease-hostnames true;

option root-path "";

subnet netmask {
if substring (option vendor-class-identifier, 0, 9) = "PXEClient" {
filename "/lts/";
filename "/lts/vmlinuz-";
# If you need to pass parameters on the kernel command line, you can
# do it with option-129. In order for Etherboot to look at option-129,
# you MUST have option-128 set to a specific value. The value is a
# special Etherboot signature of 'e4:45:74:68:00:00'.
# Add these two lines to the host entry that needs kernel parameters
# option option-128 e4:45:74:68:00:00; # NOT a mac address
# option option-129 "NIC=ne IO=0x300";
host ws002 {
hardware ethernet 00:40:F4:E8:DA:6D;
filename "lts/vmlinuz-";

atmelton 01-14-2007 12:35 PM

Getting closer
WOO HOO! I've just got one step closer! I guess I can be called an idiot now. I took out the two other network cards (an old ISA 3-COM card and a Netgear card I bought last year for it)! I turned it on after I took them out and didn't get a kernel panic. Now all I have to do is configure the display settings because when it got to the point where it is suppose to show a login screen the monitor went into low power standby, so I am pretty sure all I have to do now is to configure that terminal's resolution, etc. At least I hope that is all I have to do!

atmelton 01-14-2007 02:54 PM

SUCCESS IS MINE! I got it to working! I kept trying to use S3 mode because I know the graphics card is S3, or at least that's what it said when Windows was running on it. I changed the mode to Vesa and it worked, no problems! YAY! FINALLY! I've got a terminal services server!

UhhMaybe 04-24-2007 05:22 PM

S3 is the Manufacturer. S3 Mode is a variety of choices for standby or power conservation.

All times are GMT -5. The time now is 09:32 AM.