LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-11-2003, 08:31 PM   #1
toastermaker
Member
 
Registered: Oct 2003
Location: coastal alabama, united states
Distribution: Mandrake 10.0 official, slackware 9.1
Posts: 219

Rep: Reputation: 30
dhclient / cant use keyboard on internet


I can use wireless card to surf internet but when I try to type, in any website no letters appear and mozilla freezes

I just got the wireless card to allow internet connection for 1st time today. This prob. has been there from the start.

I have had no problem with mozilla, using the onboard nic and cat5 cable through the same router and adsl modem. (the router supports both wired and wireless) when dhclient is not running

I hope this is known issue as I know not squat about configuring networking. I have Defaulted, Homer'd , Beat and Begged my way to get this far.

Any ideas whats causing this?

Mandrake 9.2
iblitzz wireless AP w 4 port router
iblitzz wireless card w/ ADM8211 chipset using "105_src" driver from ADMtek's website.

Thanks for any help!

<EDIT>
The driver for wireless card (I dont think) loads from /etc/modules.conf , I wasnt able to get the driver to load at boot so I made a symlink to the driver. The symlink is in /<path>/init.d

Last edited by toastermaker; 12-12-2003 at 05:14 AM.
 
Old 12-12-2003, 01:17 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
I had a similar problem a few weeks ago. There seems to be problems with mozilla and over elaborate iptables rules. What rules do you ahve:
iptables -L
 
Old 12-12-2003, 02:55 PM   #3
physcofish
LQ Newbie
 
Registered: Sep 2003
Distribution: Gentoo r1.4
Posts: 1

Rep: Reputation: 0
I also get this problem with my iptables setup as:
Code:
:INPUT DROP [659:78097]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [9839:1381477]
:mychain - [0:0]
-A INPUT -j mychain 
-A mychain -i eth0 -m state --state RELATED,ESTABLISHED -j ACCEPT
If I take go:
Code:
bash-2.05b# iptables -P INPUT ACCEPT
The problem would go away.

Later I found out that if I add this:
Code:
bash-2.05b# iptables -A INPUT -p tcp -s 127.0.0.1 -j ACCEPT
My setup would work even with INPUT set to DROP all NEW connections.

Last edited by physcofish; 12-12-2003 at 03:31 PM.
 
Old 12-12-2003, 03:29 PM   #4
toastermaker
Member
 
Registered: Oct 2003
Location: coastal alabama, united states
Distribution: Mandrake 10.0 official, slackware 9.1
Posts: 219

Original Poster
Rep: Reputation: 30
Thank you,
Here is output from iptables -L, this is the 1st time I have seen a iptable but on a hunch this one looks kind of simple?

root@localhost teabear]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
[root@localhost teabear]#

What do you think?

Thank you.
 
Old 12-12-2003, 07:39 PM   #5
toastermaker
Member
 
Registered: Oct 2003
Location: coastal alabama, united states
Distribution: Mandrake 10.0 official, slackware 9.1
Posts: 219

Original Poster
Rep: Reputation: 30
Not totally solved, but I am now using my keyboard over my wireless nic.

The only thing I've done to try to get it fixed is starting different things in differing order (eth0, eth1, dhclient)
I lost track of what combo worked, but it includes not having eth0 up at all. Thats why I cant claim success.

I have a 4 port router, but 5 puters, so I was going to use 2 of the puters hooked together with internet connection sharing (if thats possible with my configuration), and so I would need two nics going at same time on one of them.

So I am still looking for answer but to new variation of question.

New Question might be :
"when trying to have two nics "up" at same time I cant type into browser while at any website"

I will go search this new variation of problem.
If I don't get problem solved with searching should I bump this thread or start a new one because of the modification in problem?

Thank you for your help and replies.
 
Old 12-15-2003, 05:25 PM   #6
toastermaker
Member
 
Registered: Oct 2003
Location: coastal alabama, united states
Distribution: Mandrake 10.0 official, slackware 9.1
Posts: 219

Original Poster
Rep: Reputation: 30
I have not been able to get my two nics going at the same time without "freezing" web browser when I try to type.
I searched for "two nics" and got a lot of hits. One of them looked like something I might be able to handle so I tried configuring both nics manually after removing ifcfg-ethx and commenting out eth drivers in modules.conf. I wasnt able to configure properly and wound up re-deleting the new ifcfgs and getting mandrake control center (gui) to get configuration back to where I started.

Any recomendations? I need/want to use one nic for Internet connection sharing and the other nic to the router and modem.
The wireless card driver wasnt included with mandrake 9.2 . I got it off the internet.

If it would make "The" difference I can go get A nic that has the driver already included with mandy 9.2?

Thanks for any help.

Edit:
just saw this:
http://www.linuxquestions.org/questi...hreadid=125598
does it look like it will apply to my situation?

<edit>
It turns out that while my internet connection "fired up" when I ran dhclient, and I could surf the web as long as I didnt try to type into my browser, solving this particular problem only required me to add "eth0" to dhclient instead of just using dhclient.
Appearently dhclient trying to run my local loopback and eth0 at the same start/time caused my problem.

Last edited by toastermaker; 01-05-2004 at 07:01 AM.
 
Old 06-04-2004, 01:15 AM   #7
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 862

Rep: Reputation: 118Reputation: 118
Cool Sweet!

Thanks, toastermaker, for your last post! I had exacly the same problem and setup and using "dcclient eth0" as opposed to simply "dcclient" fixed it for me. My internet is working a lot faster too now that it's not trying to compete with my manual ip settings (I think).

Have a good one.

--Dane
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dhclient shows IP, but internet including ping wont work mjkelly93 Linux - Networking 1 10-09-2005 07:46 AM
dhclient needed every time i boot to get internet michiaki Linux - Newbie 5 06-26-2005 08:37 PM
Internet Keyboard odd Linux - Software 1 06-14-2004 07:53 AM
Internet keyboard? carluva Linux - Hardware 3 05-17-2004 06:09 AM
Cannot conect to the internet. ¿dhclient? Guayacan Linux - Networking 1 01-01-2004 04:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration