LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Networking (http://www.linuxquestions.org/questions/forumdisplay.php?f=3)
-   -   "...Device eth0 has different MAC address than expected,.." (http://www.linuxquestions.org/questions/showthread.php?t=516793)

lothario 01-05-2007 10:51 PM

"...Device eth0 has different MAC address than expected,.."
 
I had to setup 3 identical Fedora Core 4 systems for a custom application training session.
All 3 machines have identical hardware.

So I got the first machine configured as per the requirements.
Then I used "Ghost for Linux" to make an image of this PC on a ftp server.
I used the "Ghost for Linux" boot CD to put the same image on the 2nd machine.

Machines 1 and 2 are DHCP clients and they are working pretty much as expected.

But ONLY on the 2nd machine, I keep getting this warning (on the console) when I reboot:
Quote:

"Shutting down interface eth0: Device eth0 has different MAC address than expected, ignoring."
Ok, yes the mac address of the 1st machine was inherited by the 2nd machine via the ghost imaging.
And it is being ignored. But I would like to fix this warning.

How do I fix eth0 on the 2nd machine so that the inherited MAC address goes away
and therefore the above warning goes away?

jonwatson 01-06-2007 12:40 AM

On a Debian machine I would investigate the /etc/iftab file. I'm not sure if this is the same file on a FC machine, but it might point you in the right direction.

lothario 01-06-2007 06:16 AM

Thanks for the tip.
It helped me find the right file to edit:

/etc/sysconfig/network-scripts/ifcfg-eth0

Just updated the HWADDR value and rebooted the system.
Problem solved.

jonwatson 01-06-2007 12:14 PM

Good to know, thanks!

IonutIonescu 02-25-2010 03:55 PM

thanks, just the ticket
 
had similar problem with RedHat RHEL5.4 on and old Toshiba laptop.
Edited the file and it worked.

montego 03-18-2013 06:06 PM

I have the same problem.
When I try to change MAC with the following commands:

ifconfig eth0 down
ifconfig eth0 hw ether aa:bb:cc:dd:ee
ifconfig eth0 up


after service network restart it gives me the error: Device eth0 has different MAC address than expected, ignoring.

I also tried to update /etc/sysconfig/network-scripts/ifcfg-eth0, but after the restart nothing happens, the new MAC has no effect.

Is there another way to do it?

P.S. I am using Centos 6.4.


All times are GMT -5. The time now is 12:28 PM.