LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-16-2002, 02:40 AM   #16
netdemon
LQ Newbie
 
Registered: May 2002
Location: Northeast US
Distribution: Fedora
Posts: 24

Rep: Reputation: 15

RoadRunner in the Albany, NY area also allows 3 IPs. They are not technically static ips, but they won't change unless you disconnect. I really wish IPV6 was implemented by ISPs. It is annoying having to set up dynamic dns for my web domain. If IPV6 was implemented, we could have as many IPs as we wanted. Also, it would make it easier for those times you have to recover your IP for whatever reason (It could be memorized). But, oh well... *sigh*

I had a similiar problem and I found that connecting it directly to the modem was the only way once. Then I reinstalled redhat and connecting it through the hub and resetting the modem worked the other time. Go figure.

I am also having that problem:
"Could not look up internet address for dhcp-xxx-xxx this will prevent gnome... etc"
(x represents a number)

I have no clue how to solve that.

I also connect through SSH to my X server on the Linux box in NY (currently) from my Windows machine in CT.

After I enable X11 packet forwarding on SecureCRT (an SSH client), I get the following upon logon:
/usr/X11R6/bin/xauth: (stdin):1: bad display name "dhcp-xxx-xxx:10.0" in "add" command


I have to manually set the DISPLAY=localhost:10.0

Afterwards, X programs appear on X-Win32 (gedit, xterm), but not the gnome desktop itself.

Running gnome-session - I get the error aforementioned about problem running gnome (which locally doesn't affect anything except for an annoyance).

remotely, though... I get the following error after I click continue and gnome fails to load on X-Win32:

SESSION_MANAGER=local/dhcp-xxx-xxx:/tmp/.ICE-unix/2753
Gdk-ERROR **: X connection to localhost:10.0 broken (explicit kill or server shutdown).

startx gives me this:

(~)> startx
hostname: Unknown host


Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
Please report problems to xfree86@xfree86.org.

xinit: unexpected signal 2

Couldnt get a file descriptor referring to the console




What I think is this might be related to the dhcp-xxx-xxx problem for gnome somehow... as in - maybe caused by the same problem.

Someone from irc.openprojects.org #redhat said that their isp comcast.net doesn't use client-id and to try the following in:
/etc/sysconfig/networking/devices/ifcfg-eth0
add line:
DHCP_HOSTNAME=blah
and restart network

Unfortunately, that didn't work.

This is my /etc/hosts file:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
 
Old 05-16-2002, 02:48 AM   #17
netdemon
LQ Newbie
 
Registered: May 2002
Location: Northeast US
Distribution: Fedora
Posts: 24

Rep: Reputation: 15
I found the fix:

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain dhcp-xxx-xxx

Where dhcp-xxx-xxx is your hostname when you type the hostname command.

It still didn't allow me to login to gnome remotely, but at least I got passed the error message before I got the sockets error :-)
 
Old 05-16-2002, 04:56 AM   #18
mikek147
Member
 
Registered: Mar 2002
Location: Elyria, Ohio
Distribution: Debian, Nothing else required
Posts: 141

Rep: Reputation: 15
A couple notes here.

When a dhcp client requests an identity, it gets a lease time, say 24 hours. Once a client receives a lease, every 12 hours therafter, it will request a lease renewal. On dialup ppp type connections, this lease time is quite short, allowing for ip reuse for another client. In the case of cable/dsl, this lease time is long. This cuts down on renewal request traffic.

In order to get around the single ip from an ISP, install an Ethernet Cable/DSL router, in my case a Linksys BEFSR41 $80 US. The router takes the single ip from the ISP on the internet side of the router, and provides a dhcp server, independant of your ISP, for a private network, generally 192.168.x.x. With this method of internet connection, you could potentially have 254 hosts on your private net. This also allows you to set a static ip for your linux hosts, more perferable than dynamic ip. In my case, I set my Linux box and my network printer to 192.168.1.10 and 192.168.1.50, respectively. While my MS PCs use DHCP in the range of 192.168.1.100-150.

Hope this helps. -mk
 
Old 05-24-2002, 07:55 AM   #19
netdemon
LQ Newbie
 
Registered: May 2002
Location: Northeast US
Distribution: Fedora
Posts: 24

Rep: Reputation: 15
Angry It only was a temporary fix!

My hostname changed, and now it didn't work any more. I don't want to have to edit that file every time the hostname (dhcp-xxx-xxx) changes. So, I changed /etc/hosts back to:

127.0.0.1 localhost.localdomain localhost

And now I am looking for answers again :-(

This seems to be a bug in Linux. I am a newbie though, so I have no clue.
 
Old 05-26-2002, 11:34 PM   #20
netdemon
LQ Newbie
 
Registered: May 2002
Location: Northeast US
Distribution: Fedora
Posts: 24

Rep: Reputation: 15
I am now in Connecticut on a different cable service and I am still having the same problem.
 
Old 05-27-2002, 12:37 AM   #21
biggiefatts
Member
 
Registered: May 2002
Location: Buffalo, NY
Distribution: Mandrake 9.0, Red Hat 8.0
Posts: 60

Rep: Reputation: 15
netdemon...I myself am pretty new to Linux also. I am however familiar with networking in general. What I would suggest as a quick and simple fix is the samething that Mikek147 suggested a couple posts ago. If you have the means to purchase a Cable/DSL router, it will solve all of your problems. With the router you can assign a static private IP address to your Linux box. This way, if your Interent IP with RR changes you don't have to worry about it. The router will pick up the new address and everything will work the same without interuption. I use A LinkSys 4 port Cable/DSL router. The price has really come down on it lately and it is very simple to set up. If you would like to see some screen shots of the sett up program click here:

http://www.archide.com/~dave/linksys/index.html

If you have any questions please feel from to email me directly through the message boards.

PS: excuse the fact that the screen shots are coming from a windows machine. I still haven't gotten used to using GIMP so I used Photoshop to make the shots.

Last edited by biggiefatts; 05-27-2002 at 12:41 AM.
 
Old 05-27-2002, 01:46 AM   #22
netdemon
LQ Newbie
 
Registered: May 2002
Location: Northeast US
Distribution: Fedora
Posts: 24

Rep: Reputation: 15
Very strange..

I went into the Redhat Network Configuration program "neat" and went into the DNS section and removed the settings for domain, and Primary and Secondary DNS (which I must have manually set once upon a time) and the problem is gone :-)

BTW - Since Cox Cable only allows one IP, I was planning to get a router (but one capable of IPV6), etc etc. I am anal, though, and wanted to figure out what the problem was first in case I ever encounter it again.
 
Old 06-03-2002, 12:05 AM   #23
netdemon
LQ Newbie
 
Registered: May 2002
Location: Northeast US
Distribution: Fedora
Posts: 24

Rep: Reputation: 15
I patched my kernel, and the problem returned again. :-(

See also:
http://bugzilla.redhat.com/bugzilla/...g.cgi?id=55173
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
determining ip information for eth0...failed flamah Linux - Newbie 38 02-11-2008 11:30 PM
Determining IP information for eth0....failed linuxnew Linux - Networking 12 05-11-2004 07:05 AM
determining ip information for eth0...failed flamah Linux - Networking 5 02-27-2004 01:18 PM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 06:33 PM
Determining IP information for eth0: failed... rajeshdorai Linux - Networking 5 10-09-2003 10:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration