LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Determining IP information for eth0: failed... (https://www.linuxquestions.org/questions/linux-networking-3/determining-ip-information-for-eth0-failed-102095/)

rajeshdorai 10-09-2003 11:59 AM

Determining IP information for eth0: failed...
 
Hello,

I recently got a Dell Precision 650n (dual processor Xeon) with Red Hat Linux 9.0 installed. I installed almost all of the extra packages as part of the first boot.

I am currently trying to setup the TCP/IP and it fails. As of now, I am try to connect via a DHCP. I tried the following and their results are shown below. I would very much appreciate any help you can provide.

1. ifconfig

eth0 Link encap:Ethernet HWaddr 00:0B:DB:58:FF:B6
UP BROADCAST RUNNING MULTICAST MTU:1500 metric:1
RX packets:18903 errors:0 dropped:0 overruns:0 frame:0
TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:17134888 (16.3 Mb) TX bytes:14186 (13.8 kb)
Interrupt:24 Base address:0xecc0 Memory:fe5e0000-fe600000

lo Link encap: Local Loopback
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:43667 errors:0 dropped:0 overruns:0 frame:0
TX packets:43667 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2823500 (2.6 Mb) TX bytes: 2823500 (2.6 Mb)


2. ifconfig eth0 up

This does not produce any output

3. cat /etc/modules.conf

alias usb-controller ehci-hcd
alias eth0 e1000
alias usb-controller1 usb-uhci
alias ieee1394-controller ohci1394
alias block-major-20 off
alias char-major-195 nvidia
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f
/etc/.aumixrc -L > /dev/null 2>&1 || :
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S > /dev/null 2>&1 || :

4. lspci

lspci: /usr/share/hwdata/pci.ids, line 2687: duplicate entry


5. lsmod &

Ehe entry for e1000 is

e1000 50924 1

6. cat /proc/net/dev

The entries for errs, drop, fifo, frame, compressed, multicast for both lo and eth0 are 0

7. dmesg | more |grep eth0

eth0: Intel(R) PRO/1000 Network Connection
e1000: eth0 NIC Link is Up 10 Mbps Half Duplex

8. cat /proc/pci

One of the entries is

Bus 3, device 14, function 0:
Ethernet controller: Intel Corp. 82545EM Gibabit Ethernet Controller (rev 1).
IRQ 24
Master CApable. Latency=64. Min Gnt=255.
Non-prefetchable 64 bit memory at 0xfe5e0000 [0xfe5fffff].
I/O at 0xecc0 [0xecff].

superbondbond 10-09-2003 12:17 PM

by typing ifconfig alone it simply returns the current configuration of the network device(s). It is showing that eth0 exists but is not currently configured. you can manually configure the device using the ifconfig command. here's a link to the man page

or much easier try
redhat-config-network

porous 10-09-2003 12:20 PM

or try #setup
and chose network configuration

rajeshdorai 10-09-2003 12:28 PM

Activating network device ... failed..
 
I just did the redhat-config-network:

It says:

"Cannot activate network devide eth0!

Determining IP information for eth0... failed.

stickman 10-09-2003 05:42 PM

What does /etc/sysconfig/network-scripts/ifcfg-eth0 contain?
Does it look anything similar to:
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

If you don't have this file, create it and restart the network service.

rajeshdorai 10-09-2003 10:50 PM

Thanks very much Stickman.

I checked up the ifcfg-eth0 file that you mentioned. It has
the parameters and the values as you mentioned. I recently wanted to change over to static ip and so, I have BOOTPROTO=none instead of BOOTPROTO=dhcp.

Now, for some reason, my system works. I am still not sure what change I had made that made it work... But, anyhow, thanks so much for your time and help. I very much appreciate it.


All times are GMT -5. The time now is 10:53 AM.