LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-15-2015, 04:15 AM   #1
hiboy
LQ Newbie
 
Registered: Jul 2015
Posts: 11

Rep: Reputation: Disabled
debian network down after reboot


Here is the story:
I have a debian/wheezy installed on harddisk A, and I add A to a new computer. After I login debian from new machine, I need to reinstall the network driver. So I install the new driver e1000e-3.2.4.2. And the network start to work.

After I reboot, the network goes down again. Then I google for the answer but with no luck. Every configure looks fine, but I can't even ping the gateway.

Someday I swear to fix it and google deeply. After I remove the driver e1000e-3.2.4.2 and install e1000e-3.1.0.2, the network go to work !!!

HOWEVER, after I reboot, the network goes down again. There must be something wrong hiding behind that I don't know. Someone please help me.

Information list below may be useful:
Code:
$ifconfig
    eth0      Link encap:Ethernet  HWaddr 98:90:96:9d:0b:75  
              inet addr:10.214.52.112  Bcast:10.214.52.255  Mask:255.255.255.0
              inet6 addr: fe80::9a90:96ff:fe9d:b75/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:121 errors:0 dropped:0 overruns:0 frame:0
              TX packets:85 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:18621 (18.1 KiB)  TX bytes:12635 (12.3 KiB)
              Interrupt:20 Memory:f7100000-f7120000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:243 errors:0 dropped:0 overruns:0 frame:0
              TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:18784 (18.3 KiB)  TX bytes:18784 (18.3 KiB)
Code:
$route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         10.214.52.1     0.0.0.0         UG    0      0        0 eth0
    10.214.52.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
Code:
$cat /etc/network/interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet static
    address 10.214.52.112
    netmask 255.255.255.0
    gateway 10.214.52.1
    dns-nameservers 10.10.0.25
    dns-nameservers 10.10.0.21
Code:
$ping 10.214.52.1
    PING 10.214.52.1 (10.214.52.1) 56(84) bytes of data.
    From 10.214.52.112 icmp_seq=1 Destination Host Unreachable
    From 10.214.52.112 icmp_seq=2 Destination Host Unreachable
    From 10.214.52.112 icmp_seq=3 Destination Host Unreachable
    
    --- 10.214.52.1 ping statistics ---
    5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 4024ms
    pipe 3
Code:
    00:19.0 Ethernet controller [0200]: Intel Corporation Ethernet Connection I217-LM [8086:153a] (rev 04)
    	Subsystem: Dell Device [1028:05a4]
    	Flags: bus master, fast devsel, latency 0, IRQ 45
    	Memory at f7100000 (32-bit, non-prefetchable) [size=128K]
    	Memory at f7139000 (32-bit, non-prefetchable) [size=4K]
    	I/O ports at f040 [size=32]
    	Capabilities: <access denied>
    	Kernel driver in use: e1000e
 
Old 07-15-2015, 08:04 AM   #2
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874
udev will assign the next available eth# name to the interface when it sees that eth0 is allocated to the other MAC of the other machine that it booted first.

# ifconfig -a

You can rm the /etc/udev/rules.d/70-persistent-net.rules and when you reboot it will likely get the eth0 name again. For those who don't want to change /etc/network/interfaces or their firewall scripts from the assumed default of eth0. There's also some devices that have ifconfig names related to their driver name. Recalling eth1798 or some such on at least one machine. And some network drivers, even ethernet, need firmware that may not be installed by default.

$ dmesg | grep -i firmware

Lots of possibilities.
 
1 members found this post helpful.
Old 07-15-2015, 09:02 AM   #3
hiboy
LQ Newbie
 
Registered: Jul 2015
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
udev will assign the next available eth# name to the interface when it sees that eth0 is allocated to the other MAC of the other machine that it booted first.

# ifconfig -a

You can rm the /etc/udev/rules.d/70-persistent-net.rules and when you reboot it will likely get the eth0 name again. For those who don't want to change /etc/network/interfaces or their firewall scripts from the assumed default of eth0. There's also some devices that have ifconfig names related to their driver name. Recalling eth1798 or some such on at least one machine. And some network drivers, even ethernet, need firmware that may not be installed by default.

$ dmesg | grep -i firmware

Lots of possibilities.
Thank you for your reply.
the output of 'ifconfig -a' is the same as 'ifconfig'. In fact, eth0 is eth1. I may change it before installing e1000e-3.1.0.2, but I can't remember how I dit it.

$ dmesg | grep -i firmware
give
Code:
[    0.926288] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
I can't understand it. What I do next?
 
Old 07-15-2015, 11:45 AM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874
https://downloadcenter.intel.com/download/15817

vender:model seems to be 8086:153a

The e1000e-3.2.4.2.tar.gz seems to be the right driver. Is this a relatively fresh install? It seems like there used to be an e1000 (without e suffix) module. Perhaps that's still present and what is loading at boot.

$ lsmod | grep -i 1000

Perhaps check your /etc/modules for e1000 or add e1000e to it so it loads at boot. And check /etc/modprobe.d/ for any blacklist of e1000 modules.

$ egrep -r -i "e1000" /etc/modprobe.d/*

or maybe you have multiple modules in the /lib/modules/$(uname -r)/ tree that are in conflict.

$ find /lib/modules/$(uname -r)/ -iname '*e1000*'

AKA you need to uninstall the OLD driver(s) that you're not using with regards to e1000/e1000e. Just some random thoughts. It could also be that your using your OS in RAM and nothing persists between reboots. Lots of possibilities.
 
1 members found this post helpful.
Old 07-15-2015, 02:18 PM   #5
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
Quote:
Originally Posted by hiboy View Post
I install the new driver e1000e-3.2.4.2 [...] After I remove the driver e1000e-3.2.4.2 and install e1000e-3.1.0.2
How are you installing & removing these drivers?

AFAIK the e1000e driver is included in the kernel.
 
Old 07-16-2015, 02:49 AM   #6
hiboy
LQ Newbie
 
Registered: Jul 2015
Posts: 11

Original Poster
Rep: Reputation: Disabled
Thank you for your replies.

To Shadow_7
How can I confirm the version of current running driver ? what do you mean by 'relatively fresh' ?
Code:
$locate e1000
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000/e1000.ko
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
/usr/local/MATLAB/R2013a/help/dsp/csh/blocks/_d0e10007.html
/usr/local/MATLAB/R2013a/help/symbolic/mupad_ref/strmatch-d0e1000.png
/usr/share/man/man7/e1000e.7.gz
/usr/src/linux-headers-3.2.0-4-amd64/include/config/e1000.h
/usr/src/linux-headers-3.2.0-4-amd64/include/config/e1000e.h
/var/cache/man/cat7/e1000e.7.gz
It looks like the system indeed have a module of e1000. What's its relationship with e1000e ? Should I need to remove it ?

Code:
$ lsmod | grep -i 1000
e1000e                133833  0
$ egrep -r -i "e1000" /etc/modprobe.d/*
output nothing

Code:
$ find /lib/modules/$(uname -r)/ -iname '*e1000*'
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000/e1000.ko

To Head_on_a_Stick
I usually install like this.
Code:
jason@hiboy:~$ cd software/e1000e-3.2.4.2/src/
jason@hiboy:src$ sudo make install
[sudo] password for jason: 
make -C /lib/modules/3.2.0-4-amd64/build SUBDIRS=/media/wind/software/debian64/e1000e-3.2.4.2/src modules
make[1]: Entering directory `/usr/src/linux-headers-3.2.0-4-amd64'
  Building modules, stage 2.
  MODPOST 1 modules
make[1]: Leaving directory `/usr/src/linux-headers-3.2.0-4-amd64'
# remove all old versions of the driver
find /lib/modules/3.2.0-4-amd64 -name e1000e.ko -exec rm -f {} \; || true
find /lib/modules/3.2.0-4-amd64 -name e1000e.ko.gz -exec rm -f {} \; || true
install -D -m 644 e1000e.ko /lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
/sbin/depmod -a 3.2.0-4-amd64 || true
install -D -m 644 e1000e.7.gz /usr/share/man/man7/e1000e.7.gz
man -c -P'cat > /dev/null' e1000e || true
e1000e.
jason@hiboy:src$ sudo modprobe e1000e
jason@hiboy:src$ sudo service networking restart
[....] Running /etc/init.d/networking restart is deprecated because it may not r[warnble some interfaces ... (warning).
[....] Reconfiguring network interfaces...RTNETLINK answers: No such process
done.
jason@hiboy:src$ ping 10.214.52.1
PING 10.214.52.1 (10.214.52.1) 56(84) bytes of data.
From 10.214.52.112 icmp_seq=2 Destination Host Unreachable
From 10.214.52.112 icmp_seq=4 Destination Host Unreachable
From 10.214.52.112 icmp_seq=5 Destination Host Unreachable
From 10.214.52.112 icmp_seq=7 Destination Host Unreachable
From 10.214.52.112 icmp_seq=8 Destination Host Unreachable
^C
--- 10.214.52.1 ping statistics ---
10 packets transmitted, 0 received, +5 errors, 100 packet loss, time 9046ms
pipe 2
Removing like this.
Code:
$sudo ifconfig eth0 down
or $sudo ifdown eth0
$sudo rmmod e1000e
$cd e1000e-3.2.4.2/src/ && sudo make uninstall 
if [ -e /lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko ] ; then \
	    rm -f /lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko ; \
	fi
/sbin/depmod -a
if [ -e /usr/share/man/man7/e1000e.7.gz ] ; then \
		rm -f /usr/share/man/man7/e1000e.7.gz ; \
	fi
The make uninstall actually do not remove e1000e.ko. I need to remove it explicitly.

Last edited by hiboy; 07-16-2015 at 02:52 AM. Reason: refine
 
Old 07-16-2015, 07:37 AM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874
The e1000 seems like it's the OLD driver. And it's presence is likely getting in the way.

# modprobe -r e1000
# modprobe e1000e

Might be the same as the reinstall that you're currently doing. To verify that the module is the module that you think it is, look at the date/timestamp on it. If it matches the date/time of when you installed the new driver from source it's what you compiled and installed. If it doesn't, then it's from another source. If unsure, recompile and install again so you know the date/timestamp that it should have.

# modinfo e1000

Should show some information about a given module. Like description, and the possible parameters that it takes.

# modinfo e1000e
 
Old 07-16-2015, 07:38 AM   #8
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874
And since it's a network driver you will likely want to:

# ifconfig eth0 down

Before doing any modprobe -r -ness.
 
Old 07-16-2015, 01:38 PM   #9
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
Does the connection work if you just use the driver included in the kernel?
 
Old 07-16-2015, 08:56 PM   #10
hiboy
LQ Newbie
 
Registered: Jul 2015
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
The e1000 seems like it's the OLD driver. And it's presence is likely getting in the way.

# modprobe -r e1000
# modprobe e1000e

Might be the same as the reinstall that you're currently doing. To verify that the module is the module that you think it is, look at the date/timestamp on it. If it matches the date/time of when you installed the new driver from source it's what you compiled and installed. If it doesn't, then it's from another source. If unsure, recompile and install again so you know the date/timestamp that it should have.

# modinfo e1000

Should show some information about a given module. Like description, and the possible parameters that it takes.

# modinfo e1000e
It looks like the evil is not the e1000
Code:
jason@hiboy:~$ lsmod | grep -i e1000
e1000                  86156  0 
e1000e                133833  0 
jason@hiboy:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 98:90:96:9d:0b:75  
          inet addr:10.214.52.112  Bcast:10.214.52.255  Mask:255.255.255.0
          inet6 addr: fe80::9a90:96ff:fe9d:b75/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:49230 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22862 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6622405 (6.3 MiB)  TX bytes:1484116 (1.4 MiB)
          Interrupt:20 Memory:f7100000-f7120000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10713 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10713 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:985105 (962.0 KiB)  TX bytes:985105 (962.0 KiB)

jason@hiboy:~$ sudo ifconfig eth0 down
[sudo] password for jason: 
jason@hiboy:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 98:90:96:9d:0b:75  
          inet addr:10.214.52.112  Bcast:10.214.52.255  Mask:255.255.255.0
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:49255 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22871 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6625044 (6.3 MiB)  TX bytes:1484792 (1.4 MiB)
          Interrupt:20 Memory:f7100000-f7120000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10713 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10713 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:985105 (962.0 KiB)  TX bytes:985105 (962.0 KiB)

jason@hiboy:~$ sudo ifdown eth0
RTNETLINK answers: No such process
jason@hiboy:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 98:90:96:9d:0b:75  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:49255 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22871 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6625044 (6.3 MiB)  TX bytes:1484792 (1.4 MiB)
          Interrupt:20 Memory:f7100000-f7120000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10713 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10713 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:985105 (962.0 KiB)  TX bytes:985105 (962.0 KiB)

jason@hiboy:~$ ifconfig 
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10713 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10713 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:985105 (962.0 KiB)  TX bytes:985105 (962.0 KiB)

jason@hiboy:~$ sudo modprobe -r e1000
jason@hiboy:~$ lsmod | grep -i e1000
e1000e                133833  0 
jason@hiboy:~$ sudo modprobe e1000e
jason@hiboy:~$ sudo service networking restart
[....] Running /etc/init.d/networking restart is deprecated because it may not r[warnble some interfaces ... (warning).
[ ok ] Reconfiguring network interfaces...done.
jason@hiboy:~$ ifconfig 
eth0      Link encap:Ethernet  HWaddr 98:90:96:9d:0b:75  
          inet addr:10.214.52.112  Bcast:10.214.52.255  Mask:255.255.255.0
          inet6 addr: fe80::9a90:96ff:fe9d:b75/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:49270 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22912 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6626825 (6.3 MiB)  TX bytes:1494220 (1.4 MiB)
          Interrupt:20 Memory:f7100000-f7120000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10719 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10719 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:985629 (962.5 KiB)  TX bytes:985629 (962.5 KiB)

jason@hiboy:~$ ping 10.214.52.1
PING 10.214.52.1 (10.214.52.1) 56(84) bytes of data.
From 10.214.52.112 icmp_seq=2 Destination Host Unreachable
From 10.214.52.112 icmp_seq=3 Destination Host Unreachable
From 10.214.52.112 icmp_seq=6 Destination Host Unreachable
^C
--- 10.214.52.1 ping statistics ---
9 packets transmitted, 0 received, +3 errors, 100 packet loss, time 8048ms
pipe 2
I think I have removed e1000 and inserted e1000e, but the network is still down.

Code:
jason@hiboy:media$ locate e1000
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000/e1000.ko
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
/usr/local/MATLAB/R2013a/help/dsp/csh/blocks/_d0e10007.html
/usr/local/MATLAB/R2013a/help/symbolic/mupad_ref/strmatch-d0e1000.png
/usr/share/man/man7/e1000e.7.gz
/usr/src/linux-headers-3.2.0-4-amd64/include/config/e1000.h
/usr/src/linux-headers-3.2.0-4-amd64/include/config/e1000e.h
/var/cache/man/cat7/e1000e.7.gz

jason@hiboy:media$ ll /lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000* -R
/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000:
 140
-rw-r--r-- 1 root root 139328  6 17 08:46 e1000.ko

/lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/intel/e1000e:
 4944
-rw-r--r-- 1 root root 5058850  7 16 21:33 e1000e.ko

Last edited by hiboy; 07-16-2015 at 09:03 PM.
 
Old 07-16-2015, 09:03 PM   #11
hiboy
LQ Newbie
 
Registered: Jul 2015
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
Does the connection work if you just use the driver included in the kernel?
Could you tell me how to setup so that I juse use the driver included in the kernel ? Thank you !
 
Old 07-17-2015, 11:21 AM   #12
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874
In debian you could move the /lib/modules/ for the current kernel. And apt-get install --reinstall linux-image-... for the current kernel.

# mv /lib/modules/$(uname -r) /lib/modules/$(uname -r)_old
# apt-get install --reinstall linux-image-$(uname -r)

Plus or minus some stuff depending on actual names. And have a backup boot option to move the _old back if things go south. Like a power outage mid process.

Although it looks like your routing is messed up, not the interface. As in the interface wouldn't have an IP if the driver wasn't working (at least partially).

# route add default eth0

# route -n
# netstat -r

Or maybe something else is at play like a bad ethernet cable.
 
Old 07-17-2015, 12:02 PM   #13
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,249
Blog Entries: 3

Rep: Reputation: 194Reputation: 194
First ping yourself;

Code:
ping -c 3 10.214.52.112
If you still get no pings then your system is the problem and you need to start looking or even re-installing your network

If pings are returned then run ethtool to see if you have a network connection;

Code:
ethtool eth0
Look at the last line. If it doesn't say "Link detected: yes" then check to ensure both ends of the cable are properly plugged in.

If all this is good reboot your router.
 
Old 07-20-2015, 07:57 AM   #14
hiboy
LQ Newbie
 
Registered: Jul 2015
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by lazydog View Post
First ping yourself;

Code:
ping -c 3 10.214.52.112
If you still get no pings then your system is the problem and you need to start looking or even re-installing your network

If pings are returned then run ethtool to see if you have a network connection;

Code:
ethtool eth0
Look at the last line. If it doesn't say "Link detected: yes" then check to ensure both ends of the cable are properly plugged in.

If all this is good reboot your router.
Thank you for your reply
I can ping myself and `ethtool eth0` says "Link detected: yes".
How to reboot the router? I can't access to the hardware router. Do you mean the router table or something software?
 
Old 07-20-2015, 08:01 AM   #15
hiboy
LQ Newbie
 
Registered: Jul 2015
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
In debian you could move the /lib/modules/ for the current kernel. And apt-get install --reinstall linux-image-... for the current kernel.

# mv /lib/modules/$(uname -r) /lib/modules/$(uname -r)_old
# apt-get install --reinstall linux-image-$(uname -r)

Plus or minus some stuff depending on actual names. And have a backup boot option to move the _old back if things go south. Like a power outage mid process.

Although it looks like your routing is messed up, not the interface. As in the interface wouldn't have an IP if the driver wasn't working (at least partially).

# route add default eth0

# route -n
# netstat -r

Or maybe something else is at play like a bad ethernet cable.
I do the linux-image reinstall and nothing change.
`route add` change nothing too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
network on reboot qwerty.yp Linux - Networking 2 12-02-2010 11:22 AM
Debian Lenny server, no connectivity to network after reboot neilgunton Linux - Networking 3 08-24-2010 10:04 AM
Reboot of Debian Lenny now Windows PCs cannot see Debian. sr_25 Debian 3 02-14-2009 02:03 PM
No Network after Reboot patisawsome Ubuntu 3 05-07-2006 10:42 PM
network down after reboot ZaphyR Linux - Networking 1 08-12-2004 09:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration