-   Linux - Networking (
-   -   Debian can't enable wifi. Atheros AR9285 card. Using ath9k driver. (

Greet 01-04-2012 09:56 PM

Debian can't enable wifi. Atheros AR9285 card. Using ath9k driver.
I just installed debina on my lenovo s205 laptop and it works great except that wifi for some reason is disabled.
The hardware button for on/off wifi is on. And when i right-click the nm-applet in my tray it shows that wireless can be enabled (not grayed out). But when I click on "Enable wireless" nothing happens.

I have Atheros AR9285 card which is using the ath9k driver I think.


03:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
        Subsystem: Lenovo Device [17aa:30a1]
        Kernel driver in use: ath9k

evo2 01-05-2012 01:36 AM


according to the Debian wiki this device should work. Please have a look at and try to follow the instructions. If you get stuck post back here explaining your situation in terms of the instructions on the wiki.



Greet 01-05-2012 05:33 AM

Thank you for your answer.

It still doesn't work.

I've done what the wiki says in the section about installing. And I don't get any errors or warnings on any of these commands, that makes me a little puzzled. So I don't get any clue on were the problem might lie.
When I run the "modprobe ath9k" command it does not give any output at all. Is that how it's supposed to be?

One thing I remember now is that during the installation it complained about "missing firmware for some devices" but it didn't say which. But it's possible that it has something to do with this.

evo2 01-05-2012 10:55 PM


hmm. What do you mean by "doesn't work"? At what stage in the instructions (eg steps 1. through 7.) does the device fail?

What are the ouputs of the following commands?

ifconfig -a

Regarding firmware, as far as I know this device should not need it. However you could try installing the firmware-linux
and firmware-linux-nonfree packages to be sure.


All times are GMT -5. The time now is 11:00 AM.