LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-03-2016, 09:51 AM   #1
adhemar
LQ Newbie
 
Registered: Jul 2016
Location: Belgium Roeselare
Distribution: Debian 8 amd64
Posts: 11

Rep: Reputation: Disabled
debian 8 centrino Advanced N 6200


Hi,
I installed Debian 8 amd64 via network cable.
In Wifi Networks, I can't select a network or Turn on Wifi.
The laptop is a HP ProBook 6550b with a Centrino Advanced N 6200 wireless card.
I edit the sources.list with:
# Debian 8 "Jessie"
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
https://wiki.debian.org/iwlwifi
I'm newbie in linux and 70+
Can somebody guide my?
Thanks in advance.
 
Old 08-03-2016, 10:14 AM   #2
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,661

Rep: Reputation: Disabled
Did you run
Code:
apt-get update && apt-get install firmware-iwlwifi
 
Old 08-03-2016, 10:50 AM   #3
adhemar
LQ Newbie
 
Registered: Jul 2016
Location: Belgium Roeselare
Distribution: Debian 8 amd64
Posts: 11

Original Poster
Rep: Reputation: Disabled
Yes, I run this command a few times and restart my computer.

Code:
........
Fetched 9,616 B in 3s (2,733 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
firmware-iwlwifi is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@hpdeb:/home/adhemar#
 
Old 08-03-2016, 11:11 AM   #4
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: antiX 23, MX 23
Posts: 7,110
Blog Entries: 21

Rep: Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474
Show output of

Code:
sudo ifconfig -a
and what desktop environment or Window manager and also connection manager you are using in Debian. I ask this because I use

Code:
harry@biker:~
$ inxi -Fxz
System:    Host: biker Kernel: 4.2.1-antix.2-686-pae i686 (32 bit gcc: 4.9.2)
           Desktop: IceWM 1.3.8 Distro: antiX-15-V_386-full Killah P 30 June 2015
Machine:   System: Dell (portable) product: Latitude E4310 v: 0001
           Mobo: Dell model: 0T6M8G v: A01 Bios: Dell v: A03 date: 07/08/2010
Battery    BAT0: charge: 56.0 Wh 264.9% condition: 21.1/56.0 Wh (38%)
           model: Samsung SDI DELL J163808 status: Full
CPU:       Dual core Intel Core i5 M 520 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9578
           clock speeds: max: 2400 MHz 1: 1466 MHz 2: 1199 MHz 3: 1599 MHz
           4: 1599 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Ironlake Mobile x86/MMX/SSE2
           GLX Version: 2.1 Mesa 10.3.2 Direct Rendering: Yes
Audio:     Card Intel 5 Series/3400 Series High Definition Audio
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.2.1-antix.2-686-pae
Network:   Card-1: Intel 82577LM Gigabit Network Connection
           driver: e1000e v: 3.2.5-k port: 6040 bus-ID: 00:19.0
           IF: eth0 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6200 driver: iwlwifi bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 60.0GB (47.4% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 60.0GB
Partition: ID-1: / size: 7.6G used: 5.3G (73%) fs: ext3 dev: /dev/sda2
           ID-2: /home size: 48G used: 22G (48%) fs: ext3 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 138 Uptime: 17:15 Memory: 495.5/8027.1MB
           Init: SysVinit runlevel: 5 Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301) inxi: 2.3.0
You will iwlwifi and wlan0 connected <my wireless> in my above readout.
 
Old 08-03-2016, 11:13 AM   #5
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: antiX 23, MX 23
Posts: 7,110
Blog Entries: 21

Rep: Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474
All you might need is to connect to your router.
 
Old 08-04-2016, 03:09 AM   #6
adhemar
LQ Newbie
 
Registered: Jul 2016
Location: Belgium Roeselare
Distribution: Debian 8 amd64
Posts: 11

Original Poster
Rep: Reputation: Disabled
I use the Gnome desktop. My editor is gedit.

Code:
root@hpdeb:/home/adhemar# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 64:31:50:8a:d4:18  
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6631:50ff:fe8a:d418/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1643 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1173 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1864265 (1.7 MiB)  TX bytes:150406 (146.8 KiB)
          Interrupt:20 Memory:d4800000-d4820000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:37 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3701 (3.6 KiB)  TX bytes:3701 (3.6 KiB)

wlan0     Link encap:Ethernet  HWaddr 18:3d:a2:03:59:74  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
My wifi is not connected to the network.
 
Old 08-04-2016, 10:33 AM   #7
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: antiX 23, MX 23
Posts: 7,110
Blog Entries: 21

Rep: Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474Reputation: 3474
Quote:
My wifi is not connected to the network.
That is because it is up to you to connect it your self through whatever gnome connecting manager Debian uses. I don't use Gnome.

https://wiki.debian.org/WiFi/HowToUse#GNOME

Quote:
Ensure your user account is a member of the netdev group.
Code:
$ groups harry
harry : harry lp dialout cdrom floppy sudo audio dip video plugdev users netdev lpadmin scanner

Last edited by rokytnji; 08-04-2016 at 10:40 AM.
 
Old 08-05-2016, 04:31 AM   #8
adhemar
LQ Newbie
 
Registered: Jul 2016
Location: Belgium Roeselare
Distribution: Debian 8 amd64
Posts: 11

Original Poster
Rep: Reputation: Disabled
The network-manager was already installed.
Next to the wifi-symbol is indicated: Hardware Disabled.

By the installation, the system saw my Centrino Advanced N 6200 (the driver must probably build in)
I do not know how to activate the wifi-card.

By Select Network, I can't turn on the wifi.
 
Old 08-05-2016, 05:15 AM   #9
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,876

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
Post the output of
Code:
/usr/sbin/rfkill list all
 
Old 08-05-2016, 09:32 AM   #10
adhemar
LQ Newbie
 
Registered: Jul 2016
Location: Belgium Roeselare
Distribution: Debian 8 amd64
Posts: 11

Original Poster
Rep: Reputation: Disabled
Code:
adhemar@hpdeb:~$ /usr/sbin/rfkill list all
bash: /usr/sbin/rfkill: No such file or directory
adhemar@hpdeb:~$
Another operating system-code?
 
Old 08-05-2016, 05:53 PM   #11
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,876

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
OK, install rfkill first then
Code:
apt-get update && apt-get install rfkill
 
Old 08-06-2016, 03:18 AM   #12
adhemar
LQ Newbie
 
Registered: Jul 2016
Location: Belgium Roeselare
Distribution: Debian 8 amd64
Posts: 11

Original Poster
Rep: Reputation: Disabled
Code:
root@hpdeb:/home/adhemar# /usr/sbin/rfkill list all
0: hp-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hp-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: hp-wwan: Wireless WAN
	Soft blocked: no
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
4: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
root@hpdeb:/home/adhemar#
 
Old 08-06-2016, 03:32 AM   #13
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,876

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
Have you got a switch or key combo to en/disable wireless?
 
Old 08-06-2016, 04:01 AM   #14
adhemar
LQ Newbie
 
Registered: Jul 2016
Location: Belgium Roeselare
Distribution: Debian 8 amd64
Posts: 11

Original Poster
Rep: Reputation: Disabled
HP Probook 6550b
Keyboard configured as En US
Above the keyboard is a switch with the wifi symbol. The symbol is normal dark-blue. I can toggle it off to orange, but I leave it on.
 
Old 08-06-2016, 06:03 PM   #15
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,876

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
Quote:
Originally Posted by adhemar View Post
Code:
3: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
Not sure if this is a problem or not - toggle your switch and rerun rfkill to spot the difference.

Code:
lspci -k | grep -iA2 net
This should show that your kernel module ("driver") is loaded.

Then it's just a matter of (mis)configuration.
NetworkManager doesn't always get it right without help, but I don't use it (I use WICD) so can't help with that.

See if this info helps.
https://wiki.debian.org/WiFi/HowToUse

The command line method is straightforward and if it still doesn't work should at least provide better feedback.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install intel-centrino-advanced-n-6205 driver in debian laptop padiharish Debian 12 07-14-2013 02:15 AM
Intel Centrino Advanced-N 6200 Wireless pr0xibus Slackware 9 12-30-2012 08:36 PM
LXer: Intel Centrino Advanced-N 6205 AGN LXer Syndicated Linux News 0 06-10-2012 02:31 PM
[SOLVED] Can't get wlan0(intel centrino 6200) to ping anything but the AP (slackware 13.7) fastghost93 Linux - Networking 6 02-09-2012 01:51 PM
[SOLVED] Intel Centrino N 6200 wireless in Slackware 64 13.1? qlands Linux - Hardware 5 02-06-2011 11:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration