LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-24-2015, 07:03 AM   #1
bocabits
Member
 
Registered: Dec 2009
Location: Madrid, Spain
Distribution: Debian
Posts: 38

Rep: Reputation: 2
debian 8.2 stops "seeing" my router


Good day to all of you.

My PC has a dual boot, debian 8.2 which is my favourite and Windows 7. Since two days ago I am suffering a pretty weird issue: I cannot reach 192.168.0.1 (the router) and I have no Internet. But, if I boot W7, it works OK.

I'm connecting to the router using an ethernet wire.

The WiFi connection has worked OK, son I think it's not a router problem.

Everything has worked perfectly for years. I cannot think of any changes I might have done, I've checked the files and they have not been modified lately.

I use DHCP but debian has a static IP adress (192.168.0.2).

Now I'm writing from W7 so I cannot attach any configuration file.

Thank you for your attention and help.
 
Old 09-24-2015, 07:43 AM   #2
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Fedora, OpenSUSE, FreeBSD, OpenBSD, macOS (hack). Past: Debian, Arch, RedHat (pre-RHEL).
Posts: 1,335
Blog Entries: 7

Rep: Reputation: 402Reputation: 402Reputation: 402Reputation: 402Reputation: 402
UGH! I had typed a detailed reply, and got a "Bad Request" error from NginX when submitted... all lost!

Did you recently do an upgrade? Specifically, do you remember if there was a kernel upgrade involved?

What is the output of lspci -v? This will tell you what hardware you have and what driver is loaded. For example, from my laptop that I am using right now:

Code:
anthony@serenity: ~ $ lspci -v | grep -A 6 -i net
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
	Subsystem: AzureWave Device 1186
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at f7d00000 (64-bit, non-prefetchable) [size=512K]
	Expansion ROM at f7d80000 [disabled] [size=64K]
	Capabilities: <access denied>
	Kernel driver in use: ath9k
--
03:00.0 Ethernet controller: Qualcomm Atheros AR8162 Fast Ethernet (rev 10)
	Subsystem: ASUSTeK Computer Inc. Device 200f
	Flags: bus master, fast devsel, latency 0, IRQ 29
	Memory at f7c00000 (64-bit, non-prefetchable) [size=256K]
	I/O ports at e000 [size=128]
	Capabilities: <access denied>
	Kernel driver in use: alx
(Note that -A 6 was just used as I knew how many lines of output I needed for this example, you may want to start with a few lines more.)

If it's a Realtek, Atheros, or one of some others, there's likely firmware involved. If lspci lists no kernel driver in use, I'd likely bet that is your problem. The firmware was not installed in the kernel upgrade, you'll have to install it again. I go through this every kernel upgrade as both my ethernet and wireless adapters require firmware.

If no driver is in use, you can also check the output of dmesg. It may indicate why the driver was not loaded at boot time (for example "bad or missing firmware" or some such error).

If you can't figure it out, feel free to post the relevant output of those commands here. I understand you're visiting the site from Windows 7, so save a text file on that partition with the output so you have access to it. It really will help us to help you better.

Last edited by goumba; 09-24-2015 at 07:46 AM. Reason: Noticed the Win7 part.
 
Old 09-25-2015, 03:47 AM   #3
bocabits
Member
 
Registered: Dec 2009
Location: Madrid, Spain
Distribution: Debian
Posts: 38

Original Poster
Rep: Reputation: 2
Thank you for your reply,

this is the relevant output of the lspci and dmesg commands.

I don't remeber any upgrades since last Tuesday, the last day everything worked OK.

Linux bossanova 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u3 (2015-08-04) x86_64 GNU/Linux

Code:
$ lspci

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 02)
        Subsystem: Hewlett-Packard Company Asus IPIBL-LB Motherboard
        Flags: bus master, fast devsel, latency 0, IRQ 44
        I/O ports at e800 [size=256]
        Memory at febff000 (64-bit, non-prefetchable) [size=4K]
        Memory at fdff0000 (64-bit, prefetchable) [size=64K]
        Expansion ROM at febc0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: r8169

Code:
$ dmesg


[    0.529954] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    0.529963] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
[    0.530292] r8169 0000:02:00.0: irq 44 for MSI/MSI-X
[    0.530519] r8169 0000:02:00.0 eth0: RTL8168c/8111c at 0xffffc90000c74000, 00:26:18:7b:27:52, XID 1c4000c0 IRQ 44
[    0.530522] r8169 0000:02:00.0 eth0: jumbo features [frames: 6128 bytes, tx checksumming: ko]
[    0.532710] ehci-pci 0000:00:1a.7: cache line size of 32 is not supported
[    0.532733] ehci-pci 0000:00:1a.7: irq 18, io mem 0xfe7fec00


[   12.929304] r8169 0000:02:00.0 eth0: link down
[   12.929320] r8169 0000:02:00.0 eth0: link down
[   12.929332] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Thanks for your help.
 
Old 09-25-2015, 04:05 AM   #4
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Fedora, OpenSUSE, FreeBSD, OpenBSD, macOS (hack). Past: Debian, Arch, RedHat (pre-RHEL).
Posts: 1,335
Blog Entries: 7

Rep: Reputation: 402Reputation: 402Reputation: 402Reputation: 402Reputation: 402
Several variations of the 8111/8168/8411 require firmware, included in firmware-realtek. Check to see if it is installed.

You say you don't recall any updates, however it wouldn't hurt to make sure firmware-realtek is installed, if it is in fact needed.

Have you tried another ethernet cable?

Last edited by goumba; 09-25-2015 at 04:13 AM.
 
Old 09-25-2015, 05:02 AM   #5
bocabits
Member
 
Registered: Dec 2009
Location: Madrid, Spain
Distribution: Debian
Posts: 38

Original Poster
Rep: Reputation: 2
I think firmware-realtek is not installed.

http://i.imgur.com/XiNnr7E.png

I'll download and install it.

Thanks!

PD: Yes, I've tried two different cables, both work under W7.
 
Old 09-25-2015, 05:28 AM   #6
bocabits
Member
 
Registered: Dec 2009
Location: Madrid, Spain
Distribution: Debian
Posts: 38

Original Poster
Rep: Reputation: 2
After installing firmware-realtek.deb

Code:
# ip addr show dev eth0
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:26:18:7b:27:52 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.2/24 brd 192.168.0.255 scope global eth0
       valid_lft forever preferred_lft forever
Code:
# ifconfig

root@bossanova:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:26:18:7b:27:52  
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:283 errors:0 dropped:0 overruns:0 frame:0
          TX packets:283 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:24934 (24.3 KiB)  TX bytes:24934 (24.3 KiB)
Code:
# lspci

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 02)
        Subsystem: Hewlett-Packard Company Asus IPIBL-LB Motherboard
        Flags: bus master, fast devsel, latency 0, IRQ 44
        I/O ports at e800 [size=256]
        Memory at febff000 (64-bit, non-prefetchable) [size=4K]
        Memory at fdff0000 (64-bit, prefetchable) [size=64K]
        Expansion ROM at febc0000 [disabled] [size=128K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 01
        Capabilities: [b0] MSI-X: Enable- Count=2 Masked-
        Capabilities: [d0] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 00-00-00-00-ec-10-68-81
        Kernel driver in use: r8169
Code:
# dmesg

[    0.528039] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    0.528055] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
[    0.528397] r8169 0000:02:00.0: irq 44 for MSI/MSI-X
[    0.528641] r8169 0000:02:00.0 eth0: RTL8168c/8111c at 0xffffc90000c72000, 00:26:18:7b:27:52, XID 1c4000c0 IRQ 44
[    0.528645] r8169 0000:02:00.0 eth0: jumbo features [frames: 6128 bytes, tx checksumming: ko]
[   13.141300] r8169 0000:02:00.0 eth0: link down
[   13.141319] r8169 0000:02:00.0 eth0: link down
[   13.141351] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

Code:
# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Speed: 10Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: no
Thank you!

Last edited by bocabits; 09-25-2015 at 05:47 AM.
 
Old 09-25-2015, 11:24 AM   #7
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Fedora, OpenSUSE, FreeBSD, OpenBSD, macOS (hack). Past: Debian, Arch, RedHat (pre-RHEL).
Posts: 1,335
Blog Entries: 7

Rep: Reputation: 402Reputation: 402Reputation: 402Reputation: 402Reputation: 402
So now it works, great! You're welcome.

Use the Thread Tools menu to mark this as [SOLVED] so others looking for the same issue can find it.

Odd that the firmware somehow got uninstalled, but the fact it works is all that matters!

Last edited by goumba; 09-25-2015 at 11:25 AM.
 
Old 09-25-2015, 12:29 PM   #8
bocabits
Member
 
Registered: Dec 2009
Location: Madrid, Spain
Distribution: Debian
Posts: 38

Original Poster
Rep: Reputation: 2
Sorry, it's not working. I still cannot reach my router.
 
Old 09-25-2015, 12:59 PM   #9
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Fedora, OpenSUSE, FreeBSD, OpenBSD, macOS (hack). Past: Debian, Arch, RedHat (pre-RHEL).
Posts: 1,335
Blog Entries: 7

Rep: Reputation: 402Reputation: 402Reputation: 402Reputation: 402Reputation: 402
My mistake, I saw the IP address, thought you were up and running now. I had taken it early you weren't even getting that.

Are you using NetworkManager? What does /etc/network/interfaces look like? If you're using network manager (GNOME for instance), there wouldn't be an entry for eth0, but if you're not, you want to make sure it has something like.

Code:
allow-hotplug eth0
iface eth0 inet dhcp
If you're using another DE, you may want to consult the network management app's manual page to see if you need to modify /etc/network/interfaces.

Something had to have changed, and you just don't realize it. Debian wouldn't suddenly stop working for no reason. Have you tried resetting the router? Have you checked the router's logs? Can you ping the router?

Last edited by goumba; 09-25-2015 at 01:14 PM.
 
Old 09-25-2015, 02:17 PM   #10
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142
Quote:
Originally Posted by bocabits View Post
I use DHCP but debian has a static IP adress (192.168.0.2).
What does that mean? Debian is configured to use dhcp but you have a rule in the router that always pairs its mac address with that IP? Or you use dhcp for everything else and you've configured debian with static? If the latter, what is the dhcp address range in the router?

Also, what's the output of "ip route"?

Last edited by suicidaleggroll; 09-25-2015 at 02:18 PM.
 
Old 09-26-2015, 05:09 AM   #11
bocabits
Member
 
Registered: Dec 2009
Location: Madrid, Spain
Distribution: Debian
Posts: 38

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by goumba View Post
My mistake, I saw the IP address, thought you were up and running now. I had taken it early you weren't even getting that.

Are you using NetworkManager? What does /etc/network/interfaces look like? If you're using network manager (GNOME for instance), there wouldn't be an entry for eth0, but if you're not, you want to make sure it has something like.

Code:
allow-hotplug eth0
iface eth0 inet dhcp
If you're using another DE, you may want to consult the network management app's manual page to see if you need to modify /etc/network/interfaces.

Something had to have changed, and you just don't realize it. Debian wouldn't suddenly stop working for no reason. Have you tried resetting the router? Have you checked the router's logs? Can you ping the router?

I'm using KDE. This is my /etc/networks/interface file

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0

# IP dinámica
# iface eth0 inet dhcp

# IP Fija
iface eth0 inet static 
        address 192.168.0.2
        netmask 255.255.255.0
        network 192.168.0.0
        broacast 192.168.0.255                                                                                                                                                          
        gateway 192.168.0.1                                                                                                                                                             
        dns-nameservers 192.168.0.1
Router works OK under W7. Under debían it cannot be reached. Ping fails, no matter I'm connected through a Ethernet cable.
 
Old 09-26-2015, 05:17 AM   #12
bocabits
Member
 
Registered: Dec 2009
Location: Madrid, Spain
Distribution: Debian
Posts: 38

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by suicidaleggroll View Post
What does that mean? Debian is configured to use dhcp but you have a rule in the router that always pairs its mac address with that IP? Or you use dhcp for everything else and you've configured debian with static? If the latter, what is the dhcp address range in the router?

Also, what's the output of "ip route"?
The DHCP server runs on the router, but I force the PC to get a static IP (some P2P software requirement). W7 gets a dinamic IP. I can disable this to give a try

This is the output of ip route

Code:
root@bossanova:/etc/network# ip route                                                                                                                                                   
default via 192.168.0.1 dev eth0                                                                                                                                                        
default via 192.168.0.1 dev eth0  proto static  metric 1024                                                                                                                             
192.168.0.0/24 dev eth0  proto kernel  scope link  src 192.168.0.2
Thanks for your help!
 
Old 09-26-2015, 05:37 AM   #13
bocabits
Member
 
Registered: Dec 2009
Location: Madrid, Spain
Distribution: Debian
Posts: 38

Original Poster
Rep: Reputation: 2
If I use DHCP, I don't even get an IP adress, it's kind of obvious since I can't reach the router
 
Old 09-26-2015, 09:27 AM   #14
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,573

Rep: Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142Reputation: 2142
Quote:
Originally Posted by bocabits View Post
I'm using KDE. This is my /etc/networks/interface file

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0

# IP dinámica
# iface eth0 inet dhcp

# IP Fija
iface eth0 inet static 
        address 192.168.0.2
        netmask 255.255.255.0
        network 192.168.0.0
        broacast 192.168.0.255                                                                                                                                                          
        gateway 192.168.0.1                                                                                                                                                             
        dns-nameservers 192.168.0.1
Router works OK under W7. Under debían it cannot be reached. Ping fails, no matter I'm connected through a Ethernet cable.
You misspelled "broadcast"
Also just remove that line and a couple of others. Leave address, netmask, and gateway, remove the rest. Are you sure your router can function as a dns server? You can just stick 8.8.8.8 in /etc/resolv.conf to use google's.

---------- Post added 09-26-15 at 08:28 AM ----------

Quote:
Originally Posted by bocabits View Post
The DHCP server runs on the router, but I force the PC to get a static IP (some P2P software requirement).
What does your router use as its dhcp range?
 
Old 09-26-2015, 12:55 PM   #15
bocabits
Member
 
Registered: Dec 2009
Location: Madrid, Spain
Distribution: Debian
Posts: 38

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by suicidaleggroll View Post
You misspelled "broadcast"
Also just remove that line and a couple of others. Leave address, netmask, and gateway, remove the rest. Are you sure your router can function as a dns server? You can just stick 8.8.8.8 in /etc/resolv.conf to use google's.
I've followed your advice, using Google's DNS and the following interfaces file

Code:
root@bossanova:~# more /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0

# IP dinámica
# iface eth0 inet dhcp

# IP Fija
auth eth0
iface eth0 inet static 
        address 192.168.0.2
        netmask 255.255.255.0
        gateway 192.168.0.1
Code:
root@bossanova:~# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:26:18:7b:27:52  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:80 errors:0 dropped:0 overruns:0 frame:0
          TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:6176 (6.0 KiB)  TX bytes:6176 (6.0 KiB)

root@bossanova:~# ping 192.168.0.1
connect: Network is unreachable
Quote:
Originally Posted by suicidaleggroll View Post

---------- Post added 09-26-15 at 08:28 AM ----------

What does your router use as its dhcp range?
http://i.imgur.com/tRFXnzS.png
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Squeeze: TCP stops working, UDP doesn't, with "unexpectedly shrunk window" hnatt Linux - Networking 26 04-15-2012 03:26 AM
Hardy won't startup, stops with a "fail" and I have to "ctrl+alt+del" to boot. brjoon1021 Ubuntu 10 12-15-2008 06:29 PM
"USB device stops working after a time" 'fix' stops cdrom device mount/readability adamben Slackware 6 04-18-2007 01:18 PM
Data transfer online is slow "at times" or "stops at times" Balarabay1 SUSE / openSUSE 14 04-30-2006 10:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration