LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-23-2004, 04:07 AM   #1
RINO2004
LQ Newbie
 
Registered: Jun 2004
Location: Lithuania
Distribution: Slackware 9.x
Posts: 21

Rep: Reputation: 15
ddc on mIRC not working


I' cant send any ddc outside my lan, but i can get files from outside. What is the problem? Should i forward some kind of port ?

using: slack 9.0
kernel 2.4
NAT: iptables v1.2.8
 
Old 08-23-2004, 04:39 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
you've just bumped into the magical problem that seems to persist among us I can't use dcc outside my lan either..I mean the send-part. receiving works. I've figured out this far that it's because my NAT/connection tracking isn't working with dcc though I've loaded the modules and tweaked my firewall for ages...

and yes, you do need forwarding I guess, but that's where the problem lies..for some reason, possibly the ports used in this thing, the forwarding doesn't work like it should. tell me if you get it working, and how you did it...I've tried for too long now dug the whole web up without finding anything really helpful and so on...good luck though.

EDIT: as far as I've understood, it SHOULD go like this: "make your iptables forward the connections from the net to your lan and vice versa, load ip_nat_irc and ip_conntrack_irc modules to your kernel, start your irc and send". but as I said, at least on my config the irc connection's DCC send never gets tracked or something, so NAT doesn't work for it, and it won't work.

ok, perhaps I lied a bit...just remembered that I actually did get it working once. but after that one single time I never got it working again, and I'm damn sure I didn't change anything after that....the thing just didn't want to work anymore. guess twice if I was furious? :P

Last edited by b0uncer; 08-23-2004 at 04:43 AM.
 
Old 08-29-2004, 05:09 AM   #3
RINO2004
LQ Newbie
 
Registered: Jun 2004
Location: Lithuania
Distribution: Slackware 9.x
Posts: 21

Original Poster
Rep: Reputation: 15
Well i loaded those two modules but as you said dcc still not work's i think that problems is with port redirecting that irc_nat module not work propertly or my firewall is buggy , i'll write you if i make dcc work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem: XFree4.3 + Radeon 7500 - DDC? Zoidy Debian 7 09-22-2004 04:00 PM
mIRC santasballz Linux - Newbie 4 07-28-2004 02:52 PM
Who have EDID / DDC database ? lhseong Linux - Hardware 0 06-28-2004 09:44 PM
VGA DDC detection problem. lhseong Linux - Hardware 0 06-09-2004 04:42 AM
my mirc =) Patchorus General 4 08-17-2003 09:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration