-   Linux - Networking (
-   -   CPAN Problem (

mesh2005 10-24-2005 08:38 AM

CPAN Problem
i use Linux Redhat 7.2 , i have perl installed
i tried to use the CPAN, the problems is
it reports many errors ("Could not connect")
and reports "url is invalid" , here is the
configuration i use:
commit Commit changes to disk
defaults Reload defaults from disk
init Interactive setting of all options

build_cache 10
build_dir /root/.cpan/build
cache_metadata 1
cpan_home /root/.cpan
ftp /usr/kerberos/bin/ftp
getcwd cwd
gpg /usr/bin/gpg
gzip /bin/gzip
histfile /root/.cpan/histfile
histsize 100
inactivity_timeout 0
index_expire 1
inhibit_startup_message 0
keep_source_where /root/.cpan/sources
links /usr/bin/links
make /usr/bin/make
ncftpget /usr/bin
pager /usr/bin/less
prerequisites_policy ask
scan_cache atstart
shell /bin/bash
tar /bin/tar
term_is_latin 1
unzip /usr/bin/unzip
wget /usr/bin/wget

it refuses to download any package, can anyone help

peter_robb 10-24-2005 09:06 AM

How do you use CPAN?

perl -MCPAN -e shell will either start the autoconfigure script or give you a shell.

I suggest doing the autoconfigure again. At the cpan> shell prompt, enter o conf init

mesh2005 10-25-2005 03:05 AM

i use it : perl -MCPAN -e shell
and this opens the CPAN shell, i tried to run the o conf init to reconfigure it but the same problem occurs again....
is there anything wrong with the configuration file i sent? i think it is error-less
i hope u can help

peter_robb 10-25-2005 05:51 AM

Ok.. sounds more like a dns problem..

Did you upgrade perl?
It needs to be compiled with the same version of gcc as on your RH system.

And is there any special reason you want to keep RH7.2?
There are lots of security updates not available in package format anymore.
I use it on some firewalls, but it isn't RH7.2 anymore. Many changes to it.

mesh2005 10-25-2005 06:02 AM

thanks for ur reply
perl is automatically installed with my System so it is already complied with gcc
you said that it is a dns problem? what u exactly mean by that?

peter_robb 10-25-2005 07:03 AM

It needs looking at why perl cannot find the url
Either it can't resolve the address, dns
or ftp can't connect, passive or active ftp..

The perl module used to download is LWP::UserAgent
Is this where the config fails?

mesh2005 10-25-2005 08:50 AM

you r right!!! the machine was not properly configured to connect the right DNS
, just i have one more question i need some url to be added to the url sitelist of CPAN. can u give me some?
thanks so much for ur help

peter_robb 10-25-2005 09:36 AM

Run the config again and it will give you a list of world regions.
You can add as many as you want from there..

All times are GMT -5. The time now is 10:01 PM.