LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-14-2001, 12:52 AM   #1
rdaves@earthlink.net
Member
 
Registered: May 2001
Location: Full-time traveler I live where I am.
Distribution: I use Red Hat V 7.1
Posts: 297

Rep: Reputation: 30
Question


I am able to dial my ISP using wvdial, however, the PPP daemon dies just following the entry "looks like a welcome message".

My /var/log/messages file shows the following entry:
"pppd 2.3.11 started by root, uid 0
Couldn't attach tty to PPP unit 0: invalid argument
tcsetattr:invalid argument"

Also, there's a message created by wvdial just in front of the message "looks like a welcome..." that says "IP address is 63.224.192.60. My ISP's Primary DNS is 216.104.72.5. Is something wrong?
 
Old 06-14-2001, 11:05 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
my first hunch would be to check if ure pppd version matches the kernel, kernel-2.4x needs a newer version of pppd as mentioned in the kernel docs.
 
Old 06-14-2001, 02:40 PM   #3
rdaves@earthlink.net
Member
 
Registered: May 2001
Location: Full-time traveler I live where I am.
Distribution: I use Red Hat V 7.1
Posts: 297

Original Poster
Rep: Reputation: 30
You mention "kernel docs"
Where do I find them.
Have looked in /usr/src/linux/documentation, but found nothing that looked like it alpplied to ppp.
 
Old 06-14-2001, 07:27 PM   #4
rdaves@earthlink.net
Member
 
Registered: May 2001
Location: Full-time traveler I live where I am.
Distribution: I use Red Hat V 7.1
Posts: 297

Original Poster
Rep: Reputation: 30
Disregard previous post. Found what I needed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change tty => system crashes (ati driver/tty resolution) mosca Debian 6 08-05-2004 07:37 AM
could not set tty to ppp discipline ABID4321 Debian 0 07-21-2004 06:18 AM
Couldnt set tty to PPP discipline edM Slackware 4 07-16-2004 12:08 AM
couldn't attach tty to PPP unit 0: Invalid argument TheGrimJester Linux - Networking 3 07-28-2001 05:54 PM
Couldn't attach tty to PPP shun_22 Linux - Networking 1 06-15-2001 10:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration