LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-09-2016, 01:52 AM   #1
sekarlinux
Member
 
Registered: Dec 2011
Posts: 48

Rep: Reputation: Disabled
Could not disable DEFROUTE in ppp connection in RHEL-6.8


Hello All,

I have disabled DEFROUTE=no in my PPP configuration file. But when I bring up the ppp interface it will automatically add default route with ppp interface. I need to disable this auto defroute. Please check if there is anything missing. Note : NetworkManager already stopped.

USERCTL=yes
BOOTPROTO=dialup
NAME=DSLppp0
DEVICE=ppp0
TYPE=xDSL
ONBOOT=no
PIDFILE=/var/run/pppoe-adsl.pid
FIREWALL=NONE
PING=.
PPPOE_TIMEOUT=0
LCP_FAILURE=0
LCP_INTERVAL=0
CLAMPMSS=1412
CONNECT_POLL=6
CONNECT_TIMEOUT=60
SYNCHRONOUS=no
DEFROUTE=no
ETH=eth1
PROVIDER=DSLppp0
USER="xxxx@xxx.xx"
PEERDNS=no
DEMAND=no

route

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
xx.xx.xx.xx 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
xx.xx.xx.xx 0.0.0.0 255.255.255.252 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1002 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1003 0 0 eth1
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp0
 
Old 09-09-2016, 02:54 PM   #2
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,850

Rep: Reputation: 161Reputation: 161
Which file do you talk about, under network-scripts directory?
 
Old 09-09-2016, 11:52 PM   #3
sekarlinux
Member
 
Registered: Dec 2011
Posts: 48

Original Poster
Rep: Reputation: Disabled
Yes. /etc/sysconfig/network-scripts/ifcfg-ppp0 file. DEFROUTE=no is not disabling the auto defroute in PPP connection at CentOS-6.8 or I missed something here ?

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
xx.xx.xx.xx 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
xx.xx.xx.xx 0.0.0.0 255.255.255.252 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1002 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1003 0 0 eth1
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp0

Last edited by sekarlinux; 09-10-2016 at 12:00 AM. Reason: updating routing info
 
Old 09-12-2016, 03:35 PM   #4
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,850

Rep: Reputation: 161Reputation: 161
Do you configure any default gateway? It look like you don't configure any default gateway.
 
Old 09-13-2016, 04:22 AM   #5
sekarlinux
Member
 
Registered: Dec 2011
Posts: 48

Original Poster
Rep: Reputation: Disabled
Thanks nini09 for trying to solve this issue. I dig more on this today and found the parameter changed from DEFROUTE to DEFAULTROUTE in the newer versions . Now it is working as expected and we can mark this thread as Solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
etablish one connection ppp between a client ppp and a server ppp camilla261086 Linux - Server 2 07-20-2010 07:09 AM
ppp connection camilla261086 Linux - Networking 1 07-16-2010 11:26 AM
Need help for ppp connection ajay.ringne Linux - Networking 0 10-20-2007 04:42 AM
ppp connection aps_rewa Linux - Networking 0 05-20-2004 04:39 AM
ppp connection help LUXX Linux - Newbie 4 11-14-2003 01:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration