-   Linux - Networking (
-   -   Connection refused rsh (

onaeem 05-28-2004 08:39 AM

Connection refused rsh
I am trying to run PVM on a small cluster (5 machines). I cannot add any hosts in PVM. Nor can i use rsh to login to any other host, even the local hostname of the machine i am on! :mad:

the message i get is:

connection refused

when using rsh. I have checked the .rhosts file and the hosts.equiv file. Does anyone please have any solutions that i can try? Or any other way to get PVM up and running?

(i am using mandrake 10.0 distro)

thanks big time!!!!

Oz. :)

LuggerHouse 05-28-2004 02:46 PM

IMHO you better try ssh... rsh is completely out of trend...

SSH package is in almost every distros basic installation..

onaeem 06-04-2004 04:28 AM

I am really stuck ...pls help!

I can run SSH without any problem, and logon succesfully to other machines. but i STILL CANT ush rsh to logon! it just says:

hostname: Connection refused

I have read books, FAQs , and everything i can find, but im still stuck. and i really need rsh to be able to use PVM.

If it helps:
->I checked, and i do not have a file called /usr/sbin/in.rshd
-> my hosts.allow and hosts.equiv are ok
-> i dont have inetd, but have xinetd (is that ok?)

chrisvanloan 06-23-2004 06:08 PM

a couple of things to try
cd to /etc/xinetd.d

there should be a rsh file in this directory. Edit the file and ensure the disabled = no
Also edit rlogin file and ensure disabled = no

The files also display the path to the rsh and rlogin daemon executables. Verify that the files are present and executable.

Restart the rlogin and rsh service or reboot the machine.

This problem drove me crazy for a couple of weeks.

onaeem 06-24-2004 01:52 AM

problem solved! rsh-server was missing
My problem is now fixed! It seems my distro did not contain the rsh-server package. I downloaded and installed it, and then made all the tuning/adjustements to the hosts.allow and the .rlogin files. Now everything is running smoothly, and i can rsh without using passwords.

Thanks! Linux rocks!!!

phatboyz 06-24-2004 01:31 PM

I think that you should give public key access a try and use ssh if you done want to use passwords.

manjunath537 03-27-2010 05:38 AM

setting up a cluster

i m trying to setup a cluster of three systems....

i'm unable to setup.....i m getting error as connection refused ....

i'm not able to find what's the problem......?

please help me.................

have a nice day............

skrajath 02-25-2011 01:44 AM

Same problem
Hi Manjunath,

did ur problem solved.?
even am facing the same problem... tried all posibilities but no success

All times are GMT -5. The time now is 01:35 PM.