LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-13-2010, 01:06 PM   #1
james8734
LQ Newbie
 
Registered: May 2010
Posts: 3

Rep: Reputation: 0
Connection from FTP client to PURE FTPd server fails at MLSD


I wonder if anyone can assist with a delicate question.

I have a "friend" who hosts a couple of websites that I maintain. I have always used filezilla client to connect and update the files on the website.

I lost access for a little while and he said that "The profiles had accidentally been dropped".

He reinstated everything but now I cannot complete a log on session. I maintain several other websites which have the same PURE FTPd server at their end and I can connect to these OK.

The delicacy of the matter is that, with no changes at my end, and my other sites working, logic suggests that something has changed at his end. I have very patiently worked through all his suggestions but to no avail.

I can't suggest that he is at fault when he claims expertise in the field and I am a complete lamer when it comes to FTP.

I wonder if anyone would be kind enough to review the log on result below and see if they can throw some light on the situation for me.

(I have anonymised the IP address and other information for security reasons)

Many Thanks

James

Status: Resolving address of xxxxxxx.co.uk
Status: Connecting to 000.000.000.000:21...
Status: Connection established, waiting for welcome message...
Response: 220-=(<*>)=-.:. (( Welcome to PureFTPd 1.1.0 )) .:.-=(<*>)=-
Response: 220-You are user number 1 of 50 allowed
Response: 220-Local time is now 17:56 and the load is 0.00. Server port: 21.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER xxxxxxxxxx
Response: 331 User xxxxxxxxx OK. Password required
Command: PASS ************
Response: 230-User xxxxxxxx has group access to: 503
Response: 230 OK. Current directory is /
Command: SYST
Response: 215 UNIX Type: L8
Command: FEAT
Response: 211-Extensions supported:
Response: EPRT
Response: IDLE
Response: MDTM
Response: SIZE
Response: REST STREAM
Response: TVFS
Response: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Response: MLSD
Response: PASV
Response: EPSV
Response: SPSV
Response: 211 End.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (000,000,000,000,152,169).
Command: MLSD
Error: Connection timed out
Error: Failed to retrieve directory listing

Last edited by james8734; 05-13-2010 at 01:07 PM.
 
Old 05-17-2010, 03:13 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,155

Rep: Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436
A firewall problem somewhere but the problem is mlsd. That needs to be changed back to list.

http://ipswitchft.custhelp.com/app/a...etail/a_id/493
 
Old 05-17-2010, 07:41 PM   #3
james8734
LQ Newbie
 
Registered: May 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks Jefro

My firewall is OK as the MLSD command works with other servers. The command used to work OK. I can't really determine if his firewall has been changed or not, but due to the nature of his business. I guess he will have something very up to date and extremely secure.

Cheers

James
 
Old 05-18-2010, 04:21 PM   #4
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,155

Rep: Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436Reputation: 3436
Maybe but more likely it is old. You use list and try it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pure-ftpd login fails! i.you Linux - Software 1 12-03-2007 04:04 PM
Pure-Ftpd client-XXXXXX files fifawe Linux - Software 1 07-19-2006 04:06 AM
pure-ftpd init script fails to start server in standalone mode Cronjob Debian 1 05-23-2006 12:11 AM
Forward to another ftp-server with pure-ftpd didi86 Linux - Software 0 12-20-2004 12:55 PM
Set up ftp server with pure-ftpd aeruzcar Linux - Software 7 04-15-2004 07:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration