LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-13-2003, 04:06 PM   #1
explorer
Member
 
Registered: Feb 2003
Posts: 229

Rep: Reputation: 34
Angry Connecting to Samba Server from Windows


I set my linuxbox up as a samba server, changed the workgroup name in smb.conf to the name of the windows network domain that I will be connecting from, and now the samba server shows up in in the windows network neighborhood like I wanted. When I try to map a network drive to a share on the samba server from windows, a dialog ask me for a username and password. I enter a username and password that exists on the linux box and click OK..after a couple of seconds the username/password dialog pops back up, but now with the name of the windows domain in front of the username that I entered. It does the same thing when I try using any of the user accounts on the linuxbox.

WINDOWSDOMAINNAME\username
password

What should I do to get this connected ? I'm using mandrake 9.
 
Old 03-13-2003, 04:20 PM   #2
ranger_nemo
Senior Member
 
Registered: Feb 2003
Location: N'rn WI -- USA
Distribution: Kubuntu 8.04, ClarkConnect 4
Posts: 1,142

Rep: Reputation: 47
Did you smbpasswd?

smbpasswd -a username
 
Old 03-13-2003, 07:27 PM   #3
jamrock
Member
 
Registered: Jan 2003
Location: Kingston, Jamaica
Posts: 444

Rep: Reputation: 41
In other words, you need to add the user to the smbpasswd file as well as the passwd file.
 
Old 03-14-2003, 11:28 AM   #4
explorer
Member
 
Registered: Feb 2003
Posts: 229

Original Poster
Rep: Reputation: 34
Arrow session request failed

I've got the passwords setup. Now I can still see the samba server in the nethood and ping it by hostname, but I get a 'share doesn't exist' from windows clients when I try to map to the samba server. When I do a "smbcleint -L RALPH1 -N" I get a "session request to RALPH1 failed ( NOT LISTENING FOR CALLING NAME ), but when I do the same command using LOCALHOST, I get all of my share information for the server. RALPH1 is the netbios name in smb.conf .
 
Old 03-14-2003, 05:25 PM   #5
explorer
Member
 
Registered: Feb 2003
Posts: 229

Original Poster
Rep: Reputation: 34
Red face share password

After doing smbpasswd -a username I'm still not getting connected to the share from a windows client. It acts like it's looking in the Windows Domain database for the username not on the samba server. When it asks me for a username and password I put the username only in the top line. I click OK and after a few seconds the same username / password dialog pops back up with the username and password still in it, but now the Windows Domain name is in front of the user name. This is my first samba server installation so I'm a little slow....Shouldn't it be looking on the samba server for authentication instead of the Windows Domain ?.....
 
Old 03-14-2003, 09:15 PM   #6
jamrock
Member
 
Registered: Jan 2003
Location: Kingston, Jamaica
Posts: 444

Rep: Reputation: 41
Please post your smb.conf file.

You speak of mapping a drive. What happens when you click on the samba server in network neighbourhood?

Do you put in the user name and password specified in the smbpasswd file?

Quote:
This is my first samba server installation so I'm a little slow....
We all start out the same.
 
Old 03-16-2003, 04:12 AM   #7
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
if your windows clients are win2k and up you need to enable encrypted passwords on samba otherwise it won't login.
It sounds like you are running XP on the clients from your description?
If your clients are part of a domain that the samba server isn't then you might have to type in 'sambaserver\username' then the password otherwise it will check the domian controller
 
Old 03-16-2003, 06:26 PM   #8
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian 6+, CentOS 5+
Posts: 1,323

Rep: Reputation: 100Reputation: 100
there is also another possibility I was having a similar problem until someone told me to add and or change

create mode and directory mode

create mode = 0664

directory mode = 0775

after this modification it worked just fine no spitting password back

Alex
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connecting Windows XP client to Samba server srini2001 Linux - Networking 5 03-15-2006 10:25 AM
Problem connecting SAMBA to Windows 2003 Server Micro420 Linux - Networking 5 11-08-2005 04:53 PM
Samba (again!) and connecting to server cyclic Linux - Networking 2 03-18-2004 04:33 AM
Connecting Samba to Windows 2000 server domain subzero80 Linux - Networking 0 12-01-2003 06:35 PM
connecting to windows workgroup using samba? linoob Linux - Newbie 7 10-23-2002 09:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration