LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-10-2004, 06:10 AM   #1
Un0riginal
LQ Newbie
 
Registered: Jun 2004
Location: Leeds
Distribution: Suse 9.1
Posts: 5

Rep: Reputation: 0
Connecting from suse 9.1 to an XP box under a domain


Ok, this is my problem. (I have searched the forums and found nothing that helps me, however if I have missed something I apologise)

System: Suse 9.1

Using Konqueror I can browse to windows network and then to my domain, and then I can see all of the machines as you would expect. I can then connect to the PDC and BDC (running NT Server) fine and login as the admin (yes i have the rights not hacking :P), it then pops up showing all the available connections on that box. When I attempt to connect to my own XP box, or even any other users box it keeps coming back with the 'Authorization Dialog' box, not been one to give up very easily I looked up all the command line stuff and tried the command line mount approach. Using this command

"mount -t smbfs -o username=xxxx,password=xxxx //ipaddress/share /mountpoint"

it comes back with the errors

4634: session request to "ipaddress" failed (called name not present)
4634: session request to "first octect of ip address" failed (called name not present)

however when i check the mountpoint it has actually mounted it and I can browse to my hearts content. So i try this on my own XP box and instead I get this error

4666: session setup failed: ERRDOS - ERRnoaccess (Access denied.)

I have tried this with several different usernames to no avail. Any help would be most gratefully accepted.

just as an additional question .. .. whats the difference between smbfs and ntfs ? if I run the command with -t ntfs it comes back with the error

mount: special device //ipaddress/share does not exist

thanks in advace

Un0riginal
 
Old 06-10-2004, 07:01 AM   #2
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Not totally sure about this but worth a try.

I'm pretty sure the mount command "mount -t smbfs -o username=xxxx,password=xxxx //servername/share /mountpoint" should have the servername rather than ip address - at least that's how I always connect.

As regards you Windows workstations check on the permissions tab who you are giving access to for the shares you are trying to browse. It can either be individual users or something like domain members.

In my own setup my linux Samba server is the PDC but I share the Windows printer attached to my Win2k machine which logs on to my domain. To use that resource from linux the relevant bit from the linux printing manager was "smb://userassword@server/printer_share_name"

Sorry I can't be more specific but I'm at work and hence linuxless - I'll check it out tonight.

As regards the mount -t ntfs - that's for a ntfs drive on the machine you're running eg a windows partition.
 
Old 06-10-2004, 07:27 AM   #3
Un0riginal
LQ Newbie
 
Registered: Jun 2004
Location: Leeds
Distribution: Suse 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for the response ... The IP addy was used because I was trying several differnet machines and it was not working when I was attempting to use it to connect to my XP box, using the server name connecting to the PDC and BDC gets rid of the 2 errors it was bringing up, which totally baffles me because I would have thought (from my limited networking) that using either should have the same results (assuming DNS was working because we don't use WINS on our subnet)
 
Old 06-10-2004, 07:57 AM   #4
Un0riginal
LQ Newbie
 
Registered: Jun 2004
Location: Leeds
Distribution: Suse 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
New development using konquerer if the username is typed in as domain\username and then the password it works brilliantly, I can only assume that such a requrement is necessary for the command line as well .. anyone who already knows how to point it to authenticate to the domain? I will continue my search
 
Old 06-10-2004, 01:29 PM   #5
andrewdodsworth
Member
 
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
Glad it worked - Yast .. Network Services .. Samba client looks as though it wants to help you but PLEASE have a read of the help files first before you tick authenticate linux against NT network - you could end up locked out of your linux machine!

I tried something similar when playing around with an LDAP server before setting up users on it and thought at one stage I'd have to reinstall linux completely!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubles Internally Connecting to Domain spindley Linux - Networking 1 10-03-2005 11:27 AM
connecting to my linux samba domain spivy66 Linux - Newbie 4 04-15-2005 12:52 PM
Connecting Linux box to Internet through Windowx XP box over LAN pcd007 Linux - Networking 1 03-14-2004 09:02 AM
Connecting to a Win2K domain dptulk Linux - Networking 2 09-26-2003 12:11 PM
Connecting to a windows NT Domain Xetox Linux - Newbie 3 08-06-2003 03:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration