-   Linux - Networking (
-   -   Connect to Uni VPN on Acer Aspire One (

joe729605 09-22-2008 10:12 AM

Connect to Uni VPN on Acer Aspire One
Hey guys, this is my first post
I got an AA1 (running Linpus Lite & Firefox 3) for Uni and can't connect to the campus network. Obviously there's windows & mac installers but no info on linux!

It's a wired VPN,and I know the IP & the proxy settings needed. There was a connection package to install which I had to open with WINE, but whenever I ran this it would say that I wasn't connected to the network (even though the network connections manager recognised the wired connection).

I've tried a couple of things in the terminal (openvpn etc.) and looked around a few forums, but as this is my first Linux computer, I'm a little lost.

Sorry if this isn't enough information - ask and I'll add anything else you think might be relevant.
Any help would be greatly appreciated.
Thanks in advance

meggark 10-22-2008 05:10 AM

Is it the cisco VPN client that they provide for windows? If so you can use the vpnc client for linux.

Just run
$ sudo yum install vpnc
$ sudo mouspad /etc/vpnc/<myvpn>.conf

Enter the following:

IPSec gateway <my.vpn.gateway> (Your gateway IP or hostname)
IPSec ID <> (This is your group username)
IPSec secret <mysecret> (Your group password)
Xauth username <username> (your personal username)
Xauth password <password> (your personal password)

Save and close mousepad.


Unzip the file, cd into the directory that was created and copy tun.ko using

$ sudo cp tun.ko /lib/modules/

Run the Command

$sudo depmod

Plug in and connect to the network:

$sudo vpnc <myvpn>

This works for me on my wireless uni network.

plnnightsky 03-17-2009 09:46 AM

I have not been able to find anything with my searches and have no clue on how to do this.

I am trying figure out how to configure VPN tunnel to a MS firewall with PPTP with. I am lost as too what I need to install or how to configure it on Acer Aspire One running Linux.

Please point me in the correct direction.


_Nikolaus_ 03-27-2009 05:06 PM

MS VPN might need mppe-128
and you might need to refuse PAP and refuse CHAP in the file /etc/ppp/peers/your_new_connection_name (that leaves CHAP-V2 which is needed for mppe-128 as the only option iirc).

for complete instructions.

newer kernels include the module mppe-128, no need to compile them, but you need pptp-linux.

my working /etc/ppp/peers/name_of_connection (on a debian system connecting to a vanilla MS-box):

unit 10
ipparam name_of_connection
user xxxxxxx
pty "pptp --nolaunchpppd"

mru 1478
mtu 1478


Musta Lammas 09-18-2010 05:23 PM


Originally Posted by meggark (Post 3318452)
Just run
$ sudo yum install vpnc
$ sudo mouspad /etc/vpnc/<myvpn>.conf

I did this, and after the first line, Terminal told me there was nothing to do (already installed). Then, after the second line, I was told there is no such file or directory.

If I need to install something for Linpus Lite 1.0.3.E to connect to VPN, what is it?

Or did I type something wrong?

Thanks from the newbie...

All times are GMT -5. The time now is 09:01 AM.