-   Linux - Networking (
-   -   connect: Network is unreachable (

phahn 01-05-2008 12:48 PM

connect: Network is unreachable
I recently re-installed the operating system on my Dell Server, running RH Enterprise AS 3.0. Somehow, I lost connection to my local network (and thus the Internet). I tested eth0 from the system diagnostic CD and it is perfect. The ethernet wire from the upstairs office seems to be working fine (the LEDs on the Dell eth0 connection flash when I try to ping the Dell). But when I try to communicate from the Dell, I get the message "connect: Network is unreachable".

The Dell has a fixed IP address of I can ping this address successfully at the Dell and I can also ping the loopback address But, if I try to ping anything else, I get the message: "connect: Network is unreachable". And, of course, I can't ping the Dell from any other computer on the network. I successfully added using the route command and stopped and restarted the network using "ifdown eth0 " and "ifup eth0". But, then the routing table changes are automatically reset.

I tried everything useful that I could find in previous LinuxQuestions postings of a similar nature, but nothing helped.

Brian1 01-05-2008 05:30 PM

I am assuming it is eth0. Post contents of /etc/sysconfig/network-scripts/ifcfg-eth0
Output from the commands
/sbin/ifconfig -a
/sbin/route -n

Now is there a firewall or selinux enabled on the RHAS machine? If so disable them and try again.


phahn 01-05-2008 06:36 PM

Problem solved thanks to Brian
Hi Brian,

You saved the day. When I saw the contents of /etc/sysconfig/network-scripts/ifcfg-eth0 it was obvious what went wrong. The broadcast, netmask and network addresses were all wrong. I easily corrected them, stopped and restared the interface and I am back in business.

Many thanks,


Brian1 01-06-2008 11:53 AM

Glad to be of help.


All times are GMT -5. The time now is 12:20 PM.