LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-19-2004, 04:18 PM   #1
Mad Malc
Member
 
Registered: Jun 2004
Location: West Midlands UK
Distribution: Mint 2.1 with Kubuntu Desktop
Posts: 59

Rep: Reputation: 15
Conflict USB Modem/LAN Mandrake?


Hi all
This driving me nuts, I have a perfectly usable PC which I multiboot on and can connect to the internet with using both Mandrake since version 7.1 and W*ndows 98 onwards, but as soon as I put a LAN PCI card into the box, Mandrake assumes my internet connection is via LAN. The result is no internet connection. I have not yet got the LAN fully operational, I am extending my house and wish to connect 2 machines to share an internet connection.
My internet is via a restricted broadband 150kbps connection, and I wish to just use a simple cross over cable to make a 2 machine LAN and share the internet using a USB Alcatel 330 Modem, works perfectly well on a PC without a LAN PCI card installed..

Your suggestions/help would be appreciated.
If they do not entail more expenditure they will be even more welcome....

I thank members of this forum for solving an ASROCK K7S8X R3.0 problem on installing Linux to a PC using that motherboard, thanks to a forum member who passsed on your help.

So please can you help me out with this?

Mad Malc
 
Old 06-19-2004, 04:54 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
Don't know how it is in MDK 10, but in 9.2 in DrakGW allows to choose which interface is connected to the Internet. You should have the same in ver 10.
 
Old 06-19-2004, 05:20 PM   #3
Mad Malc
Member
 
Registered: Jun 2004
Location: West Midlands UK
Distribution: Mint 2.1 with Kubuntu Desktop
Posts: 59

Original Poster
Rep: Reputation: 15
Hi Mara
I do but have been faced with a failure to load eth0 on boot when using it, eth0 being duplicated which I do not begin to understand....
I have started again from Mandrake 7.1 through 8,9 and now 10 and still cannot crack it.
Mandrake seems to assume just because you have a LAN card installed you must be using a router,which I am not, to connect to the internet.
No matter what i do in the Mandrake control centre, I come unstuck, take out the LAN card no problem internet connection fine, (it's not the card I have 3 LAN cards). Once a card is installed no internet.
As I wish to use the LAN to share the internet I am not getting very far.

Mad Malc
 
Old 06-20-2004, 03:10 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
So I have one question now. Does your cable modem work as Ethernet card (ethX) or pppX? If the modem is eth0, when you insert the NIC, it (modem) may become eth1 (NIC driver will load earlier).

If that's true, this trick should work: Deconfigure internet. Insert NIC, configure it (not important how, static IP will be OK). Then plug the modem and configure it.

The thing is that you should be able to do it in the MDK Control Center. I can't tell you how to do it exactly, because I don't run MDK 10.
 
Old 06-27-2004, 04:11 AM   #5
Mad Malc
Member
 
Registered: Jun 2004
Location: West Midlands UK
Distribution: Mint 2.1 with Kubuntu Desktop
Posts: 59

Original Poster
Rep: Reputation: 15
Hi Mara,
Thanks for the suggestion I will give it a go.
Sorry for the late reply I have builders working on my house and lost my BT phone line for awhile.

Mad Malc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Interrupt conflict on boot with Xircom MiniPCI LAN/56K Modem jenna_h Linux - Laptop and Netbook 0 10-19-2005 07:59 PM
How to connect to LAN with USB modem? CWL Linux - Newbie 2 09-09-2005 12:52 PM
Fedora Core 2 with 2 M/C Lan (X over cable + USB Modem)? Mad Malc Fedora 3 06-27-2004 04:07 AM
Simple Xover LAN with Mandrake 10 and USB Modem problem? Mad Malc Mandriva 0 06-19-2004 04:46 PM
Mandrake 8.2, ESS 1876 and USB Hub Conflict dittigas Linux - Hardware 1 06-05-2002 10:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration