LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-30-2002, 10:23 PM   #1
santosh
LQ Newbie
 
Registered: Jul 2002
Posts: 3

Rep: Reputation: 0
configuring squid


Hi,

I have a Linux redhat 7.2 system running squid for proxy.I am new to linux so am not very familiar with the commands.I wanted to create an acl in the etc/squid/suid.conf file to block certain websites .After editing the file and saving...i am not able to restart the squid service now.

The squid restart/stop commands dont have any effect.

Do i need to reboot the server ?


Please help

Santosh
 
Old 07-30-2002, 11:39 PM   #2
sarin
Member
 
Registered: May 2001
Location: India, Kerala, Thrissur
Distribution: FC 7-10
Posts: 354
Blog Entries: 2

Rep: Reputation: 34
can you post what changes you made to the default config file?
--Sarin
 
Old 07-31-2002, 03:00 AM   #3
MartBrooks
Member
 
Registered: May 2002
Location: London
Distribution: Debian
Posts: 388

Rep: Reputation: 31
If squid is failing to restart, you most likely have a syntax error in your config file. Check the error log.

Regards
 
Old 07-31-2002, 08:22 AM   #4
turnip
Member
 
Registered: Jul 2002
Posts: 143

Rep: Reputation: 15
If you want to have a file you can add all the banned sites to other than the squid.conf file do this

make this the first acl

acl ads url_regex "/etc/ban"
http_access deny ads <-- that rule has to be above the localnet rule.

then create a file in /etc/ called ban
in it add the url's you want blocked

http://ads.doubleclick.net

and then just restart squid.
 
Old 07-31-2002, 08:35 AM   #5
SkahlaN355A
LQ Newbie
 
Registered: Jul 2002
Distribution: homebrew
Posts: 5

Rep: Reputation: 0
Just give the ipadres of your proxy on the gatway and on DNS. And after that write

ipchains -A forward -s <your netID with subnet like 192.168.10.0/0> -d 0.0.0.0/0 -j MASQ

you have to write this line every time your squid server reboots. or if u want permanent setting then write this line in ur /etc/sysconfig/ipchains file and restart the ipchain service.
i hope u solve your problem after this
 
Old 07-31-2002, 10:22 AM   #6
turnip
Member
 
Registered: Jul 2002
Posts: 143

Rep: Reputation: 15
Why masquerade a local network when he is using ap roxy server to get out on the net? And how does that block sites he doesnt want to see?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring squid as a cache only usmanmehmood Linux - Networking 1 10-03-2005 03:58 PM
Problem with configuring squid.... coolguy_iiit Linux - Networking 2 09-05-2005 06:55 AM
configuring squid Faizan Linux - Networking 1 05-05-2005 12:12 PM
Configuring Squid phatboyz Linux - Software 2 02-18-2004 07:39 AM
Configuring Squid with 2 Switches BonScott Linux - Networking 2 09-30-2003 08:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration