LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-15-2003, 10:50 PM   #1
spuzzzzzzz
Member
 
Registered: Sep 2003
Location: Australia
Distribution: Gentoo
Posts: 465

Rep: Reputation: 30
Unhappy configuring an isa ethernet card


I have an Intel EtherExpress 16 ISA ethernet card on an old 486 (the module for it is eexpress.o). Whenever I try to connect to the internet via adsl (using adsl-setup and adsl-start), the connection times out. If I watch the lights on the back of the ethernet card, I can see it flicker once or twice before it times out, so there is some activity going through. On boot, I get a few errors related to the ethernet card:

eexpress.c: Aoutoprobe not recommended: give io=xx
eth0: EtherExpress 16 at 0x300 (IRQ 5, AUI connector, 8-bit bus, 32k RAM)
.
.
.
Configuring eth0:
/sbin/ifconfig eth0 address 127.0.0.2 broadcast 127.0.0.255 netmask 255.255.255.0
SIOCSIFFLAGS: device or resource busy

I'm pretty sure my adsl-setup options are correct because i used the same options on my other PC and it worked fine

thanks,
Joe
 
Old 12-15-2003, 11:06 PM   #2
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,186

Rep: Reputation: 52
you might have to play with isapnptools.
the first error is the module trying to load, but desiring tohave the io port
given as an option. that may be set by a jumper on the card.
if you have windows on the machine, you might can look at what it's
settings for that card are.
 
Old 12-15-2003, 11:39 PM   #3
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
According to that message, it looks like your card is tied up somehow. However, the timeout might be crapping it out. Is your MTU (in Linux that would be mss, I guess) set to 1492? If you connect with PPPoE, there's an 8 bit header on every packet that needs to be sent along with, which lowers your max packet size from 1500. Some servers won't resize to accomodate because they have been set to reject ICMP requests, so they don't realize your packets are too large and they don't change their window. Not your machine's fault - just their paranoia. Its common, but not well noted. I don't know if I helped at all...
 
Old 12-15-2003, 11:42 PM   #4
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Quote:
Originally posted by whansard
you might have to play with isapnptools.
the first error is the module trying to load, but desiring tohave the io port
given as an option. that may be set by a jumper on the card.
if you have windows on the machine, you might can look at what it's
settings for that card are.
I hadn't thought of that. Good point. Is the card PNP? If yes, open all the jumpers and let the card be detected. Might be all it is.
 
Old 12-16-2003, 04:40 PM   #5
spuzzzzzzz
Member
 
Registered: Sep 2003
Location: Australia
Distribution: Gentoo
Posts: 465

Original Poster
Rep: Reputation: 30
I don't think the card is pnp, because pnpdump tells me "no cards found." Also, there are no jumpers on the card itself. Maybe this information will help (I got it from the manufacturer's website):
Interrupt levels
2, 3, 4, 5, 9, 10, 11

I/O address
16 settings over the range 200H-37Fh.

running "ifconfig eth0" tells me:
BROADCAST=MULTICAST
MTU=1500 (you were right, but i don't know how to change it)
Interrupt=5
Base Address=0x300 (is this related to I/O address?)
.
.
.
and a buch of other stuff related to IP address etc.

thanks for your help,
Joe
 
Old 12-16-2003, 04:50 PM   #6
spuzzzzzzz
Member
 
Registered: Sep 2003
Location: Australia
Distribution: Gentoo
Posts: 465

Original Poster
Rep: Reputation: 30
Oh wait, here's something else: ifconfig eth0 tells me that my interrupt is 5, but "cat /proc/interrupts" tells me that IRQ 5 is for my soundblaster sound card. Any idea how i would change one of the interrupts?
 
Old 12-18-2003, 01:46 AM   #7
spuzzzzzzz
Member
 
Registered: Sep 2003
Location: Australia
Distribution: Gentoo
Posts: 465

Original Poster
Rep: Reputation: 30
ok, I think I've made some progress. Using a DOS boot disk *shudder* and a utility from intel's web site, I changed the IRQ to 9 and the I/O address to 0x310. No more boot-up error messages I also set the card up with a 16-bit bus instead of 8-bit. However adsl-start still times out. Are there any other PPPoe/ADSL connection scripts I can try? Or anything else I can do? Any tests I can run?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!!! ISA Ethernet Card xenogear3 Debian 1 09-08-2005 07:19 PM
ISAPnP support for ISA ethernet card OmegaBlac Arch 3 11-18-2003 02:07 PM
How to Configuring Ethernet Card? gluelogic Linux - Newbie 1 03-16-2002 12:47 AM
Configuring an ISA Ethernet Card in Slackware 8.0 nojathna Linux - Networking 1 01-17-2002 11:52 PM
configuring sound card and ethernet card justlearning Linux - General 1 05-14-2001 02:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration