LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-10-2009, 05:43 AM   #1
poiuytrez
LQ Newbie
 
Registered: May 2009
Posts: 15

Rep: Reputation: 0
Question Configuration problem bind9 [ Solved ]


Hello,

I am trying to setup a dns server (which is also a webserver) on debian lenny.
bind just does not want to start. It seems that I made a mistake in the configs files. I do not have any more error messages...

This is my named.conf.local

zone "ooole.be" {
type master;
file "/etc/bind/db.ooole.be"
};

and this is my db.ooole.be file

$TTL 85000
@ IN SOA ns.ooole.be. hostmaster.ooole.be. (
2009061001
8H
2H
1W
1D )

@ IN NS ns.ooole.be.
www IN A 87.98.153.152


Thank you for you help.

Last edited by poiuytrez; 06-13-2009 at 12:23 AM.
 
Old 06-10-2009, 05:55 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,738

Rep: Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837
You miss a ";" at the end of the line "file "/etc/bind/db.ooole.be". It should be
Code:
file "/etc/bind/db.ooole.be";
You have also to add an A record for your dns, so your zone file should be:
Code:
$TTL 85000
@ IN SOA ns.ooole.be. hostmaster.ooole.be. (
2009061002
8H
2H
1W
1D )

@ IN NS ns.ooole.be.
www IN A 87.98.153.152
ns      IN A 87.98.153.152
Regards
 
Old 06-11-2009, 10:13 PM   #3
poiuytrez
LQ Newbie
 
Registered: May 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks man ! It seems to work !
 
Old 06-12-2009, 05:34 AM   #4
poiuytrez
LQ Newbie
 
Registered: May 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Bind works, but the DNS serveur does not work.
My registrar is correctly pointing on the dns server, but my dns server does not seems to work...
When I do a
nslookup www.oole.be
on my server, it works. But when I do it from outsite (at home), it does not work.
Do you have any suggestions or tools to help me debug this problem ?

Thanks.
 
Old 06-12-2009, 05:54 AM   #5
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,738

Rep: Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837
Quote:
My registrar is correctly pointing on the dns server, but my dns server does not seems to work...
Are you sure about that? Because as you can see from the following trace is seems that sdns1.ovh.net and r24786.ovh.net are authoritative for your domain.
Quote:
dig +trace oole.be

; <<>> DiG 9.6.1rc1 <<>> +trace oole.be
;; global options: +cmd
. 420885 IN NS B.ROOT-SERVERS.NET.
. 420885 IN NS D.ROOT-SERVERS.NET.
. 420885 IN NS J.ROOT-SERVERS.NET.
. 420885 IN NS I.ROOT-SERVERS.NET.
. 420885 IN NS F.ROOT-SERVERS.NET.
. 420885 IN NS L.ROOT-SERVERS.NET.
. 420885 IN NS A.ROOT-SERVERS.NET.
. 420885 IN NS K.ROOT-SERVERS.NET.
. 420885 IN NS H.ROOT-SERVERS.NET.
. 420885 IN NS C.ROOT-SERVERS.NET.
. 420885 IN NS E.ROOT-SERVERS.NET.
. 420885 IN NS M.ROOT-SERVERS.NET.
. 420885 IN NS G.ROOT-SERVERS.NET.
;; Received 272 bytes from 127.0.0.1#53(127.0.0.1) in 1 ms

be. 172800 IN NS a.ns.dns.be.
be. 172800 IN NS b.ns.dns.be.
be. 172800 IN NS c.ns.dns.be.
be. 172800 IN NS x.dns.be.
be. 172800 IN NS london.ns.dns.be.
be. 172800 IN NS prague.ns.dns.be.
be. 172800 IN NS brussels.ns.dns.be.
be. 172800 IN NS amsterdam.ns.dns.be.
;; Received 369 bytes from 193.0.14.129#53(K.ROOT-SERVERS.NET) in 106 ms

oole.be. 86400 IN NS sdns1.ovh.net.
oole.be. 86400 IN NS r24786.ovh.net.
;; Received 87 bytes from 194.0.1.10#53(x.dns.be) in 103 ms

;; Received 25 bytes from 213.251.188.140#53(sdns1.ovh.net) in 106 ms
 
Old 06-12-2009, 02:10 PM   #6
poiuytrez
LQ Newbie
 
Registered: May 2009
Posts: 15

Original Poster
Rep: Reputation: 0
The primary dns is r24786.ovh.net.
which is my server.
 
Old 06-12-2009, 03:17 PM   #7
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,738

Rep: Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837
According to your 1st post the NS record for oole.be is supposed to be ns.ooole.be, so you have to change that to r24786.ovh.net
And the main problem is that r24786.ovh.net is not reachable from the internet:
Quote:
dig oole.be @r24786.ovh.net

; <<>> DiG 9.6.0-P1 <<>> oole.be @r24786.ovh.net
;; global options: +cmd
;; connection timed out; no servers could be reached
If this is the named server you're trying to configure, then you must configure your firewall to allow dns queries (open tcp/udp port 53)

Regards
 
Old 06-12-2009, 03:22 PM   #8
poiuytrez
LQ Newbie
 
Registered: May 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Ok, when I try on the server
dig @87.98.153.183 www.oole.be
is does not work. But when I try
dig @127.0.0.1 www.oole.be
is works. But the firewall is not configured in debian by default, so I really don't see where it does not work.

Thanks.
 
Old 06-12-2009, 03:32 PM   #9
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,738

Rep: Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837Reputation: 1837
Could you please post /etc/named.conf, or at least the output of:
Code:
netstat -tuanp|grep 53
Maybe you have configured bind to listen only on the loopback interface.
 
Old 06-13-2009, 12:22 AM   #10
poiuytrez
LQ Newbie
 
Registered: May 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Thank you man,

You were right! I had to modify /etc/bind/named.conf.options
to add the line :

listen-on { 87.98.153.183; };

Now it works !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get bind9 configuration ok on Ubuntu 8.04 havan Linux - Networking 2 11-30-2008 02:08 PM
bind9: configuration: non-authoritative zone tilman1 Linux - Networking 3 05-11-2008 05:06 PM
Problem on starting BIND9 satimis Linux - Server 2 10-23-2007 06:27 AM
dns configuration using Bind9 and ubuntu aljohn123 Ubuntu 0 11-13-2006 10:47 PM
Bind9 problem WiWa Linux - Networking 3 06-06-2004 05:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration