-   Linux - Networking (
-   -   Cisco VPN Client ( and 2.6.24 Kernel (

revof11 03-07-2008 09:35 AM

Cisco VPN Client ( and 2.6.24 Kernel
I am currently have problems using the Cisco VPN Client for Linux ( vpnclient-linux-x86_64- and my 2.6.24 kernel ( It seems to have mixed results, but the most comment error I get is this:


[revof11@xfedora vpn]$ vpnclient connect workvpn
Cisco Systems VPN Client Version 4.8.01 (0640)
Copyright (C) 1998-2007 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Linux
Running on: Linux #1 SMP Tue Feb 26 14:21:30 EST 2008 x86_64
Config file directory: /etc/opt/cisco-vpnclient

Initializing the VPN connection.
The VPN sub-system is busy or has failed.

I installed using the following procedure (as root, obviously):


tar -zxvf vpnclient-linux-x86_64-
cd vpnclient
patch < cisco_skbuff_offset.patch
patch < vpnclient-linux-2.6.24-final.diff
vim Makefile
/etc/init.d/vpnclient_init restart
chmod 4111 /opt/cisco-vpnclient/bin/cvpnd/

When editing the Makefile I just change the CFLAGS variable in the Makefile to EXTRA_CFLAGS (it's on line 15 if you are using the same version of the Cisco VPN Client that I am).

The patches I'm using are from the following locations:
The strange thing is that, occasionally, if I reinstall it works perfect... but just once. Does anyone have any ideas on how to fix this or anything? It's pretty frustrating and I'd hate to have to revert back to the 2.6.22 kernel.

bsdunix 03-08-2008 09:56 AM

Have you tried enabling logging to see if there are clues? Open a second terminal window to start and watch the logging. The vpnlogfile name is user defined and is placed where the user wants it, /var/log/vpnlogfile would be a good suggestion.

# vi /etc/opt/cisco-vpnclient/vpnclient.ini
EnableLog=0 to EnableLog=1

# /etc/init.d/vpnclient_init restart
# /usr/local/bin/ipseclog /path/to/vpnlogfile &
# tail -f /path/to/vpnlogfile

Start VPN session on another terminal window

$ vpnclient connect workvpn

Return to the VPN logging terminal window and see
if there are any clues as to why the connection is failing

You say the connection works once, so I suspect the cisco_ipsec module is at fault. Restarting the vpnclient_init is supposed to remove and load the module.

alkos333 03-10-2008 12:10 AM

Try using vpnc - has been very successful for me (with 2.6.24 as well)

revof11 03-19-2008 07:12 AM

I was actually able to get it working with just a simple reboot. I'm not sure what the issue was, but that fixed it. I updated the kernel again (an even newer version) and the same thing fixed it.

Next time I'm going to try it with debug on after I recompile/reset it to see if I can figure out what is actually wrong.

NBU 03-20-2008 12:01 PM

VPN Clinet on Fedora Core 8 with kernel
Try to follow recommendations on this page:

heavywizard 02-12-2010 02:17 AM

Cisco doesn't connect
Hi everybody, anyone found a solution for this problem?

I've got the same problem, but I cannot connect ever, any suggestions please?


All times are GMT -5. The time now is 09:34 AM.