LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Change user@host.domain to user@domain (https://www.linuxquestions.org/questions/linux-networking-3/change-user%40host-domain-to-user%40domain-230040/)

Wynand1 09-13-2004 08:46 AM

Change user@host.domain to user@domain
 
Hi,

I'm using webmin to setup a mail server (sendmail). Currently our email addresses look like this : root@crew-ex.crewtech.co.za and we would like it too look like this root@crewtech.co.za.

How do I change this in webmin.

i.e we want not user@host.domain.

Thanks

r0b0 09-13-2004 08:48 AM

This is not a server setting, rather a setting of your e-mail client software. Set your e-mail address to yourname@crewtech.co.za in your e-mail client.
And configure sendmail to accept e-mail sent to crewtech.co.za for local delivery (I'm not a sendmail expert, don't know how).

Satriani 09-13-2004 09:33 AM

You can also use a feature in sendmail:

MASQ_ENVELOPE and MASQUARADE

http://www.sendmail.org/m4/masquerading.html

scowles 09-13-2004 09:37 AM

Re: Change user@host.domain to user@domain
 
Quote:

Originally posted by Wynand1
Hi,

I'm using webmin to setup a mail server (sendmail). Currently our email addresses look like this : root@crew-ex.crewtech.co.za and we would like it too look like this root@crewtech.co.za.

How do I change this in webmin.

i.e we want not user@host.domain.

Thanks

Personally, I don't use webmin. Nothing against it, but it has never supported setting all the sendmail specific parameters to "properly" configure the MTA.

If webmin supports setting "masquerade_as", then this would be the setting to change. If not... then adding:

MASQUERADE_AS(`mydomain.com')dnl

to your sendmail.mc file will fix your problem. Note: You must rebuild your sendmail.cf file after editing sendmail.mc using m4 or whatever tools your linux distro supplies (you never stated that in your post).

Pete M 09-13-2004 11:35 AM

Wynand1

Add crewtech.co.za to /etc/mail/local-host-names like this

/etc/mail/local-host-names
# local-host-names - include all aliases for your machine here.
crewtech.co.za

Restart Sendmail, should be good to go

Pete

scowles 09-13-2004 12:29 PM

Quote:

Originally posted by Pete M
Wynand1

Add crewtech.co.za to /etc/mail/local-host-names like this

/etc/mail/local-host-names
# local-host-names - include all aliases for your machine here.
crewtech.co.za

Restart Sendmail, should be good to go

Pete

Funny how the wording of ones post can be interpreted differently. I interpreted the OP question as referring to how to configure sendmail to change the mail from address for non fully qualified e-mail address i.e. masquerade - you the recipient address. i.e. what domains sendmail considers local (hand off to procmail)

Either way, I think he's covered

Pete M 09-13-2004 03:32 PM

Hi scowles

From Wynand1's first post I assumed from the email address 'root@crew-ex.crewtech.co.za' that 'crew-ex' is the hostname of his machine and 'crewtech.co.za' his FQDN, which does in fact resolve via DNS, so the easiest way to send mail as 'user@crewtech.co.za' is to add 'crewtech.co.za' to /etc/mail/local-host-names which makes Sendmail responsible for this domain

Quote:

i.e we want not user@host.domain
MASQUERADE_AS may well work for him, just never used it for this purpose

Pete

Wynand1 09-13-2004 11:56 PM

Thanks for all the input :)


All times are GMT -5. The time now is 09:38 PM.