-   Linux - Networking (
-   -   Change between 2G/3G modes on a USB stick modem. (Alcatel x220) (

masmddr 03-30-2011 06:43 AM

Change between 2G/3G modes on a USB stick modem. (Alcatel x220)

I have just bought a new netbook and now it runs ARCH linux.

To connect to the internet I am using an Alcatel x220 USB 3G modem dongle and wvdial (with pywvdial) and here is wvdial.conf

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
ISDN = 0
Modem = /dev/gsmmodem
Baud = 460800
Phone = *99#
Username = cellcom
Password = cellcom
Stupid Mode = 1
Init3 = AT+CGDCONT=1,"IP","internetg"

Everything works fine except it's seems to be locked into 2G mode.
Before I installed linux I tried the modem on windows, there I changed the modem to 2G mode only ( I do crazy things sometimes...) and I think the configuration was saved on the modem it self.
I searched google and found a lot of information of how to connect but nothing about switching between 3G and 2G.
The best solution would be to connect the modem to a windows box and change it ( or check if I'm even right) but I don't have one.

Arch Linux 2.6.37 and Gnome
Lenovo S10-3 Netbook
Alcatel x220 Modem using wvdial to connect

blesbok 04-26-2011 04:34 PM

zsnt modem
Do a search with Yahoo or Google using zsnt modem. Am no expert and looked into this matter thinking my connection issue had to do with the modem being in 3G mode where 2G would work better. What you'll see will resemble the lines below but I can't say what files are involved. Should you succeed, please tell what you did on this thread for the benefit of others.

AT+ZSNT=0,0,0 automatic
AT+ZSNT=1,0,0 2G only
AT+ZSNT=2,0,0 3G

masmddr 04-26-2011 05:29 PM

Thank you for your replay.

I tried doing a search about zsnt but all I could find was about ZTE modems.
I tried adding those as init lines in wvdial.conf but it kept returning "bad init line" errors.

So far the only way I found around this was to use MS windows to change between GSM/UMTS modes.

blesbok 04-27-2011 04:48 AM

AT commands seem to differ from modem to modem, at least when it comes to 2G/3G. Keep trying. Pardon my ignorance as I throw some links.

masmddr 04-27-2011 06:22 AM

I tried a lot of commands all with different forms (AT+BAND AT_BAND AT^BAND AT BAND ) but nothing.
The only AT command that did work was AT+CFUN which toggled on/off.

It seems we need someone who actually knows what they are doing, or someone who knows where to find Alcatel AT commands.
However I was right, changing the band mode in windows does persist on the modem when you connect to another computer/OS.

perazim 05-01-2011 03:17 AM

I am also using an Alcatel X220 modem.

I am trying to get NetworkManager/ModemManager on Fedora 14 to use it. Presently, it doesn't. I have found that NetworkManager is trying to connect using port ttyUSB3 when it should be using ttyUSB4. ttyUSB3 appears to be the port for sending/receiving smses and other commands.

I have posted this to the NetworkManager mailing list with no replies. It appears that there may be support issues with NetworkManager. Does anyone know anything about the internals of NetworkManager as it appears that it is simply a configuration table error?



All times are GMT -5. The time now is 10:10 PM.