-   Linux - Networking (
-   -   Certain Websites No Longer Working Correctly on Linux (

DJOtaku 02-24-2011 10:20 PM

Certain Websites No Longer Working Correctly on Linux
OK, I'm having an issue that's driving me nuts. I have not manually changed anything - that doesn't mean that something hasn't changed automatically via some tool or something.

Starting today I cannot log into on Linux. Whenever I try to login, it just takes forever and then either Chrome or Firefox tell me that perhaps the site no longer exists. It works perfectly fine on Windows. Strangely it also does not work on my Roku box and is working sporadically on my PS3. I would think it was my ISP or my router if it wasn't working perfectly fine on Windows.

I AM NOT TRYING TO WATCH NETFLIX ON LINUX. I know that doesn't work. I'm just trying to update my queue. I'm having this problem both on Fedora and Ubuntu (latest stable releases on both). I know it's not just loading from cache on my Windows machine because I'm going to pages that I have never been to and it's working just fine. Now, I have not tried signing out and in because then I'll be up a creak. OK, I installed another browser on my Windows computer and I'm able to sign into Netflix just fine. So it's not a sign-in issue.

WHY DOES THIS WORK ON WINDOWS? It's the same browsers - Chrome and Firefox on Linux and Windows and the same network.

ALSO, flickr is not working correctly - I cannot make any comments in the discussions (but can on photos which is ajax-y).

ANYTHING to keep me from further tearing my hair out would be greatly appreciated,


update: also checked a Linux computer using Linux Mint that hasn't been turned on in 2 months. I know it was able to access Netflix back then. Nothing has been changed - not even updates. It also cannot access Netflix. Either taking forever to load or when trying to login.

via looking in Konqueror, I saw it's trying to go and that's what makes it so that I cannot connect to if it considers me to be signed in. And here's what Konqueror said:

The requested operation could not be completed
Connection to Server Closed Unexpectedly
Details of the Request:
Protocol: http
Date and Time: Thursday, February 24, 2011 22:56
Additional Information:
Although a connection was established to, the connection was closed at an unexpected point in the communication.
Possible Causes:
There may have been a problem with your network connection.
There may have been a problem at some point along the network path between the server and this computer.
A protocol error may have occurred, causing the server to close the connection as a response to the error.
Possible Solutions:
Try again, either now or at a later time.
Contact the administrator of the server for further assistance.
Contact your appropriate computer support system, whether the system administrator, or technical support group for further assistance.

RockDoctor 02-25-2011 07:15 AM

Have you tried using Firefox's User Agent Switcher addon to id your browser as IE?

DJOtaku 02-25-2011 08:34 AM

While I have not tried that it would not make sense for the following reasons:

1) On my Windows computer I am not using IE. I am using Firefox and Chrome (and it works!)
2) How would I do that on my PS3 and Roku and BluRay Player? (Which were all working and no longer are)

In other words, it appears that it is something different about the way Windows handles networking vs everything else in my house.

DJOtaku 02-25-2011 09:30 PM


Still doesn't work on Linux. Tried on another Linux computer - my laptop and it still doesn't work. Also, Roku still doesn't work. PS3 spontaneously started working.

Did a wireshark on my main Linux computer - I got a packet being sent over and over again. So something's up with the TCP. That's as far as I can figure it out. Still convinced it's not a Linux issue since the Roku box is also affected (or maybe that runs Linux underneath everything).

Not quite sure why everything should work fine and dandy on Windows.

Reset my modem all the way (including pushing the little button in the back) but that didn't do anything.

Technician had me run

service nscd restart
(Well, he wanted me to run ipconfig /fushdns and that was the Linux equiv)

I'm thinking Windows TCP/IP stack ignores these dropped packets.

I'm not sure if it's 100% related, but Kopete seems to go nuts and take over my whole computer and that started about the same time as all this. Within Kopete I have it authorized to AIM, MSN, Facebook, and Gmail.

DJOtaku 02-25-2011 09:35 PM

took another look at the TCP dump. Her's what jumps out at me:

The first 15 entries take 0.297 units of time. After that it gets [TCP Dup ACK 11#1] and then it gets larger and larger until 56.54 units of time. At that point I see TLSv1 Encrypted Alert. Then it goes until 467.2 units of time and the web page has timed out.

flickr posting to or deleting entries in conversation posts is not working - it keeps timing out
netflix - still cannot login - it times out (at one point early in things yesterday I was able to login but everything looked funky. After that I lost the ability to login)
on Firefox - Facebook - cannot post anything to wall - it times out

Verizon currently has a technician working on it after I exhausted all the help they could give on the phone

DJOtaku 02-26-2011 09:34 AM

Update: Installed a fresh Fedora install on a Virtualbox VM in the Windows computer. This still did not work with the netflix website. (logging in) So it's not like my router was favoring the windows NIC or something. Also tried VM in Linux with no different results.

DJOtaku 02-26-2011 09:44 AM

Update: Twitter does not work either. Basically, anything with authentication isn't working. This is maddening!

jefro 02-26-2011 06:38 PM

Wonder if your dns is not correctly using www or not www or even the actual sites? Guess you could test that with a hosts file or double check that your dns is same on all boxes.

nsloolup or other commands to test also maybe dig.

DJOtaku 02-26-2011 07:26 PM

This is my resolve.conf:


# Generated by NetworkManager
search mushroomkingdom
nameserver is my broadband router/modem. On my windows computer, where it's working I have as my DNS server. So I think that's probably fine. But let me know if something looks weird.



Non-authoritative answer:

Probably working OK. I think it's somehow dropping packets or getting duped or something.From what I can tell from wireshark.

jefro 02-26-2011 10:13 PM

This was the www deal.

I'd also add in your ISP's addresses also. It could be your router flaking out for some odd reason.

soplin 02-26-2011 11:45 PM

Yes certain websites still don't support Gnu Linux. It's a Windows world being served by mostly Gnu Linux servers. Game sites are notorious for this lack of support.

The problem you have seems to be dns/resolv.conf. The is provided as the dns and it sometimes will work very slowly or not at all with some ISPs for some reason. The previous ISP I had worked even if the dns was the same as the gateway while the new one does not work, except of course on Windows. This was fixed by manually putting in resolv.conf the name servers available on router via gateway ip.

Go to and jot down or copy paste the DNS name servers and place them in the resolv.conf file. To make them permanent, the following link provides the howto.

Does anybody know what is "the some reason" causing this?

DJOtaku 02-27-2011 10:39 AM

I went ahead and added in the name servers listed on my router's page. No luck. I also added the router's gateway as a nameserver - no luck there either.

DJOtaku 02-27-2011 10:42 AM

1 Attachment(s)
Attached is a screenshot of a failed attempt to get to the netflix site after signing in.

DJOtaku 02-27-2011 10:53 AM

More info:
It looks like my router is asking which IP address goes with my MAC address every 42 seconds. (ARP) Is that normal or does the router seem to be unable to remember my computer? Combined with my previously attached screenshot, does that give any clues as to what may be going on?

DJOtaku 02-27-2011 10:55 AM


Originally Posted by jefro (Post 4272508)
This was the www deal.

I'd also add in your ISP's addresses also. It could be your router flaking out for some odd reason. comes up with a different IP address every time:


$ nslookup

Non-authoritative answer:      canonical name =

$ nslookup

Non-authoritative answer:      canonical name =

$ nslookup

Non-authoritative answer:      canonical name =

All times are GMT -5. The time now is 12:13 PM.