Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 10-24-2016, 02:12 PM   #1
LQ Newbie
Registered: Oct 2016
Posts: 2

Rep: Reputation: Disabled
Centos 7 Ethernet Driver Issues (e1000e)

I just recently installed Centos 7 on my desktop with an Asrock z97 extreme4 motherboard. The LAN port is an Intel I218V. I am using intel's provided driver e1000e for device communication. The issue I am having is when I first start my network the speeds are perfect, but after a minute or two the speed reduces drastically and usually just stops. If I simply issue 'service network restart' then the network comes back up fast then goes back to a crawl. I've used nethogs and the speed gets down to 0.02kb/s or lower. I've tried different versions of the driver, I have set up a static ip and used google's dns and specified the gateway. I am not sure what else to try.
Old 10-24-2016, 03:37 PM   #2
LQ Guru
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,831
Blog Entries: 15

Rep: Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669Reputation: 1669
Did you ADD a driver or was it the one you got with the installation? Typically it will configure your network devices based on what it discovers during installation so adding a driver isn't necessary.

If you run 'ethtool <interface>' what does it show you? A lot of NICs default to "auto-negotiate" which could be an issue if the other side is negotiating down. You can actually hard set the speed and duplex with ethtool from command line (and make it do it persistently across reboots by adding settings to the ifcfg-<interface> file in /etc/sysconfig/network-scripts.

I have seen issues with interfaces negotiating down to something like 10MB/half duplex causing issues like the one you describe on servers when the cable between it and the switch was flaky. Usually replacing the cable solved the issue.

Last edited by MensaWater; 10-25-2016 at 09:53 AM.
Old 10-24-2016, 03:59 PM   #3
LQ Newbie
Registered: Oct 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
At first it was using the packaged driver provided by Centos 7 but I added the same driver later on thinking maybe the package was corrupt. I've ran the ethtool -i command to verify the driver and the version but didn't realize I could set the negotiation using that command. I want to bet that is the issue as I am running a gigabyte connection on a max connection speed of 22 mb/s. I will let you know what the output is.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i install e1000e-3.0.4 driver permanently in Centos 6.5 ? sargurus Linux - Software 5 04-28-2014 01:42 PM
e1000 and e1000e not working Ethernet... dashang.trivedi Linux - Kernel 5 11-09-2011 11:25 PM
Ethernet e1000e(on PCI express) driver - with kernel 2.2.12, please help... vico3000 Programming 1 11-22-2009 08:02 AM
LXer: When Linux does well: the e1000e Ethernet bug fixed LXer Syndicated Linux News 0 10-06-2008 09:30 PM
CentOS 5.2 Linux Kernel 2.6.18-92.1.10.el5 - Cannot Load e1000e driver jreige Linux - Hardware 1 09-18-2008 12:57 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:26 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration