-   Linux - Networking (
-   -   Can't transfer a file to a server (

eantoranz 08-24-2012 11:10 AM

Can't transfer a file to a server

I'm trying to get a tgz from my host to a remote server. Both are linux boxes... the server has a rather dated ubuntu but it's been running fine.

Methods I have tried:
- scp from my host to the server
- scp from the server to my host
- ftp from my host to the server (passive, active)
- ftp from the server to my host (passive, active)
- I just tried netcat

I only get to transfer a small part of the file and then I see no more advance in the process.... this is rather unusual, if you ask me. What could be the problem?

Thanks in advance.

eantoranz 08-24-2012 11:23 AM

Well.... this is the first time ever I've had to do this.... just as an easy attempt, I changed the MTU of the interface from 1500 to 1000 and the file is moving forward.... let's see if the files does go up completely.


ifconfig eth0 mtu 1000

Ser Olmy 08-24-2012 11:39 AM

If you have to reduce the MTU to transfer a file, there's something wrong with a router, switch, NIC or driver.

Are these systems on the same network?

szboardstretcher 08-24-2012 11:42 AM

I was going to suggest checking the NIC. But Ser Olmy is correct. It could be any device between you and it.

If you are in an emergency, and have access, it might help to use a USB stick for the moment.

Alternately, you could break the file up into pieces and send it that way.

eantoranz 08-24-2012 11:55 AM

It's a VPN so not in the same network geographically.

eantoranz 08-24-2012 12:02 PM

Just told local network admin... let's see what goes on with that. Thanks for your help.

eantoranz 08-24-2012 12:10 PM

Is it possible to set the mtu with sysctl? Or how can I set the default mtu for a given interface (so that when the box starts, the interface has the mtu set correctly)?

All times are GMT -5. The time now is 08:48 AM.